community/texstudio to 2.12.6-4

This commit is contained in:
Kevin Mihelich 2017-12-01 14:46:17 +00:00
parent 090cd09a60
commit 86a093c972
2 changed files with 17 additions and 2 deletions

View file

@ -6,9 +6,9 @@
pkgname=texstudio pkgname=texstudio
pkgver=2.12.6 pkgver=2.12.6
pkgrel=2 pkgrel=4
pkgdesc="Integrated writing environment for creating LaTeX documents" pkgdesc="Integrated writing environment for creating LaTeX documents"
arch=('i686' 'x86_64') arch=('x86_64')
url="http://texstudio.sourceforge.net/" url="http://texstudio.sourceforge.net/"
license=('GPL') license=('GPL')
depends=('poppler-qt5' 'qt5-svg' 'qt5-script' 'libxkbcommon-x11' 'hicolor-icon-theme') depends=('poppler-qt5' 'qt5-svg' 'qt5-script' 'libxkbcommon-x11' 'hicolor-icon-theme')
@ -18,14 +18,17 @@ optdepends=('evince: pdf reader'
replaces=('texmakerx') replaces=('texmakerx')
source=("hg+http://hg.code.sf.net/p/texstudio/hg#tag=${pkgver}" source=("hg+http://hg.code.sf.net/p/texstudio/hg#tag=${pkgver}"
fs54269.patch fs54269.patch
fs56433.patch
texstudio-debughelper-arm-fix.patch) texstudio-debughelper-arm-fix.patch)
sha512sums=('SKIP' sha512sums=('SKIP'
'247e85f668b06c8a2def4e7456f0ddc8d35c7990484c1c037f7cf43fdee91419b5df66e968ef1e0c637fe685722bbad9171bdd79fad7a10912ae329aff088b68' '247e85f668b06c8a2def4e7456f0ddc8d35c7990484c1c037f7cf43fdee91419b5df66e968ef1e0c637fe685722bbad9171bdd79fad7a10912ae329aff088b68'
'3c5df094564c0d4a2ad09ea408eb129f723bded6c274f5ceb695f0672cbcbf2dab57edf86232e4bf302bec9c0f049ca0a11845b4bf9dfb37023494ed279ff9a9'
'dcb5ce7cd3e83fc221903fa895e6c428c54ada7468e74bb0a3e6bfac01c9e9575e4780d300b67f44064f2d25e10dd1aef531b847cdee71fbfbe7337808a0c8f4') 'dcb5ce7cd3e83fc221903fa895e6c428c54ada7468e74bb0a3e6bfac01c9e9575e4780d300b67f44064f2d25e10dd1aef531b847cdee71fbfbe7337808a0c8f4')
prepare() { prepare() {
cd hg cd hg
patch -Np1 < "${srcdir}"/fs54269.patch patch -Np1 < "${srcdir}"/fs54269.patch
patch -Np1 < "${srcdir}"/fs56433.patch
patch -p1 -i ../texstudio-debughelper-arm-fix.patch patch -p1 -i ../texstudio-debughelper-arm-fix.patch
} }

View file

@ -0,0 +1,12 @@
diff -r 184eb474c083 grammarcheck.cpp
--- a/grammarcheck.cpp Sun Nov 26 21:13:19 2017 +0100
+++ b/grammarcheck.cpp Fri Dec 01 15:23:55 2017 +0100
@@ -898,7 +898,7 @@
}
triedToStart = true;
startTime = 0;
- if (ltPath == "" || !QFileInfo(ltPath).exists()) return;
+ if (ltPath == "") return;
javaProcess = new QProcess();
connect(javaProcess, SIGNAL(finished(int)), javaProcess, SLOT(deleteLater()));
connect(this, SIGNAL(destroyed()), javaProcess, SLOT(deleteLater()));