mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/js185 to 1.0.0-2.1 (#541)
This commit is contained in:
parent
889183b65a
commit
86eddfd9a9
2 changed files with 82 additions and 3 deletions
|
@ -3,10 +3,11 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix mozilla stupidity
|
||||
# - patch to fix mozilla stupidity
|
||||
|
||||
pkgname=js185
|
||||
pkgver=1.0.0
|
||||
pkgrel=2
|
||||
pkgrel=2.1
|
||||
pkgdesc="JavaScript interpreter and libraries (legacy)"
|
||||
arch=(i686 x86_64)
|
||||
url="https://developer.mozilla.org/En/SpiderMonkey/1.8.5"
|
||||
|
@ -15,9 +16,10 @@ depends=(nspr gcc-libs)
|
|||
makedepends=(python2 zip)
|
||||
options=(!staticlibs)
|
||||
source=(http://ftp.mozilla.org/pub/mozilla.org/js/$pkgname-$pkgver.tar.gz
|
||||
ihatemozilla.patch)
|
||||
ihatemozilla.patch no-neon.patch)
|
||||
md5sums=('a4574365938222adca0a6bd33329cb32'
|
||||
'9add35f52965e4643b9235307d0d6cc5')
|
||||
'9add35f52965e4643b9235307d0d6cc5'
|
||||
'5d4817fadff71765c9b5d1f7b90f904f')
|
||||
|
||||
build() {
|
||||
cd js-1.8.5/js/src
|
||||
|
@ -26,6 +28,7 @@ build() {
|
|||
unset CPPFLAGS
|
||||
|
||||
patch -p3 -i "$srcdir/ihatemozilla.patch"
|
||||
patch -p3 -i "$srcdir/no-neon.patch"
|
||||
|
||||
./configure --prefix=/usr --with-system-nspr \
|
||||
--enable-threadsafe
|
||||
|
|
76
community/js185/no-neon.patch
Normal file
76
community/js185/no-neon.patch
Normal file
|
@ -0,0 +1,76 @@
|
|||
diff -urN a/js/src/configure b/js/src/configure
|
||||
--- a/js/src/configure 2011-03-31 13:08:36.000000000 -0600
|
||||
+++ b/js/src/configure 2014-02-05 15:19:39.915096224 -0700
|
||||
@@ -10603,72 +10603,6 @@
|
||||
|
||||
esac
|
||||
|
||||
-echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:10608: checking for ARM SIMD support in compiler" >&5
|
||||
-cat > conftest.$ac_ext <<EOF
|
||||
-#line 10610 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm("uqadd8 r1, r1, r2");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:10617: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
-echo "$ac_t"""$result"" 1>&6
|
||||
-if test "$result" = "yes"; then
|
||||
- cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_SIMD 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_SIMD=1
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:10638: checking for ARM NEON support in compiler" >&5
|
||||
-_SAVE_CFLAGS="$CFLAGS"
|
||||
-if test "$GNU_CC"; then
|
||||
- # gcc needs -mfpu=neon to recognize NEON instructions
|
||||
- CFLAGS="$CFLAGS -mfpu=neon -mfloat-abi=softfp"
|
||||
-fi
|
||||
-cat > conftest.$ac_ext <<EOF
|
||||
-#line 10645 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm("vadd.i8 d0, d0, d0");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:10652: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
-echo "$ac_t"""$result"" 1>&6
|
||||
-if test "$result" = "yes"; then
|
||||
- cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_NEON=1
|
||||
-fi
|
||||
-CFLAGS="$_SAVE_CFLAGS"
|
||||
-
|
||||
-
|
||||
case "$target_os" in
|
||||
darwin*)
|
||||
USE_PTHREADS=1
|
Loading…
Reference in a new issue