mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/icedtea-web-java7 to 1.4-2
This commit is contained in:
parent
f098d7a630
commit
8703310753
2 changed files with 62 additions and 3 deletions
|
@ -7,14 +7,16 @@
|
|||
pkgbase=icedtea-web-java7
|
||||
pkgname=('icedtea-web-java7' 'icedtea-web-java7-doc')
|
||||
pkgver=1.4
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://icedtea.classpath.org/wiki/IcedTea-Web"
|
||||
license=('GPL2')
|
||||
makedepends=('jdk7-openjdk' 'zip' 'libxtst' 'npapi-sdk' 'rhino' 'junit' 'chromium' 'epiphany')
|
||||
noextract=${pkgbase/-java7/}-$pkgver.tar.gz # due to broken path names in the tarball that fails with LANG=C in our chroot
|
||||
source=(http://icedtea.classpath.org/download/source/${pkgbase/-java7/}-$pkgver.tar.gz)
|
||||
sha256sums=('e53a41fa132e086fa8d17cadf1e7e38cb3ab99577277949fbcae4ab8705245fb')
|
||||
source=(http://icedtea.classpath.org/download/source/${pkgbase/-java7/}-$pkgver.tar.gz
|
||||
openjdk-hotfix.patch)
|
||||
sha256sums=('e53a41fa132e086fa8d17cadf1e7e38cb3ab99577277949fbcae4ab8705245fb'
|
||||
'1bf96e430d0694c53539e4e7a8c979c65a2ab5274d8ae38067b0fd7dd5bfba03')
|
||||
|
||||
_javaver=7
|
||||
_jvmdir=/usr/lib/jvm/java-${_javaver}-openjdk
|
||||
|
@ -25,6 +27,7 @@ build() {
|
|||
LANG=en_US.UTF-8 bsdtar -x -f ${srcdir}/${pkgbase/-java7/}-$pkgver.tar.gz
|
||||
|
||||
cd "${srcdir}"/icedtea-web*
|
||||
patch -Np1 < $srcdir/openjdk-hotfix.patch
|
||||
./configure --prefix=${_jvmdir} \
|
||||
--datarootdir=/usr/share \
|
||||
--with-jdk-home=${_jvmdir} \
|
||||
|
|
56
extra/icedtea-web-java7/openjdk-hotfix.patch
Normal file
56
extra/icedtea-web-java7/openjdk-hotfix.patch
Normal file
|
@ -0,0 +1,56 @@
|
|||
diff -r 1a327a09262e netx/net/sourceforge/jnlp/runtime/Boot.java
|
||||
--- a/netx/net/sourceforge/jnlp/runtime/Boot.java Mon Jun 10 13:22:53 2013 +0200
|
||||
+++ b/netx/net/sourceforge/jnlp/runtime/Boot.java Wed Jun 19 10:32:32 2013 +0200
|
||||
@@ -35,6 +35,8 @@
|
||||
import net.sourceforge.jnlp.cache.UpdatePolicy;
|
||||
import net.sourceforge.jnlp.security.viewer.CertificateViewer;
|
||||
import net.sourceforge.jnlp.services.ServiceUtil;
|
||||
+import sun.awt.AppContext;
|
||||
+import sun.awt.SunToolkit;
|
||||
|
||||
/**
|
||||
* This is the main entry point for the JNLP client. The main
|
||||
@@ -113,6 +115,9 @@
|
||||
* Launch the JNLP file specified by the command-line arguments.
|
||||
*/
|
||||
public static void main(String[] argsIn) {
|
||||
+ if (AppContext.getAppContext() == null) {
|
||||
+ SunToolkit.createNewAppContext();
|
||||
+ }
|
||||
args = argsIn;
|
||||
|
||||
if (null != getOption("-viewer")) {
|
||||
diff -r 1a327a09262e netx/net/sourceforge/jnlp/runtime/JNLPRuntime.java
|
||||
--- a/netx/net/sourceforge/jnlp/runtime/JNLPRuntime.java Mon Jun 10 13:22:53 2013 +0200
|
||||
+++ b/netx/net/sourceforge/jnlp/runtime/JNLPRuntime.java Wed Jun 19 10:32:32 2013 +0200
|
||||
@@ -234,7 +234,7 @@
|
||||
try {
|
||||
UIManager.setLookAndFeel(UIManager.getSystemLookAndFeelClassName());
|
||||
} catch (Exception e) {
|
||||
- // ignore it
|
||||
+ e.printStackTrace();
|
||||
}
|
||||
|
||||
doMainAppContextHacks();
|
||||
diff -r 1a327a09262e plugin/icedteanp/java/sun/applet/PluginMain.java
|
||||
--- a/plugin/icedteanp/java/sun/applet/PluginMain.java Mon Jun 10 13:22:53 2013 +0200
|
||||
+++ b/plugin/icedteanp/java/sun/applet/PluginMain.java Wed Jun 19 10:32:32 2013 +0200
|
||||
@@ -72,6 +72,8 @@
|
||||
import java.net.ProxySelector;
|
||||
import java.util.Enumeration;
|
||||
import java.util.Properties;
|
||||
+import sun.awt.AppContext;
|
||||
+import sun.awt.SunToolkit;
|
||||
|
||||
import net.sourceforge.jnlp.config.DeploymentConfiguration;
|
||||
import net.sourceforge.jnlp.runtime.JNLPRuntime;
|
||||
@@ -94,6 +96,9 @@
|
||||
*/
|
||||
public static void main(String args[])
|
||||
throws IOException {
|
||||
+ if (AppContext.getAppContext() == null) {
|
||||
+ SunToolkit.createNewAppContext();
|
||||
+ }
|
||||
if (args.length != 2 || !(new File(args[0]).exists()) || !(new File(args[1]).exists())) {
|
||||
System.err.println("Invalid pipe names provided. Refusing to proceed.");
|
||||
System.exit(1);
|
Loading…
Reference in a new issue