Merge pull request #913 from davidbeauchamp/master

community/lmms to 1.0.3-1
This commit is contained in:
David Beauchamp 2014-07-22 11:57:40 -06:00
commit 871a830a61
2 changed files with 5 additions and 32 deletions

View file

@ -8,7 +8,7 @@
# - remove wine makedepend, no vst
pkgname=lmms
pkgver=1.0.2
pkgver=1.0.3
pkgrel=1
pkgdesc='The Linux MultiMedia Studio.'
arch=('i686' 'x86_64')
@ -25,16 +25,16 @@ conflicts=('lmms-extras')
options=('!makeflags')
install=lmms.install
source=("${pkgname}-${pkgver}-src.tar.bz2::http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}-src.tar.bz2/download"
lmms-1.0.2-build-fix.patch
lmms-1.0.3-build-fix.patch
zynaddsubfx_unlink.patch)
md5sums=('db1c3e432cad933c9fd124c4840c0bf1'
'2ff166311a02cf6220dda5cac660528a'
md5sums=('1f63ad9abd1781206d852e79b2191638'
'fa8ab5c48b021b87f80444440479190a'
'd2ea78ac0cf2979505f140c6845617cf')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -Np1 -i ../lmms-1.0.2-build-fix.patch
patch -Np1 -i ../lmms-1.0.3-build-fix.patch
patch -Np1 -i ../zynaddsubfx_unlink.patch
}

View file

@ -1,30 +1,3 @@
From ab55b26e4b1521e5401f60a2f618f31579e9cc5c Mon Sep 17 00:00:00 2001
From: Tobias Doerffel <tobias.doerffel@gmail.com>
Date: Sat, 5 Jul 2014 17:46:10 +0200
Subject: [PATCH] SWH/BodeShifterCV: fix out-of-bounds array access
The xcoeffs array only has 100 elements and thus accessing xcoeffs[100]
leads to undefined behaviour.
---
plugins/LadspaEffect/swh/bode_shifter_cv_1432.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
index 41fb4f0..967edf6 100644
--- a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
+++ b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
@@ -247,7 +247,7 @@ static void runBodeShifterCV(LADSPA_Handle instance, unsigned long sample_count)
/* Perform the Hilbert FIR convolution
* (probably FFT would be faster) */
hilb = 0.0f;
- for (i = 0; i <= NZEROS/2; i++) {
+ for (i = 0; i < NZEROS/2; i++) {
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
}
--
1.9.3
From f91925f34aa1ee8ecacb12b8c4943c7e8aaabbfe Mon Sep 17 00:00:00 2001
From: Rafael Ruggiero <rafael46w@gmail.com>
Date: Tue, 15 Jul 2014 17:41:07 -0300