diff --git a/scripts/pkgverchecker b/scripts/pkgverchecker
new file mode 100755
index 000000000..1fa0a7b89
--- /dev/null
+++ b/scripts/pkgverchecker
@@ -0,0 +1,16 @@
+# This is a simple package version checker (for now)
+#
+# So far it only lists the names and versions of packages in ABS.
+# Planned is to grab repository pkgvers, then ABS vers, and only
+# output the differences, i.e. what packages need to be upgraded.
+
+ABSDIR=/build/abs
+
+cd $ABSDIR/$1
+
+for i in `find . -maxdepth 1 -mindepth 1 -type d`; do
+   cd $ABSDIR/$1/$i > /dev/null 2>&1
+   grep pkgname= PKGBUILD | sed -e 's/pkgname=//'
+   grep pkgver= PKGBUILD | sed -e 's/pkgver=//'
+   echo ""
+done