mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/rust to 1.58.0-1
This commit is contained in:
parent
de0b9d0bf9
commit
8786b6ad63
4 changed files with 16 additions and 16 deletions
|
@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index d4875cfe1b06..798c45506373 100644
|
||||
index 09ea84a083eb..4b18e6363bce 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -1004,7 +1004,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
@@ -1002,7 +1002,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||
let dirent = dirent.expect("read dir entry");
|
||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
|||
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index fdedb7e6a4af..c12568e77d83 100644
|
||||
index ab3c122053c5..b2f24480e43a 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -1512,7 +1512,7 @@ pub fn parse_target_triple(
|
||||
@@ -1552,7 +1552,7 @@ pub fn parse_target_triple(
|
||||
early_error(error_format, &format!("target file {:?} does not exist", path))
|
||||
})
|
||||
}
|
||||
|
@ -50,10 +50,10 @@ index 165505ee7313..00a7f5c2f8c1 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index 273221360b8b..4bbfad8441f3 100644
|
||||
index 0d49c7f6ee8b..d702aa9a746b 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -2296,6 +2296,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
@@ -2380,6 +2380,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
Ok(TargetTriple::TargetPath(canonicalized_path))
|
||||
}
|
||||
|
||||
|
@ -70,11 +70,11 @@ index 273221360b8b..4bbfad8441f3 100644
|
|||
///
|
||||
/// If this target is a path, the file name (without extension) is returned.
|
||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
index 085079e06e57..2dfa6a040b10 100644
|
||||
index c2484f2d8f66..bfda13509939 100644
|
||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
@@ -11,7 +11,7 @@ pub fn target() -> Target {
|
||||
SanitizerSet::ADDRESS | SanitizerSet::LEAK | SanitizerSet::MEMORY | SanitizerSet::THREAD;
|
||||
@@ -14,7 +14,7 @@ pub fn target() -> Target {
|
||||
| SanitizerSet::THREAD;
|
||||
|
||||
Target {
|
||||
- llvm_target: "x86_64-unknown-linux-gnu".to_string(),
|
||||
|
|
|
@ -9,7 +9,7 @@ We don't ship rust-lld.
|
|||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
index 4c954a1e567c..f1d5fbf83748 100644
|
||||
index 24e9c6251699..daf18c52a470 100644
|
||||
--- a/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
@@ -99,8 +99,7 @@ pub fn options() -> TargetOptions {
|
||||
|
|
|
@ -17,13 +17,13 @@ highmem=1
|
|||
pkgbase=rust
|
||||
pkgname=(rust rust-src)
|
||||
epoch=1
|
||||
pkgver=1.57.0
|
||||
pkgver=1.58.0
|
||||
pkgrel=1
|
||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||
url=https://www.rust-lang.org/
|
||||
arch=(x86_64)
|
||||
license=(MIT Apache)
|
||||
options=(!emptydirs !strip)
|
||||
options=(!emptydirs !strip !lto)
|
||||
_llvm_ver=13.0.0
|
||||
depends=(gcc-libs llvm-libs curl libssh2 gcc)
|
||||
makedepends=(rust "llvm=$_llvm_ver" libffi perl python cmake
|
||||
|
@ -37,14 +37,14 @@ source=(
|
|||
0002-compiler-Change-LLVM-targets.patch
|
||||
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
)
|
||||
sha256sums=('3546f9c3b91b1f8b8efd26c94d6b50312c08210397b4072ed2748e2bd4445c1a'
|
||||
sha256sums=('0ad531a32f3c2e996b9322c6b7262a9cfe557e49ff3363adea07b575106cd770'
|
||||
'SKIP'
|
||||
'4c3602d76c7868a96b30c36165c4b7643e2a20173fced7e071b4baeb2d74db3f'
|
||||
'SKIP'
|
||||
'0f8cfbe0387dd62909fe9cb9523223ae1c2319494e2caf5fa4d0592198631b3e'
|
||||
'a2a8a7c6a5732f79cc92f81d3c8380589c4e2b9a996fb565bbefe42f66b62597'
|
||||
'977da945985dce4484ace8794cbc91241b1f3c27311c1a8b201231db6e1d19e5'
|
||||
'fcf3c4442ba6a9e59415652ce8514428b2e37b80c5fe7d07fb44259ad37abafb')
|
||||
'37af05c027fdecd4b8524e33660f8a87e48660c489e407d2ccc379137f4c46b6'
|
||||
'5429cf2f78f066a71fe6c2afbb151e06650935b644daa666259ce847fc0e2a2d'
|
||||
'72cd68f43775887adfcc286e628fb5d178d39f889bef8c4622cb10221af83f7d')
|
||||
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
474E22316ABF4785A88C6E8EA2C794A986419D8A # Tom Stellard <tstellar@redhat.com>
|
||||
B6C8F98282B944E3B0D5C2530FC3042E345AD05D) # Hans Wennborg <hans@chromium.org>
|
||||
|
|
Loading…
Reference in a new issue