extra/memcached: add patch

This commit is contained in:
Kevin Mihelich 2021-03-25 23:29:10 +00:00
parent aaac34d2f2
commit 878a1059fe

View file

@ -0,0 +1,12 @@
diff --git a/linux_priv.c b/linux_priv.c
index 401e02a..19ceb10 100644
--- a/linux_priv.c
+++ b/linux_priv.c
@@ -129,6 +129,7 @@ void drop_worker_privileges(void) {
int rc = 0;
rc |= seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(sigreturn), 0);
+ rc |= seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(rt_sigreturn), 0);
rc |= seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(rt_sigprocmask), 0);
rc |= seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(futex), 0);
rc |= seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(epoll_wait), 0);