mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/mariadb to 10.5.6-3
This commit is contained in:
parent
3d4c408064
commit
878efc7bd5
2 changed files with 46 additions and 7 deletions
34
extra/mariadb/0002-use-uname-n.patch
Normal file
34
extra/mariadb/0002-use-uname-n.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
commit 1bb3ad6dfc885112d05d8d73b066f18a416ca965
|
||||
Author: Geert Hendrickx <geert@hendrickx.be>
|
||||
Date: Thu Aug 27 17:30:03 2020 +0200
|
||||
|
||||
MDEV-23589: Portability: use `uname -n` instead of `hostname`
|
||||
|
||||
Closes PR #1663
|
||||
|
||||
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
|
||||
index 33e32ea22f7..eafb051ad60 100644
|
||||
--- a/scripts/CMakeLists.txt
|
||||
+++ b/scripts/CMakeLists.txt
|
||||
@@ -162,7 +162,7 @@ ELSE()
|
||||
SET(CHECK_PID "kill -s SIGCONT $PID > /dev/null 2> /dev/null")
|
||||
ENDIF()
|
||||
|
||||
-SET(HOSTNAME "hostname")
|
||||
+SET(HOSTNAME "uname -n")
|
||||
SET(MYSQLD_USER "mysql")
|
||||
ENDIF(UNIX)
|
||||
|
||||
diff --git a/support-files/CMakeLists.txt b/support-files/CMakeLists.txt
|
||||
index 80b6ca386df..2a17cf6d0d8 100644
|
||||
--- a/support-files/CMakeLists.txt
|
||||
+++ b/support-files/CMakeLists.txt
|
||||
@@ -30,7 +30,7 @@ ELSE()
|
||||
SET(CXXFLAGS ${CMAKE_CXX_FLAGS})
|
||||
SET(MYSQLD_USER "mysql")
|
||||
SET(ini_file_extension "cnf")
|
||||
- SET(HOSTNAME "hostname")
|
||||
+ SET(HOSTNAME "uname -n")
|
||||
ENDIF()
|
||||
|
||||
# XXX: shouldn't we just have variables for all this stuff and centralise
|
|
@ -8,25 +8,27 @@
|
|||
pkgbase=mariadb
|
||||
pkgname=('mariadb-libs' 'mariadb-clients' 'mariadb' 'mytop')
|
||||
pkgdesc='Fast SQL database server, derived from MySQL'
|
||||
pkgver=10.5.5
|
||||
pkgver=10.5.6
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
license=('GPL')
|
||||
url='https://mariadb.org/'
|
||||
makedepends=('rsync' 'boost' 'bzip2' 'cmake' 'jemalloc' 'libaio' 'libxcrypt'
|
||||
makedepends=('boost' 'bzip2' 'cmake' 'jemalloc' 'libaio' 'libxcrypt'
|
||||
'libxml2' 'lz4' 'lzo' 'openssl' 'systemd' 'zlib' 'zstd' 'curl'
|
||||
'krb5' 'cracklib')
|
||||
validpgpkeys=('199369E5404BD5FC7D2FE43BCBCB082A1BB943DB') # MariaDB Package Signing Key <package-signing-key@mariadb.org>
|
||||
# The default links with mirror redirection fail for signatures, specific
|
||||
# mirrors may be out of date every now and then. Let's use the upstream
|
||||
# rsync source and hope it does not hurt them too much.
|
||||
# rsync source via https and hope it does not hurt them too much.
|
||||
# https://mariadb.com/kb/en/library/mirror-sites-for-mariadb/
|
||||
source=("rsync://rsync.osuosl.org/mariadb/mariadb-${pkgver}/source/mariadb-${pkgver}.tar.gz"{,.asc}
|
||||
source=("https://rsync.osuosl.org/pub/mariadb/mariadb-${pkgver}/source/mariadb-${pkgver}.tar.gz"{,.asc}
|
||||
'0001-arch-specific.patch'
|
||||
'0002-use-uname-n.patch'
|
||||
'0001-libatomic.patch')
|
||||
sha256sums=('cf6b2c061754c07bbb1d20b29ae111bf2d098297c9b8c321b810638a179088a4'
|
||||
sha256sums=('ff05dd69e9f6992caf1053242db704f04eda6f9accbcc98b74edfaf6013c45c4'
|
||||
'SKIP'
|
||||
'c97e36bd0aeb10f506f4843761a0cd13dbe2e7bc71c3e5cdcd1a5310338bffaf'
|
||||
'3289efb3452d199aec872115f35da3f1d6fd4ce774615076690e9bc8afae1460'
|
||||
'0605142beb6ee2e72957696f2e5b10d3084c6423bc17207fb73cd71306cae8d9'
|
||||
'59947e8154dceae50a38053ed4f659f23e5c95eb2a2fc06f60d57be5814ae1c3')
|
||||
|
||||
prepare() {
|
||||
|
@ -38,6 +40,9 @@ prepare() {
|
|||
# * make systemd-tmpfiles create MYSQL_DATADIR
|
||||
patch -Np1 < ../0001-arch-specific.patch
|
||||
|
||||
# MDEV-23589: Portability: use `uname -n` instead of `hostname`
|
||||
patch -Np1 < ../0002-use-uname-n.patch
|
||||
|
||||
if [[ $CARCH == arm || $CARCH == armv6h ]]; then
|
||||
patch -p1 -i ../0001-libatomic.patch
|
||||
fi
|
||||
|
@ -166,7 +171,7 @@ package_mariadb() {
|
|||
'etc/my.cnf.d/spider.cnf'
|
||||
'etc/security/user_map.conf')
|
||||
install=mariadb.install
|
||||
depends=("mariadb-clients=${pkgver}" 'inetutils' 'systemd-libs' 'libxml2' 'zstd')
|
||||
depends=("mariadb-clients=${pkgver}" 'systemd-libs' 'libxml2' 'zstd')
|
||||
optdepends=('cracklib: for cracklib plugin'
|
||||
'curl: for ha_s3 plugin'
|
||||
'galera: for MariaDB cluster with Galera WSREP'
|
||||
|
|
Loading…
Reference in a new issue