mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
added extra/mysql
This commit is contained in:
parent
8f126b832d
commit
8793ccb8cc
5 changed files with 415 additions and 0 deletions
139
extra/mysql/PKGBUILD
Normal file
139
extra/mysql/PKGBUILD
Normal file
|
@ -0,0 +1,139 @@
|
|||
# $Id: PKGBUILD 146512 2012-01-12 08:07:59Z andrea $
|
||||
# Maintainer:
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - added alarm.patch
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgbase=mysql
|
||||
pkgname=('libmysqlclient' 'mysql-clients' 'mysql')
|
||||
pkgver=5.5.20
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
url="https://www.mysql.com/products/community/"
|
||||
makedepends=('cmake' 'openssl' 'zlib')
|
||||
options=('!libtool')
|
||||
source=("http://ftp.gwdg.de/pub/misc/mysql/Downloads/MySQL-5.5/${pkgbase}-${pkgver}.tar.gz"
|
||||
'mysqld'
|
||||
'my.cnf'
|
||||
'alarm.patch')
|
||||
md5sums=('375794ebf84b4c7b63f1676bc7416cd0'
|
||||
'2234207625baa29b2ff7d7b4f088abce'
|
||||
'1c949c0dbea5206af0db14942d9927b6'
|
||||
'9eb0ad531d162e031a2bcc08a5ab3bc5')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
patch -p1 -i "${srcdir}/alarm.patch"
|
||||
cd "${srcdir}"
|
||||
mkdir build
|
||||
cd build
|
||||
|
||||
# CFLAGS/CXXFLAGS as suggested upstream
|
||||
CFLAGS="-fPIC ${CFLAGS} -fno-strict-aliasing -DBIG_JOINS=1 -fomit-frame-pointer" \
|
||||
CXXFLAGS="-fPIC ${CXXFLAGS} -fno-strict-aliasing -DBIG_JOINS=1 -felide-constructors -fno-rtti" \
|
||||
|
||||
cmake ../${pkgbase}-${pkgver} \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DSYSCONFDIR=/etc/mysql \
|
||||
-DMYSQL_DATADIR=/var/lib/mysql \
|
||||
-DMYSQL_UNIX_ADDR=/var/run/mysqld/mysqld.sock \
|
||||
-DDEFAULT_CHARSET=utf8 \
|
||||
-DDEFAULT_COLLATION=utf8_general_ci \
|
||||
-DENABLED_LOCAL_INFILE=ON \
|
||||
-DINSTALL_INFODIR=share/mysql/docs \
|
||||
-DINSTALL_MANDIR=share/man \
|
||||
-DINSTALL_PLUGINDIR=/usr/lib/mysql/plugin \
|
||||
-DINSTALL_SCRIPTDIR=bin \
|
||||
-DINSTALL_INCLUDEDIR=include/mysql \
|
||||
-DINSTALL_DOCREADMEDIR=share/mysql \
|
||||
-DINSTALL_SUPPORTFILESDIR=share/mysql \
|
||||
-DINSTALL_MYSQLSHAREDIR=share/mysql \
|
||||
-DINSTALL_DOCDIR=share/mysql/docs \
|
||||
-DINSTALL_SHAREDIR=share/mysql \
|
||||
-DWITH_READLINE=ON \
|
||||
-DWITH_ZLIB=system \
|
||||
-DWITH_SSL=system \
|
||||
-DWITH_LIBWRAP=OFF \
|
||||
-DWITH_MYSQLD_LDFLAGS="${LDFLAGS}" \
|
||||
-DWITH_EXTRA_CHARSETS=complex \
|
||||
-DWITH_EMBEDDED_SERVER=ON \
|
||||
-DWITH_INNOBASE_STORAGE_ENGINE=1 \
|
||||
-DWITH_PARTITION_STORAGE_ENGINE=1 \
|
||||
-DWITHOUT_EXAMPLE_STORAGE_ENGINE=1 \
|
||||
-DWITHOUT_ARCHIVE_STORAGE_ENGINE=1 \
|
||||
-DWITHOUT_BLACKHOLE_STORAGE_ENGINE=1 \
|
||||
-DWITHOUT_FEDERATED_STORAGE_ENGINE=1
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package_libmysqlclient(){
|
||||
pkgdesc="MySQL client libraries"
|
||||
depends=('openssl')
|
||||
|
||||
cd "${srcdir}"/build
|
||||
for dir in include libmysql libmysqld libservices; do
|
||||
make -C ${dir} DESTDIR="${pkgdir}" install
|
||||
done
|
||||
|
||||
install -d "${pkgdir}"/usr/bin
|
||||
install -m755 scripts/mysql_config "${pkgdir}"/usr/bin/
|
||||
install -d "${pkgdir}"/usr/share/man/man1
|
||||
for man in mysql_config mysql_client_test_embedded mysqltest_embedded; do
|
||||
install -m644 "${srcdir}"/${pkgbase}-${pkgver}/man/$man.1 "${pkgdir}"/usr/share/man/man1/$man.1
|
||||
done
|
||||
}
|
||||
|
||||
package_mysql-clients(){
|
||||
pkgdesc="MySQL client tools"
|
||||
depends=('libmysqlclient')
|
||||
|
||||
cd "${srcdir}"/build
|
||||
make -C client DESTDIR="${pkgdir}" install
|
||||
|
||||
# install man pages
|
||||
install -d "${pkgdir}"/usr/share/man/man1
|
||||
for man in mysql mysqladmin mysqlcheck mysqldump mysqlimport mysqlshow mysqlslap; do
|
||||
install -m644 "${srcdir}"/${pkgbase}-${pkgver}/man/$man.1 "${pkgdir}"/usr/share/man/man1/$man.1
|
||||
done
|
||||
|
||||
# provided by mysql
|
||||
rm "${pkgdir}"/usr/bin/{mysql_{plugin,upgrade},mysqlbinlog,mysqltest}
|
||||
}
|
||||
|
||||
package_mysql(){
|
||||
pkgdesc="A fast SQL database server"
|
||||
backup=('etc/mysql/my.cnf')
|
||||
install=mysql.install
|
||||
depends=('mysql-clients')
|
||||
optdepends=('perl-dbi' 'perl-dbd-mysql')
|
||||
options=('emptydirs')
|
||||
|
||||
cd "${srcdir}"/build
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
install -Dm644 "${srcdir}"/my.cnf "${pkgdir}"/etc/mysql/my.cnf
|
||||
install -Dm755 "${srcdir}"/mysqld "${pkgdir}"/etc/rc.d/mysqld
|
||||
|
||||
# provided by libmysqlclient
|
||||
rm "${pkgdir}"/usr/bin/{mysql_config,mysql_client_test_embedded,mysqltest_embedded}
|
||||
rm "${pkgdir}"/usr/lib/libmysql*
|
||||
rm -r "${pkgdir}"/usr/include/
|
||||
rm "${pkgdir}"/usr/share/man/man1/{mysql_config,mysql_client_test_embedded,mysqltest_embedded}.1
|
||||
|
||||
# provided by mysql-clients
|
||||
rm "${pkgdir}"/usr/bin/{mysql,mysqladmin,mysqlcheck,mysqldump,mysqlimport,mysqlshow,mysqlslap}
|
||||
rm "${pkgdir}"/usr/share/man/man1/{mysql,mysqladmin,mysqlcheck,mysqldump,mysqlimport,mysqlshow,mysqlslap}.1
|
||||
|
||||
# not needed
|
||||
rm -r "${pkgdir}"/usr/{data,mysql-test,sql-bench}
|
||||
rm "${pkgdir}"/usr/share/man/man1/mysql-test-run.pl.1
|
||||
|
||||
install -dm700 "${pkgdir}"/var/lib/mysql
|
||||
}
|
28
extra/mysql/alarm.patch
Normal file
28
extra/mysql/alarm.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
diff -urN a/sql-common/client_plugin.c b/sql-common/client_plugin.c
|
||||
--- a/sql-common/client_plugin.c 2011-03-31 07:36:18.000000000 -0600
|
||||
+++ b/sql-common/client_plugin.c 2011-04-07 11:59:48.000000000 -0600
|
||||
@@ -242,9 +242,9 @@
|
||||
initialized= 1;
|
||||
|
||||
pthread_mutex_lock(&LOCK_load_client_plugin);
|
||||
-
|
||||
+ va_list a = {0};
|
||||
for (builtin= mysql_client_builtins; *builtin; builtin++)
|
||||
- add_plugin(&mysql, *builtin, 0, 0, 0);
|
||||
+ add_plugin(&mysql, *builtin, 0, 0, a);
|
||||
|
||||
pthread_mutex_unlock(&LOCK_load_client_plugin);
|
||||
|
||||
@@ -301,8 +301,10 @@
|
||||
plugin->name, "it is already loaded");
|
||||
plugin= NULL;
|
||||
}
|
||||
- else
|
||||
- plugin= add_plugin(mysql, plugin, 0, 0, 0);
|
||||
+ else {
|
||||
+ va_list a = {0};
|
||||
+ plugin= add_plugin(mysql, plugin, 0, 0, a);
|
||||
+ }
|
||||
|
||||
pthread_mutex_unlock(&LOCK_load_client_plugin);
|
||||
return plugin;
|
145
extra/mysql/my.cnf
Normal file
145
extra/mysql/my.cnf
Normal file
|
@ -0,0 +1,145 @@
|
|||
# MySQL config file for medium systems.
|
||||
#
|
||||
# This is for a system with little memory (32M - 64M) where MySQL plays
|
||||
# an important part, or systems up to 128M where MySQL is used together with
|
||||
# other programs (such as a web server)
|
||||
#
|
||||
# MySQL programs look for option files in a set of
|
||||
# locations which depend on the deployment platform.
|
||||
# You can copy this option file to one of those
|
||||
# locations. For information about these locations, see:
|
||||
# http://dev.mysql.com/doc/mysql/en/option-files.html
|
||||
#
|
||||
# In this file, you can use all long options that a program supports.
|
||||
# If you want to know which options a program supports, run the program
|
||||
# with the "--help" option.
|
||||
|
||||
# The following options will be passed to all MySQL clients
|
||||
[client]
|
||||
#password = your_password
|
||||
port = 3306
|
||||
socket = /var/run/mysqld/mysqld.sock
|
||||
|
||||
# Here follows entries for some specific programs
|
||||
|
||||
# The MySQL server
|
||||
[mysqld]
|
||||
port = 3306
|
||||
socket = /var/run/mysqld/mysqld.sock
|
||||
datadir = /var/lib/mysql
|
||||
skip-external-locking
|
||||
key_buffer_size = 16M
|
||||
max_allowed_packet = 1M
|
||||
table_open_cache = 64
|
||||
sort_buffer_size = 512K
|
||||
net_buffer_length = 8K
|
||||
read_buffer_size = 256K
|
||||
read_rnd_buffer_size = 512K
|
||||
myisam_sort_buffer_size = 8M
|
||||
|
||||
# Don't listen on a TCP/IP port at all. This can be a security enhancement,
|
||||
# if all processes that need to connect to mysqld run on the same host.
|
||||
# All interaction with mysqld must be made via Unix sockets or named pipes.
|
||||
# Note that using this option without enabling named pipes on Windows
|
||||
# (via the "enable-named-pipe" option) will render mysqld useless!
|
||||
#
|
||||
skip-networking
|
||||
|
||||
# Replication Master Server (default)
|
||||
# binary logging is required for replication
|
||||
log-bin=mysql-bin
|
||||
|
||||
# binary logging format - mixed recommended
|
||||
binlog_format=mixed
|
||||
|
||||
# required unique id between 1 and 2^32 - 1
|
||||
# defaults to 1 if master-host is not set
|
||||
# but will not function as a master if omitted
|
||||
server-id = 1
|
||||
|
||||
# Replication Slave (comment out master section to use this)
|
||||
#
|
||||
# To configure this host as a replication slave, you can choose between
|
||||
# two methods :
|
||||
#
|
||||
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
|
||||
# the syntax is:
|
||||
#
|
||||
# CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
|
||||
# MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
|
||||
#
|
||||
# where you replace <host>, <user>, <password> by quoted strings and
|
||||
# <port> by the master's port number (3306 by default).
|
||||
#
|
||||
# Example:
|
||||
#
|
||||
# CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
|
||||
# MASTER_USER='joe', MASTER_PASSWORD='secret';
|
||||
#
|
||||
# OR
|
||||
#
|
||||
# 2) Set the variables below. However, in case you choose this method, then
|
||||
# start replication for the first time (even unsuccessfully, for example
|
||||
# if you mistyped the password in master-password and the slave fails to
|
||||
# connect), the slave will create a master.info file, and any later
|
||||
# change in this file to the variables' values below will be ignored and
|
||||
# overridden by the content of the master.info file, unless you shutdown
|
||||
# the slave server, delete master.info and restart the slaver server.
|
||||
# For that reason, you may want to leave the lines below untouched
|
||||
# (commented) and instead use CHANGE MASTER TO (see above)
|
||||
#
|
||||
# required unique id between 2 and 2^32 - 1
|
||||
# (and different from the master)
|
||||
# defaults to 2 if master-host is set
|
||||
# but will not function as a slave if omitted
|
||||
#server-id = 2
|
||||
#
|
||||
# The replication master for this slave - required
|
||||
#master-host = <hostname>
|
||||
#
|
||||
# The username the slave will use for authentication when connecting
|
||||
# to the master - required
|
||||
#master-user = <username>
|
||||
#
|
||||
# The password the slave will authenticate with when connecting to
|
||||
# the master - required
|
||||
#master-password = <password>
|
||||
#
|
||||
# The port the master is listening on.
|
||||
# optional - defaults to 3306
|
||||
#master-port = <port>
|
||||
#
|
||||
# binary logging - not required for slaves, but recommended
|
||||
#log-bin=mysql-bin
|
||||
|
||||
# Uncomment the following if you are using InnoDB tables
|
||||
#innodb_data_home_dir = /var/lib/mysql
|
||||
#innodb_data_file_path = ibdata1:10M:autoextend
|
||||
#innodb_log_group_home_dir = /var/lib/mysql
|
||||
# You can set .._buffer_pool_size up to 50 - 80 %
|
||||
# of RAM but beware of setting memory usage too high
|
||||
#innodb_buffer_pool_size = 16M
|
||||
#innodb_additional_mem_pool_size = 2M
|
||||
# Set .._log_file_size to 25 % of buffer pool size
|
||||
#innodb_log_file_size = 5M
|
||||
#innodb_log_buffer_size = 8M
|
||||
#innodb_flush_log_at_trx_commit = 1
|
||||
#innodb_lock_wait_timeout = 50
|
||||
|
||||
[mysqldump]
|
||||
quick
|
||||
max_allowed_packet = 16M
|
||||
|
||||
[mysql]
|
||||
no-auto-rehash
|
||||
# Remove the next comment character if you are not familiar with SQL
|
||||
#safe-updates
|
||||
|
||||
[myisamchk]
|
||||
key_buffer_size = 20M
|
||||
sort_buffer_size = 20M
|
||||
read_buffer = 2M
|
||||
write_buffer = 2M
|
||||
|
||||
[mysqlhotcopy]
|
||||
interactive-timeout
|
26
extra/mysql/mysql.install
Normal file
26
extra/mysql/mysql.install
Normal file
|
@ -0,0 +1,26 @@
|
|||
post_install(){
|
||||
groupadd -g 89 mysql &>/dev/null
|
||||
useradd -u 89 -g mysql -d /var/lib/mysql -s /bin/false mysql &>/dev/null
|
||||
usr/bin/mysql_install_db --user=mysql --basedir=/usr
|
||||
chown -R mysql:mysql var/lib/mysql &>/dev/null
|
||||
}
|
||||
|
||||
post_upgrade(){
|
||||
getent group mysql >/dev/null 2>&1 || groupadd -g 89 mysql &>/dev/null
|
||||
getent passwd mysql >/dev/null 2>&1 || useradd -u 89 -g mysql -d /var/lib/mysql -s /bin/false mysql &>/dev/null
|
||||
|
||||
if [ "$(vercmp $2 5.5)" -lt 0 ]; then
|
||||
echo " >> "
|
||||
echo " >> Major version update. Consider restart the service, and then running mysql_upgrade after it."
|
||||
echo " >> "
|
||||
fi
|
||||
}
|
||||
|
||||
post_remove(){
|
||||
if getent passwd mysql >/dev/null 2>&1; then
|
||||
userdel mysql
|
||||
fi
|
||||
if getent group mysql >/dev/null 2>&1; then
|
||||
groupdel mysql
|
||||
fi
|
||||
}
|
77
extra/mysql/mysqld
Executable file
77
extra/mysql/mysqld
Executable file
|
@ -0,0 +1,77 @@
|
|||
#!/bin/bash
|
||||
|
||||
# general config
|
||||
. /etc/rc.conf
|
||||
. /etc/rc.d/functions
|
||||
|
||||
getPID() {
|
||||
echo $(pgrep -u mysql mysqld 2>/dev/null);
|
||||
}
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
stat_busy "Starting MySQL Server"
|
||||
[ ! -d /var/run/mysqld ] && install -d -g mysql -o mysql /var/run/mysqld &>/dev/null
|
||||
if [ -z "$(getPID)" ]; then
|
||||
/usr/bin/mysqld_safe --user=mysql &>/dev/null &
|
||||
if [ $? -gt 0 ]; then
|
||||
stat_fail
|
||||
exit 1
|
||||
else
|
||||
timeo=30
|
||||
while [ $timeo -gt 0 ]; do
|
||||
response=`/usr/bin/mysqladmin -uUNKNOWN_USER ping 2>&1` && break
|
||||
echo "$response" | grep -q "mysqld is alive" && break
|
||||
sleep 1
|
||||
let timeo=${timeo}-1
|
||||
done
|
||||
if [ $timeo -eq 0 ]; then
|
||||
stat_fail
|
||||
exit 1
|
||||
else
|
||||
echo $(getPID) > /var/run/mysqld/mysqld.pid
|
||||
add_daemon mysqld
|
||||
stat_done
|
||||
fi
|
||||
fi
|
||||
else
|
||||
stat_fail
|
||||
exit 1
|
||||
fi
|
||||
;;
|
||||
|
||||
stop)
|
||||
stat_busy "Stopping MySQL Server"
|
||||
if [ ! -z "$(getPID)" ]; then
|
||||
timeo=30
|
||||
kill $(getPID) &> /dev/null
|
||||
if [ $? -gt 0 ]; then
|
||||
stat_fail
|
||||
exit 1
|
||||
fi
|
||||
while [ ! -z "$(getPID)" -a $timeo -gt 0 ]; do
|
||||
sleep 1
|
||||
let timeo=${timeo}-1
|
||||
done
|
||||
if [ -z "$(getPID)" ]; then
|
||||
rm -f /var/run/mysqld/mysqld.pid &>/dev/null
|
||||
rm_daemon mysqld
|
||||
stat_done
|
||||
else
|
||||
stat_fail
|
||||
exit 1
|
||||
fi
|
||||
else
|
||||
stat_fail
|
||||
exit 1
|
||||
fi
|
||||
;;
|
||||
|
||||
restart)
|
||||
$0 stop
|
||||
$0 start
|
||||
;;
|
||||
*)
|
||||
echo "usage: $0 {start|stop|restart}"
|
||||
esac
|
||||
exit 0
|
Loading…
Reference in a new issue