mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/unrealircd to 4.0.8-1
This commit is contained in:
parent
5c3167c897
commit
87f6501cd7
2 changed files with 17 additions and 17 deletions
|
@ -1,4 +1,4 @@
|
|||
From 7939096e5be2547c415d32942b4db179f77c08c1 Mon Sep 17 00:00:00 2001
|
||||
From 4d55db702344c906f2a5122c8319252eea08d510 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 8 Jan 2016 17:57:41 -0700
|
||||
Subject: [PATCH] run autoreconf on TRE library
|
||||
|
@ -11,17 +11,17 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 73cde93..40667e6 100755
|
||||
index 1bb7872..409df1e 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -6683,6 +6683,7 @@ fi
|
||||
@@ -7541,6 +7541,7 @@ fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: configuring TRE regex library" >&5
|
||||
$as_echo "configuring TRE regex library" >&6; }
|
||||
cd tre-$tre_version
|
||||
+autoreconf -fi
|
||||
./configure --disable-agrep --disable-shared --disable-system-abi --disable-wchar --disable-multibyte --prefix=$cur_dir/extras/regexp || exit 1
|
||||
./configure --disable-agrep --enable-shared --disable-system-abi --disable-wchar --disable-multibyte --prefix=$cur_dir/extras/regexp --libdir=$PRIVATELIBDIR || exit 1
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: compiling TRE regex library" >&5
|
||||
$as_echo "compiling TRE regex library" >&6; }
|
||||
--
|
||||
2.6.2
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
# - patch to fix AArch64 FTBFS
|
||||
|
||||
pkgname=unrealircd
|
||||
pkgver=4.0.7
|
||||
pkgver=4.0.8
|
||||
pkgrel=1
|
||||
pkgdesc="Open Source IRC Server"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -22,14 +22,14 @@ source=(https://www.unrealircd.org/unrealircd4/unrealircd-$pkgver.tar.gz
|
|||
unrealircd.tmpfiles.d
|
||||
install.pl
|
||||
0001-run-autoreconf-on-TRE-library.patch)
|
||||
md5sums=('49a4cb9b2f957b36b6a4a12a14096e18'
|
||||
md5sums=('4baa6d80bfa185f9edef9a837b2a4b5a'
|
||||
'677d8de0bae770488a2c1730f9475a51'
|
||||
'3ec519ea7dbe99696eb6c51dfc0d382a'
|
||||
'3a23792b03420fc578cf6688b1574ae3'
|
||||
'28bd33be158f5c494601b6b3026803fa')
|
||||
'1657e9d68926ede143916f5ab9195eea')
|
||||
|
||||
prepare() {
|
||||
cd $srcdir/unrealircd-$pkgver
|
||||
cd "$srcdir"/unrealircd-$pkgver
|
||||
sed -i \
|
||||
-e 's|$(INSTALL) -m 0700|$(INSTALL) -m 0755|g' \
|
||||
-e 's|$(INSTALL) -m 0600|$(INSTALL) -m 0644|g' \
|
||||
|
@ -38,7 +38,7 @@ prepare() {
|
|||
}
|
||||
|
||||
build() {
|
||||
cd $srcdir/unrealircd-$pkgver
|
||||
cd "$srcdir"/unrealircd-$pkgver
|
||||
./configure \
|
||||
--with-pidfile=/run/unrealircd/ircd.pid \
|
||||
--with-showlistmodes \
|
||||
|
@ -61,14 +61,14 @@ build() {
|
|||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir/unrealircd-$pkgver
|
||||
cd "$srcdir"/unrealircd-$pkgver
|
||||
|
||||
export pkgdir
|
||||
make INSTALL=$srcdir/install.pl install
|
||||
mv $pkgdir/usr/unrealircd $pkgdir/etc/unrealircd/unrealircd
|
||||
cp $pkgdir/etc/unrealircd/examples/example.conf $pkgdir/etc/unrealircd/unrealircd.conf
|
||||
rm -rf $pkgdir/tmp
|
||||
make INSTALL="$srcdir"/install.pl install
|
||||
mv "$pkgdir"/usr/unrealircd "$pkgdir"/etc/unrealircd/unrealircd
|
||||
cp "$pkgdir"/etc/unrealircd/examples/example.conf "$pkgdir"/etc/unrealircd/unrealircd.conf
|
||||
rm -rf "$pkgdir"/tmp
|
||||
|
||||
install -Dm0644 $srcdir/unrealircd.service $pkgdir/usr/lib/systemd/system/unrealircd.service
|
||||
install -Dm0644 $srcdir/unrealircd.tmpfiles.d $pkgdir/usr/lib/tmpfiles.d/unrealircd.conf
|
||||
install -Dm0644 "$srcdir"/unrealircd.service "$pkgdir"/usr/lib/systemd/system/unrealircd.service
|
||||
install -Dm0644 "$srcdir"/unrealircd.tmpfiles.d "$pkgdir"/usr/lib/tmpfiles.d/unrealircd.conf
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue