core/linux-odroid-c1 fix

fixes #1194
This commit is contained in:
Kevin Mihelich 2015-05-31 16:36:59 +00:00
parent 0766602436
commit 88320735fa
4 changed files with 51 additions and 9 deletions

View file

@ -1,7 +1,7 @@
From 6d4c94648494ca604a9676927b3feb573765da41 Mon Sep 17 00:00:00 2001
From d8e25abf2feb8e2125a236d2391d8fc5c6b56785 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 22 Jan 2015 22:24:22 -0700
Subject: [PATCH 1/2] dirty status led active low hack
Subject: [PATCH 1/3] dirty status led active low hack
---
drivers/gpio/gpiolib-of.c | 14 ++++++++++++--
@ -39,5 +39,5 @@ index 4e3a8de..cba15b1 100644
#else
int of_get_named_gpio_flags(struct device_node *np, const char *propname,
--
2.3.2
2.4.1

View file

@ -1,7 +1,7 @@
From 282a8b2c675d5857ca428777f873e37607aeb9ad Mon Sep 17 00:00:00 2001
From b248983da561b9ad93b0f91ff9fc1e6b44ca059f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 19 Mar 2015 18:31:00 -0600
Subject: [PATCH 2/2] remove backports cflags
Subject: [PATCH 2/3] remove backports cflags
---
backports/Makefile | 8 +++-----
@ -39,5 +39,5 @@ index 5636a22..740fcf9 100644
\ No newline at end of file
+obj-y += drivers/realtek/
--
2.3.2
2.4.1

View file

@ -0,0 +1,39 @@
From 76c66bc752ac11dd7058c4c1d45902e094ad0545 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 30 Apr 2015 20:15:13 -0600
Subject: [PATCH 3/3] AUFS fix for 3.10.76
---
fs/aufs/debug.c | 2 +-
fs/aufs/hnotify.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/fs/aufs/debug.c b/fs/aufs/debug.c
index a26b5bd..7cedc88 100644
--- a/fs/aufs/debug.c
+++ b/fs/aufs/debug.c
@@ -156,7 +156,7 @@ void au_dpri_dalias(struct inode *inode)
struct dentry *d;
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias)
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias)
au_dpri_dentry(d);
spin_unlock(&inode->i_lock);
}
diff --git a/fs/aufs/hnotify.c b/fs/aufs/hnotify.c
index 1bd7a9a..927beb6 100644
--- a/fs/aufs/hnotify.c
+++ b/fs/aufs/hnotify.c
@@ -198,7 +198,7 @@ static int hn_gen_by_inode(char *name, unsigned int nlen, struct inode *inode,
AuDebugOn(!name);
au_iigen_dec(inode);
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
dname = &d->d_name;
if (dname->len != nlen
--
2.4.1

View file

@ -20,13 +20,15 @@ source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
'config'
'amlogic.service'
'0001-dirty-status-led-active-low-hack.patch'
'0002-remove-backports-cflags.patch')
'0002-remove-backports-cflags.patch'
'0003-AUFS-fix-for-3.10.76.patch')
md5sums=('866852c42b0e0ea72b44d535f7bcaa42'
'SKIP'
'5d883cdab6906f06b5c1382e9a84f8a9'
'b8956789318f49cec5b8bb0b41654a9b'
'1d2f1d042ebe8b49a85b6ceab9dc0dd4'
'b2014d69ffa477f23d3a311a621a6bdc')
'fe6c0fb78823349280ff39de6fbadc40'
'c2557467b38978bb2da6ff11520c85d8'
'e9be2a15e087403ded7a9df9a1901933')
prepare() {
cd "${srcdir}/${_srcname}"
@ -35,6 +37,7 @@ prepare() {
git apply ../0001-dirty-status-led-active-low-hack.patch
git apply ../0002-remove-backports-cflags.patch
git apply ../0003-AUFS-fix-for-3.10.76.patch
# add pkgrel to extraversion
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile