mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/boost to 1.67.0-4
This commit is contained in:
parent
ded53f87e6
commit
8841878452
3 changed files with 37 additions and 9 deletions
|
@ -1,4 +1,3 @@
|
|||
# $Id$
|
||||
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Contributor: Marius Knaust <marius.knaust@gmail.com>
|
||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
|
@ -16,22 +15,24 @@
|
|||
|
||||
pkgbase=boost
|
||||
pkgname=('boost-libs' 'boost')
|
||||
pkgver=1.66.0
|
||||
pkgver=1.67.0
|
||||
_boostver=${pkgver//./_}
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
url='http://www.boost.org/'
|
||||
arch=('x86_64')
|
||||
license=('custom')
|
||||
makedepends=('icu>=55.1' 'python' 'python2' 'python-numpy' 'python2-numpy' 'bzip2' 'zlib' 'openmpi')
|
||||
makedepends=('icu' 'python' 'python2' 'python-numpy' 'python2-numpy' 'bzip2' 'zlib' 'openmpi')
|
||||
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
|
||||
776.patch)
|
||||
sha256sums=('5721818253e6a0989583192f96782c4a98eb6204965316df9f5ad75819225ca9'
|
||||
lockfree-add-include-boost-next_prior.patch
|
||||
fix-return-var-qualifier-in-svm_ptr-get_context.patch)
|
||||
sha256sums=('2684c972994ee57fc5632e03bf044746f6eb45d4920c343937a465fd67a5adba'
|
||||
'2639c43e33f9279ffbebf270be0e0951b9f0e7a8264f8c3bfebb5b9901da2db6'
|
||||
'43cdc2081f90d2acc7e4d9de6689bce07b2a1b4754e85dc7fa50872afa330ffa')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgbase}_${_boostver}/boost
|
||||
|
||||
patch -Np3 -i "$srcdir"/776.patch
|
||||
cd ${pkgbase}_${_boostver}
|
||||
patch -Np2 -i ../lockfree-add-include-boost-next_prior.patch
|
||||
patch -Np2 -i ../fix-return-var-qualifier-in-svm_ptr-get_context.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -146,6 +147,12 @@ package_boost-libs() {
|
|||
cp -a "${_stagedir}"/python3/lib/libboost_* "${pkgdir}"/usr/lib
|
||||
rm "${pkgdir}"/usr/lib/*.a
|
||||
|
||||
# https://github.com/boostorg/python/issues/203#issuecomment-391477685
|
||||
for _lib in python numpy; do
|
||||
ln -srL "${pkgdir}"/usr/lib/libboost_${_lib}{27,}.so
|
||||
ln -srL "${pkgdir}"/usr/lib/libboost_${_lib}3{6,}.so
|
||||
done
|
||||
|
||||
install -Dm644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
|
||||
"${pkgdir}"/usr/share/licenses/boost-libs/LICENSE_1_0.txt
|
||||
}
|
||||
|
|
21
extra/boost/lockfree-add-include-boost-next_prior.patch
Normal file
21
extra/boost/lockfree-add-include-boost-next_prior.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
From 12726cda009a855073b9bedbdce57b6ce7763da2 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Dimov <pdimov@pdimov.com>
|
||||
Date: Sat, 2 Dec 2017 04:10:46 +0200
|
||||
Subject: [PATCH] Add #include <boost/next_prior.hpp>; no longer in utility.hpp
|
||||
|
||||
---
|
||||
include/boost/lockfree/spsc_queue.hpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/include/boost/lockfree/spsc_queue.hpp b/include/boost/lockfree/spsc_queue.hpp
|
||||
index 7903d2c..c7f2953 100644
|
||||
--- a/include/boost/lockfree/spsc_queue.hpp
|
||||
+++ b/include/boost/lockfree/spsc_queue.hpp
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <boost/assert.hpp>
|
||||
#include <boost/static_assert.hpp>
|
||||
#include <boost/utility.hpp>
|
||||
+#include <boost/next_prior.hpp>
|
||||
#include <boost/utility/enable_if.hpp>
|
||||
#include <boost/config.hpp> // for BOOST_LIKELY
|
||||
|
Loading…
Reference in a new issue