mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/firefox: v8 fixes
This commit is contained in:
parent
483108cf64
commit
88513ed3d4
2 changed files with 30 additions and 3 deletions
|
@ -32,7 +32,12 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
|
|||
firefox-symbolic.svg
|
||||
firefox-fixed-loading-icon.png
|
||||
no-libnotify.patch
|
||||
no-neon.patch)
|
||||
no-neon.patch
|
||||
7c2671907288.patch::https://hg.mozilla.org/mozilla-central/raw-rev/7c2671907288
|
||||
b3d2424a348e.patch::https://hg.mozilla.org/mozilla-central/raw-rev/b3d2424a348e
|
||||
69f237c2cf91.patch::https://hg.mozilla.org/mozilla-central/raw-rev/69f237c2cf91
|
||||
a5919256fd5c.patch::https://hg.mozilla.org/mozilla-central/raw-rev/a5919256fd5c
|
||||
aarch64-no-static-sizes.patch)
|
||||
sha256sums=('d1814ac6d8cd687696bd0d98da3bb525f6df11fe655e0d668742b21fca57d9c8'
|
||||
'9011ffcd6eb2868d0363c216d0b28faf64bb746e8de200726a6ca7013a99106e'
|
||||
'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
|
||||
|
@ -40,9 +45,13 @@ sha256sums=('d1814ac6d8cd687696bd0d98da3bb525f6df11fe655e0d668742b21fca57d9c8'
|
|||
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
|
||||
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
|
||||
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
|
||||
'e4ebdd14096d177d264a7993dbd5df46463605ff45f783732c26d30b9caa53a7'
|
||||
'e4ebdd14096d177d264a7993dbd5df46463605ff45f783732c26d30b9caa53a7'
|
||||
'6d0c1c9ca28b20d206ce24ca84f4d4e3f5d062a2e9cb7445fcb6c2cfea959b4a'
|
||||
'cbd14ac4839062f4437d1db7cfd5fb9aaadb6786dc63612b219106e01000aafd')
|
||||
'20bdcf5424b8a3338e57fb03b9a9af03c820f23aef915b09d934b8c252ccd72a'
|
||||
'3c538925a739484eef3bf663e44e1876ad27b01755c001b81f9e3ef30f329b08'
|
||||
'32e116fcd3ede2b4074fa169453216ca8ed71f93e67fbdc78e14c308b3f2a99c'
|
||||
'fb5f84100e01f127160a82797860cb0e04bb6da860a8343963ed45c44740ef0e'
|
||||
'b73d92a6e96b84464e1f675f8cac730a12cfc9701318a3a9ba46b3d34bfe7cb4')
|
||||
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -96,6 +105,13 @@ prepare() {
|
|||
|
||||
[[ $CARCH == "aarch64" ]] && echo "ac_add_options --disable-gold" >> .mozconfig
|
||||
patch -Np0 -i ../no-neon.patch
|
||||
|
||||
# AArch64 patches
|
||||
patch -p1 -i ../7c2671907288.patch
|
||||
patch -p1 -i ../b3d2424a348e.patch
|
||||
patch -p1 -i ../69f237c2cf91.patch
|
||||
patch -p1 -i ../a5919256fd5c.patch
|
||||
patch -p0 -i ../aarch64-no-static-sizes.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
11
extra/firefox/aarch64-no-static-sizes.patch
Normal file
11
extra/firefox/aarch64-no-static-sizes.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- memory/mozjemalloc/jemalloc.c.orig 2016-03-21 19:00:39.971125884 -0600
|
||||
+++ memory/mozjemalloc/jemalloc.c 2016-03-21 18:59:22.474081051 -0600
|
||||
@@ -1089,7 +1089,7 @@
|
||||
* controlling the malloc behavior are defined as compile-time constants
|
||||
* for best performance and cannot be altered at runtime.
|
||||
*/
|
||||
-#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__)
|
||||
+#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__) && !defined(__aarch64__)
|
||||
#define MALLOC_STATIC_SIZES 1
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue