community/percona-server to 8.0.28_19-1

This commit is contained in:
Kevin Mihelich 2022-05-13 13:26:39 +00:00
parent 3c0e507550
commit 88d7e2013a
4 changed files with 54 additions and 54 deletions

View file

@ -6,11 +6,11 @@
pkgbase=percona-server
pkgname=('libperconaserverclient' 'percona-server-clients' 'percona-server')
pkgver=8.0.27_18
pkgver=8.0.28_19
_boost_ver=1.73.0
_pkgver=${pkgver/_/-}
_myver=${pkgver/_rel*}
pkgrel=3
pkgrel=1
arch=('x86_64')
makedepends=('cmake' 'zlib' 'lz4' 'zstd' 'libaio' 'systemd-tools' 'pam' 'numactl' 'jemalloc' 'openssl'
'rpcsvc-proto' 'doxygen' 'graphviz' 'libevent' 'protobuf') # 'boost'
@ -23,17 +23,15 @@ source=("https://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona
'mysql-user.conf'
'mysqlrouter-user.conf'
'openldap-2.5.patch'
'build-hostname.patch'
'no-werror.patch'
'missing-std-includes.patch'
'0001-fix-LF_PINS-padding-calculation.patch')
sha256sums=('91a7ad8fc0e3931f2d2bcb616bca8a55b6b7cac45f735aba4188c45edcf85da8'
sha256sums=('1394ba4700f3c48307b1faed5804cf774f3a4d71f27680e9b09d08fb70db8e31'
'9995e192e68528793755692917f9eb6422f3052a53c5e13ba278a228af6c7acf'
'b467b04d6d06152b2abc33f2a6de63fef0fc922dd5119d2ee1d07d3c1a489731'
'5d7710fe88ec6d298175a309c0b776142397b119c468830b2865980292ed5da6'
'4ca7ffdcb2d1716d4f31e4c7dd314e5d76e64f13fdc67c5d81c53650b793f5e0'
'92d70b75a32517f598bbffbaf5db18b0d14be504c31f531e35c8572b330785f3'
'1537fdbb92dd1c135c1eb9f4d10c44fd02e652db66c933d731990a1196f1397c'
'2343a191c452b91caa458b03b0c1ef3f5afb0e7031816c68467af5c6a6ffe253'
'56b4632d1c68895ae4f073f0a9b7a93f7b6f845c57f1bf832065b76bf3e0f1c5'
'aa5e960625843b061f47c32b4a267fab1115667b8b7d1ce7ec952efe42eb77af')
prepare() {
@ -41,8 +39,7 @@ prepare() {
rm -v sql/sql_yacc.{cc,h}
patch --verbose -p1 -i "$srcdir"/openldap-2.5.patch
patch --verbose -p1 -i "$srcdir"/build-hostname.patch
patch --verbose -p1 -i "$srcdir"/no-werror.patch
patch --verbose -p1 -i "$srcdir"/missing-std-includes.patch
sed -r -e s@/var/run/mysqlrouter@/run/mysqlrouter@ \
-e s@lib64/mysql@lib/mysql@ \

View file

@ -1,17 +0,0 @@
diff --git a/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake b/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
index 5b6882cc..d165f3e7 100644
--- a/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
+++ b/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
@@ -56,11 +56,7 @@ endmacro(whoami)
## gives the current hostname, minus .tokutek.com if it's there
macro(hostname out)
- execute_process(
- COMMAND hostname
- OUTPUT_VARIABLE fullhostname
- OUTPUT_STRIP_TRAILING_WHITESPACE)
- string(REGEX REPLACE "\\.tokutek\\.com$" "" ${out} "${fullhostname}")
+ set(${out} "archbuild")
endmacro(hostname)
## gather machine info

View file

@ -0,0 +1,48 @@
diff --git a/client/logger.cc b/client/logger.cc
index 0198dca7..c3823266 100644
--- a/client/logger.cc
+++ b/client/logger.cc
@@ -27,6 +27,7 @@
#include <time.h>
#include <iostream>
#include <locale>
+#include <memory>
using namespace std;
diff --git a/components/keyrings/common/component_helpers/src/keyring_log_builtins_definition.cc b/components/keyrings/common/component_helpers/src/keyring_log_builtins_definition.cc
index b4801329..92b483ba 100644
--- a/components/keyrings/common/component_helpers/src/keyring_log_builtins_definition.cc
+++ b/components/keyrings/common/component_helpers/src/keyring_log_builtins_definition.cc
@@ -25,6 +25,7 @@
#include <cstring>
#include <iostream>
#include <locale>
+#include <memory>
#include <sstream>
#include <m_string.h>
diff --git a/plugin/auth_ldap/src/connection.cc b/plugin/auth_ldap/src/connection.cc
index bb280388..1d221e78 100644
--- a/plugin/auth_ldap/src/connection.cc
+++ b/plugin/auth_ldap/src/connection.cc
@@ -1,6 +1,7 @@
#include "plugin/auth_ldap/include/connection.h"
#include <iostream>
+#include <iterator>
#include <regex>
#include "plugin/auth_ldap/include/plugin_log.h"
diff --git a/router/src/harness/include/mysql/harness/net_ts/executor.h b/router/src/harness/include/mysql/harness/net_ts/executor.h
index 8d0b257e..525dae33 100644
--- a/router/src/harness/include/mysql/harness/net_ts/executor.h
+++ b/router/src/harness/include/mysql/harness/net_ts/executor.h
@@ -36,6 +36,7 @@
#include <thread>
#include <type_traits> // decay_t, enable_if
#include <unordered_map>
+#include <utility>
#include "my_compiler.h"
#include "mysql/harness/net_ts/netfwd.h"

View file

@ -1,28 +0,0 @@
diff --git a/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt b/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt
index 9d2c1dd2..cefa9190 100644
--- a/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt
+++ b/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt
@@ -20,7 +20,7 @@ set_property(DIRECTORY APPEND PROPERTY COMPILE_DEFINITIONS
_FILE_OFFSET_BITS=64
_LARGEFILE64_SOURCE)
-set(CMAKE_CXX_FLAGS "-Werror -W -Wall -Wshadow ${CMAKE_CXX_FLAGS}")
+set(CMAKE_CXX_FLAGS "-W -Wall -Wshadow ${CMAKE_CXX_FLAGS}")
set(USE_VALGRIND OFF CACHE BOOL "whether to use valgrind headers")
if (USE_VALGRIND)
diff --git a/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake b/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake
index 92897b88..95dad8ac 100644
--- a/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake
+++ b/storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake
@@ -171,8 +171,8 @@ if (NOT CMAKE_CXX_COMPILER_ID STREQUAL Clang)
endif ()
## always want these
-set(CMAKE_C_FLAGS "-Wall -Werror ${CMAKE_C_FLAGS}")
-set(CMAKE_CXX_FLAGS "-Wall -Werror ${CMAKE_CXX_FLAGS}")
+set(CMAKE_C_FLAGS "-Wall ${CMAKE_C_FLAGS}")
+set(CMAKE_CXX_FLAGS "-Wall ${CMAKE_CXX_FLAGS}")
# pick language dialect
set(CMAKE_C_FLAGS "-std=c99 ${CMAKE_C_FLAGS}")