alarm/vlc-rpi to 3.0.21-2

Sync PKGBUILD with Arch Linux and include missing taglib hack to build
with taglib-2.0.1-1. Build fails on armv7h so restrict to aarch64 as most
RPi4B/5B users should be on a 64-bit kernel/userland by now anyway.
This commit is contained in:
graysky 2024-06-21 08:37:18 -04:00
parent e22fe75cda
commit 88e8687a53
2 changed files with 158 additions and 84 deletions

View file

@ -4,13 +4,15 @@
# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca> # Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
# Contributor: Martin Sandsmark <martin.sandsmark@kde.org> # Contributor: Martin Sandsmark <martin.sandsmark@kde.org>
buildarch=8
pkgname=vlc-rpi pkgname=vlc-rpi
_pkgname=vlc _pkgname=vlc
_vlcver=3.0.21 _vlcver=3.0.21
# optional fixup version including hyphen # optional fixup version including hyphen
_vlcfixupver= _vlcfixupver=
pkgver=${_vlcver}${_vlcfixupver//-/.r} pkgver=${_vlcver}${_vlcfixupver//-/.r}
pkgrel=1 pkgrel=2
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player with hw accel for RPi 3 and above' pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player with hw accel for RPi 3 and above'
url='https://www.videolan.org/vlc/' url='https://www.videolan.org/vlc/'
arch=(aarch64) arch=(aarch64)
@ -52,9 +54,9 @@ depends=(
'libsecret' 'libsecret'
'libtar' 'libtar'
'libupnp' 'libixml.so' 'libupnp.so' 'libupnp' 'libixml.so' 'libupnp.so'
#'libva' 'libva'
#'libx11' 'libx11'
#'libxcb' 'libxcb'
'libxinerama' 'libxinerama'
'libxml2' 'libxml2'
'libxpm' 'libxpm'
@ -62,8 +64,8 @@ depends=(
'qt5-base' 'qt5-base'
'qt5-svg' 'qt5-svg'
'qt5-x11extras' 'qt5-x11extras'
#'taglib' 'taglib'
#'wayland' 'wayland'
'xcb-util-keysyms' 'xcb-util-keysyms'
'zlib' 'zlib'
) )
@ -130,93 +132,101 @@ makedepends=(
'xosd' 'xosd'
'zvbi' 'zvbi'
) )
optdepends=(
# 'chromaprint: Chromaprint audio fingerprinter' 'aalib: ASCII art video output'
optdepends=('avahi: service discovery using bonjour protocol' 'alsa-lib: ALSA audio output'
'aom: AOM AV1 codec' 'aom: AOM AV1 codec'
'gst-plugins-base-libs: for libgst plugins' 'aribb25: aribcam support'
'dav1d: dav1d AV1 decoder' 'avahi: service discovery using bonjour protocol'
'libdvdcss: decoding encrypted DVDs' 'dav1d: dav1d AV1 decoder'
'libavc1394: devices using the 1394ta AV/C' 'flac: Free Lossless Audio Codec plugin'
'libdc1394: IEEE 1394 access plugin' 'fluidsynth: FluidSynth based MIDI playback plugin'
'kwallet: kwallet keystore' 'gnu-free-fonts: subtitle font'
'libva-vdpau-driver: vdpau backend nvidia' 'gst-plugins-base-libs: for libgst plugins'
'libva-intel-driver: video backend intel' 'gstreamer: for libgst plugins'
'libbluray: Blu-Ray video input' 'gtk3: notification plugin'
'flac: Free Lossless Audio Codec plugin' 'jack: jack audio server'
'twolame: TwoLAME mpeg2 encoder plugin' 'kwallet: kwallet keystore'
'libgme: Game Music Emu plugin' 'libass: Subtitle support'
'vcdimager: navigate VCD with libvcdinfo' 'libavc1394: devices using the 1394ta AV/C'
'libmtp: MTP devices discovery' 'libbluray: Blu-Ray video input'
'systemd-libs: udev services discovery' 'libcaca: colored ASCII art video output'
'smbclient: SMB access plugin' 'libcdio: audio CD playback'
'libcdio: audio CD playback' 'libdc1394: IEEE 1394 access plugin'
'gnu-free-fonts: subtitle font' 'libdvdcss: decoding encrypted DVDs'
'ttf-dejavu: subtitle font' 'libdvdnav: DVD with navigation input module'
'libssh2: sftp access' 'libdvdread: DVD input module'
'libnfs: NFS access' 'libgme: Game Music Emu plugin'
'mpg123: mpg123 codec' 'libgoom2: Goom visualization'
'protobuf: chromecast streaming' 'libjpeg-turbo: JPEG support'
'libmicrodns: mDNS services discovery (chromecast etc)' 'libkate: Kate codec'
'lua-socket: http interface' 'libmodplug: MOD output plugin'
'libdvdread: DVD input module' 'libmicrodns: mDNS services discovery (chromecast etc)'
'libdvdnav: DVD with navigation input module' 'libmtp: MTP devices discovery'
'libogg: Ogg and OggSpots codec' 'libnfs: NFS access'
'libshout: shoutcast/icecast output plugin' 'libnotify: notification plugin'
'libmodplug: MOD output plugin' 'libogg: Ogg and OggSpots codec'
'libvpx: VP8 and VP9 codec' 'libpng: PNG support'
'libvorbis: Vorbis decoder/encoder' 'libpulse: PulseAudio audio output'
'speex: Speex codec' 'libraw1394: IEEE 1394 access plugin'
'opus: opus codec' 'librsvg: SVG plugin'
'libtheora: theora codec' 'libsamplerate: audio Resampler'
'libpng: PNG support' 'libshout: shoutcast/icecast output plugin'
'libjpeg-turbo: JPEG support' 'libsoxr: SoX audio Resampler'
'librsvg: SVG plugin' 'libssh2: sftp access'
'x264: H264 encoding' 'libtheora: theora codec'
'x265: HEVC/H.265 encoder' 'libtiger: Tiger rendering for Kate streams'
'zvbi: VBI/Teletext/webcam/v4l2 capture/decoding' 'libva-intel-driver: video backend intel'
'libass: Subtitle support' 'libva-vdpau-driver: vdpau backend nvidia'
'libkate: Kate codec' 'libvorbis: Vorbis decoder/encoder'
'libtiger: Tiger rendering for Kate streams' 'libvpx: VP8 and VP9 codec'
'sdl_image: SDL image support' 'lirc: lirc control'
'srt: SRT input/output plugin' 'live-media: streaming over RTSP'
'aalib: ASCII art video output' 'lua-socket: http interface'
'libcaca: colored ASCII art video output' 'mpg123: mpg123 codec'
'libpulse: PulseAudio audio output' 'ncurses: ncurses interface'
'alsa-lib: ALSA audio output' 'opus: opus codec'
'jack: jack audio server' 'pcsclite: aribcam support'
'libsamplerate: audio Resampler' 'projectm: ProjectM visualisation'
'libsoxr: SoX audio Resampler' 'protobuf: chromecast streaming'
'lirc: lirc control' 'sdl12-compat: SDL image support'
'libgoom2: Goom visualization' 'sdl_image: SDL image support'
'projectm: ProjectM visualisation' 'smbclient: SMB access plugin'
'ncurses: ncurses interface' 'speex: Speex codec'
'libnotify: notification plugin' 'speexdsp: Speex codec'
'gtk3: notification plugin' 'srt: SRT input/output plugin'
'aribb25: aribcam support' 'systemd-libs: udev services discovery'
'pcsclite: aribcam support' 'ttf-dejavu: subtitle font'
'live-media: streaming over RTSP') 'twolame: TwoLAME mpeg2 encoder plugin'
'vcdimager: navigate VCD with libvcdinfo'
'x264: H264 encoding'
'x265: HEVC/H.265 encoder'
'zvbi: VBI/Teletext/webcam/v4l2 capture/decoding'
)
conflicts=('vlc-plugin' 'vlc') conflicts=('vlc-plugin' 'vlc')
provides=('vlc') provides=('vlc')
replaces=('vlc-plugin') replaces=('vlc-plugin')
options=('!emptydirs') options=('!emptydirs')
install='vlc.install' install='vlc.install'
source=(https://download.videolan.org/${_pkgname}/${_vlcver}/${_pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc} source=(
99-vlc.rules https://download.videolan.org/${_pkgname}/${_vlcver}/${_pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc}
vlc.config.txt update-vlc-plugin-cache.hook
0001-vlc-live-media-2021.patch taglib-2.patch
# credit to jc and RPi-Distro maintainers for this work, see: 99-vlc.rules
# https://github.com/jc-kynesim/vlc.git vlc.config.txt
# https://github.com/RPi-Distro/vlc/tree/bullseye-rpt/debian/patches # credit to jc and RPi-Distro maintainers for this work, see:
0002-test-3.0.21-rpi_2.patch # https://github.com/jc-kynesim/vlc.git and https://github.com/RPi-Distro/vlc/tree/bookworm-rpt/debian/patches
update-vlc-plugin-cache.hook) 0001-vlc-live-media-2021.patch
0002-test-3.0.21-rpi_2.patch
)
sha256sums=('24dbbe1d7dfaeea0994d5def0bbde200177347136dbfe573f5b6a4cee25afbb0' sha256sums=('24dbbe1d7dfaeea0994d5def0bbde200177347136dbfe573f5b6a4cee25afbb0'
'SKIP' 'SKIP'
'b98043683dd90d3f5a3f501212dfc629839b661100de5ac79fd30cb7b4a06f13'
'db41f3a11d4df28251f1baaf41bc0913227ff1e77680e43d7efa172e6ae1cc29'
'61125ab0da600d813f1aebd8445fcf03e176389cfb8aa28591f8225a13043089' '61125ab0da600d813f1aebd8445fcf03e176389cfb8aa28591f8225a13043089'
'f7d129441b5f1f1ce03f7056ebe2707d8c431a69a11afe153a9990dd61ce75ec' 'f7d129441b5f1f1ce03f7056ebe2707d8c431a69a11afe153a9990dd61ce75ec'
'753517a8b88c5950d516f0fe57a3ef169e0665ba7817d4b8d9976c666829a291' '753517a8b88c5950d516f0fe57a3ef169e0665ba7817d4b8d9976c666829a291'
'616833e99372317d9a1e1a73254ee48f71a803eb13e8dd04db158e7c3db0eb5c' '616833e99372317d9a1e1a73254ee48f71a803eb13e8dd04db158e7c3db0eb5c')
'b98043683dd90d3f5a3f501212dfc629839b661100de5ac79fd30cb7b4a06f13')
validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key
prepare() { prepare() {
@ -338,7 +348,7 @@ build() {
--enable-libxml2 \ --enable-libxml2 \
--disable-libgcrypt \ --disable-libgcrypt \
--enable-gnutls \ --enable-gnutls \
--disable-taglib \ --enable-taglib \
--enable-secret \ --enable-secret \
--enable-kwallet \ --enable-kwallet \
--disable-update-check \ --disable-update-check \
@ -375,3 +385,4 @@ package() {
} }
# vim: ts=2 sw=2 et: # vim: ts=2 sw=2 et:

View file

@ -0,0 +1,63 @@
diff --git a/modules/meta_engine/taglib.cpp b/modules/meta_engine/taglib.cpp
index 84b401c795..f371485008 100644
--- a/modules/meta_engine/taglib.cpp
+++ b/modules/meta_engine/taglib.cpp
@@ -185,7 +185,7 @@ public:
ByteVector res(length, 0);
ssize_t i_read = vlc_stream_Read( m_stream, res.data(), length);
if (i_read < 0)
- return ByteVector::null;
+ return ByteVector();
else if ((size_t)i_read != length)
res.resize(i_read);
return res;
@@ -465,7 +465,7 @@ static void ReadMetaFromASF( ASF::Tag* tag, demux_meta_t* p_demux_meta, vlc_meta
static void ReadMetaFromBasicTag(const Tag* tag, vlc_meta_t *dest)
{
#define SET( accessor, meta ) \
- if( !tag->accessor().isNull() && !tag->accessor().isEmpty() ) \
+ if( !tag->accessor().isEmpty() ) \
vlc_meta_Set##meta( dest, tag->accessor().toCString(true) )
#define SETINT( accessor, meta ) \
if( tag->accessor() ) \
@@ -806,15 +806,15 @@ static void ReadMetaFromMP4( MP4::Tag* tag, demux_meta_t *p_demux_meta, vlc_meta
{
MP4::Item list;
#define SET( keyName, metaName ) \
- if( tag->itemListMap().contains(keyName) ) \
+ if( tag->itemMap().contains(keyName) ) \
{ \
- list = tag->itemListMap()[keyName]; \
+ list = tag->itemMap()[keyName]; \
vlc_meta_Set##metaName( p_meta, list.toStringList().front().toCString( true ) ); \
}
#define SET_EXTRA( keyName, metaName ) \
- if( tag->itemListMap().contains(keyName) ) \
+ if( tag->itemMap().contains(keyName) ) \
{ \
- list = tag->itemListMap()[keyName]; \
+ list = tag->itemMap()[keyName]; \
vlc_meta_AddExtra( p_meta, metaName, list.toStringList().front().toCString( true ) ); \
}
@@ -824,9 +824,9 @@ static void ReadMetaFromMP4( MP4::Tag* tag, demux_meta_t *p_demux_meta, vlc_meta
#undef SET
#undef SET_EXTRA
- if( tag->itemListMap().contains("covr") )
+ if( tag->itemMap().contains("covr") )
{
- MP4::CoverArtList list = tag->itemListMap()["covr"].toCoverArtList();
+ MP4::CoverArtList list = tag->itemMap()["covr"].toCoverArtList();
const char *psz_format = list[0].format() == MP4::CoverArt::PNG ? "image/png" : "image/jpeg";
msg_Dbg( p_demux_meta, "Found embedded art (%s) is %i bytes",
@@ -1337,7 +1337,7 @@ static int WriteMeta( vlc_object_t *p_this )
if( RIFF::AIFF::File* riff_aiff = dynamic_cast<RIFF::AIFF::File*>(f.file()) )
WriteMetaToId3v2( riff_aiff->tag(), p_item );
else if( RIFF::WAV::File* riff_wav = dynamic_cast<RIFF::WAV::File*>(f.file()) )
- WriteMetaToId3v2( riff_wav->tag(), p_item );
+ WriteMetaToId3v2( riff_wav->ID3v2Tag(), p_item );
}
else if( TrueAudio::File* trueaudio = dynamic_cast<TrueAudio::File*>(f.file()) )
{