mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/firefox to 68.0.1-2
This commit is contained in:
parent
48c3114bec
commit
892dedd123
2 changed files with 62 additions and 1 deletions
|
@ -0,0 +1,56 @@
|
|||
From 1cab10b39cfda068100cab8c598f1ca0f50e4131 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <1cab10b39cfda068100cab8c598f1ca0f50e4131.1553597287.git.jan.steffens@gmail.com>
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Mon, 25 Mar 2019 20:30:11 +0100
|
||||
Subject: [PATCH] Use remoting name for GDK application names
|
||||
|
||||
---
|
||||
toolkit/xre/nsAppRunner.cpp | 6 +-----
|
||||
widget/gtk/nsAppShell.cpp | 7 +++----
|
||||
2 files changed, 4 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
|
||||
index 0b808ef215f06..28911c0ffeaec 100644
|
||||
--- a/toolkit/xre/nsAppRunner.cpp
|
||||
+++ b/toolkit/xre/nsAppRunner.cpp
|
||||
@@ -3728,11 +3728,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||
// consistently.
|
||||
|
||||
// Set program name to the one defined in application.ini.
|
||||
- {
|
||||
- nsAutoCString program(gAppData->name);
|
||||
- ToLowerCase(program);
|
||||
- g_set_prgname(program.get());
|
||||
- }
|
||||
+ g_set_prgname(gAppData->remotingName);
|
||||
|
||||
// Initialize GTK here for splash.
|
||||
|
||||
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
|
||||
index 0686ff814916b..ae4a4ea55f420 100644
|
||||
--- a/widget/gtk/nsAppShell.cpp
|
||||
+++ b/widget/gtk/nsAppShell.cpp
|
||||
@@ -24,6 +24,7 @@
|
||||
# include "WakeLockListener.h"
|
||||
#endif
|
||||
#include "gfxPlatform.h"
|
||||
+#include "nsAppRunner.h"
|
||||
#include "ScreenHelperGTK.h"
|
||||
#include "HeadlessScreenHelper.h"
|
||||
#include "mozilla/widget/ScreenManager.h"
|
||||
@@ -171,10 +172,8 @@ nsresult nsAppShell::Init() {
|
||||
// option when program uses gdk_set_program_class().
|
||||
//
|
||||
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
|
||||
- nsAutoString brandName;
|
||||
- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
|
||||
- if (!brandName.IsEmpty()) {
|
||||
- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
|
||||
+ if (gAppData) {
|
||||
+ gdk_set_program_class(gAppData->remotingName);
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
|
@ -12,7 +12,7 @@ noautobuild=1
|
|||
|
||||
pkgname=firefox
|
||||
pkgver=68.0.1
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=(x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
|
@ -31,9 +31,11 @@ options=(!emptydirs !makeflags !strip)
|
|||
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
|
||||
arm.patch
|
||||
build-arm-libopus.patch
|
||||
0001-Use-remoting-name-for-GDK-application-names.patch
|
||||
$pkgname.desktop firefox-symbolic.svg)
|
||||
sha256sums=('6037f77bdab29d79ca5e3fbd1d32f6c209e09d2066189a13dc7f7491227f5568'
|
||||
'SKIP'
|
||||
'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
|
||||
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
|
||||
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
||||
'a9e5264257041c0b968425b5c97436ba48e8d294e1a0f02c59c35461ea245c33'
|
||||
|
@ -77,6 +79,9 @@ prepare() {
|
|||
mkdir mozbuild
|
||||
cd firefox-$pkgver
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
|
||||
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
||||
|
|
Loading…
Reference in a new issue