removed extra/gst-plugins-bad

This commit is contained in:
Kevin Mihelich 2018-10-03 12:53:56 +00:00
parent 6dc83426d3
commit 89487d14f9
2 changed files with 0 additions and 123 deletions

View file

@ -1,72 +0,0 @@
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove --enable-gtk-doc from configure - broken with latest gtk-doc
pkgname=gst-plugins-bad
pkgver=1.14.3
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Bad Plugins"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
license=(LGPL)
depends=(mjpegtools gst-plugins-base-libs curl chromaprint libmms faad2 celt libdca libdvdnav
libmodplug libgme wayland libofa openjpeg2 libwebp libsrtp gnutls sbc rtmpdump libgudev
libexif libdvdread libvdpau libmpeg2 wildmidi ladspa openal libusb vulkan-icd-loader
libfdk-aac faac soundtouch spandsp neon webrtc-audio-processing libdc1394 libmpcdec zvbi
openexr libbs2b libnice lcms2 bluez-libs glu srt)
makedepends=(python gtk-doc autoconf-archive git gobject-introspection gtk3 vulkan-headers
vulkan-validation-layers librsvg libtiger zbar fluidsynth lilv opencv)
_commit=924b54b1501656a192ff391f0c2fd6cfb9f89aac # tags/1.14.3^0
source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-bad#commit=$_commit"
"gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common"
missing-includes.diff)
sha256sums=('SKIP'
'SKIP'
'acf625d58611372532bc76e7276dacd69d2a9f7dee88ed9e2e8ecae0881476a3')
pkgver() {
cd $pkgname
git describe --tags | sed 's/-/+/g'
}
prepare() {
cd $pkgname
# error: CV_RGB was not declared in this scope
patch -Np1 -i ../missing-includes.diff
git submodule init
git config --local submodule.common.url "$srcdir/gst-common"
git submodule update
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd $pkgname
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--libexecdir=/usr/lib \
--with-package-name="GStreamer Bad Plugins (Arch Linux)" \
--with-package-origin="https://www.archlinux.org/" \
--with-gtk=3.0 \
--enable-experimental \
--disable-static
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
cd $pkgname
# bad tests are bad
#make -k check || :
}
package() {
cd $pkgname
make DESTDIR="$pkgdir" install
}

View file

@ -1,51 +0,0 @@
Submodule common f0c2dc9aa..ed78bee43:
> valgrind suppressions: ignore any error triggered by */ld*.so
> gtk-doc-plugins.mak: sort xml inspect files
diff --git i/ext/opencv/MotionCells.cpp w/ext/opencv/MotionCells.cpp
index f85989e11..e75191308 100644
--- i/ext/opencv/MotionCells.cpp
+++ w/ext/opencv/MotionCells.cpp
@@ -52,6 +52,7 @@
#include <errno.h>
#include "MotionCells.h"
#include <opencv2/imgproc/imgproc_c.h>
+#include <opencv2/imgproc/imgproc.hpp>
MotionCells::MotionCells ()
{
diff --git i/ext/opencv/gsthanddetect.cpp w/ext/opencv/gsthanddetect.cpp
index 60fd5be72..aadbc03de 100644
--- i/ext/opencv/gsthanddetect.cpp
+++ w/ext/opencv/gsthanddetect.cpp
@@ -63,6 +63,7 @@
/* element header */
#include "gsthanddetect.h"
#include <opencv2/imgproc/imgproc_c.h>
+#include <opencv2/imgproc.hpp>
GST_DEBUG_CATEGORY_STATIC (gst_handdetect_debug);
#define GST_CAT_DEFAULT gst_handdetect_debug
diff --git i/ext/opencv/gstsegmentation.cpp w/ext/opencv/gstsegmentation.cpp
index d52476e7d..fd3abb507 100644
--- i/ext/opencv/gstsegmentation.cpp
+++ w/ext/opencv/gstsegmentation.cpp
@@ -92,6 +92,7 @@
#include "gstsegmentation.h"
#include <opencv2/imgproc/imgproc_c.h>
+#include <opencv2/imgproc.hpp>
GST_DEBUG_CATEGORY_STATIC (gst_segmentation_debug);
#define GST_CAT_DEFAULT gst_segmentation_debug
diff --git i/ext/opencv/gsttemplatematch.cpp w/ext/opencv/gsttemplatematch.cpp
index f39208dc2..50197f23d 100644
--- i/ext/opencv/gsttemplatematch.cpp
+++ w/ext/opencv/gsttemplatematch.cpp
@@ -64,6 +64,7 @@
#include "../../gst-libs/gst/gst-i18n-plugin.h"
#include "gsttemplatematch.h"
#include <opencv2/imgproc/imgproc_c.h>
+#include <opencv2/imgproc.hpp>
GST_DEBUG_CATEGORY_STATIC (gst_template_match_debug);
#define GST_CAT_DEFAULT gst_template_match_debug