kernel26-olinuxino: more updates from oe

This commit is contained in:
Kiril Zyapkov 2012-09-18 22:11:16 +03:00
parent 766895eaaf
commit 897c5a5f1a
11 changed files with 96 additions and 431 deletions

View file

@ -1,58 +0,0 @@
From 64bc6f1bfac43096d0102be252392f31405273ec Mon Sep 17 00:00:00 2001
From: Greg KH <gregkh@suse.de>
Date: Thu, 5 Aug 2010 13:53:35 -0700
Subject: [PATCH 2/2] cgroupfs: create /sys/fs/cgroup to mount cgroupfs on
We really shouldn't be asking userspace to create new root filesystems.
So follow along with all of the other in-kernel filesystems, and provide
a mount point in sysfs.
For cgroupfs, this should be in /sys/fs/cgroup/ This change provides
that mount point when the cgroup filesystem is registered in the kernel.
Acked-by: Paul Menage <menage@google.com>
Acked-by: Dhaval Giani <dhaval.giani@gmail.com>
Cc: Li Zefan <lizf@cn.fujitsu.com>
Cc: Lennart Poettering <lennart@poettering.net>
Cc: Kay Sievers <kay.sievers@vrfy.org>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
kernel/cgroup.c | 13 ++++++++++++-
1 files changed, 12 insertions(+), 1 deletions(-)
diff --git a/kernel/cgroup.c b/kernel/cgroup.c
index 7a14a97..cd81c18 100644
--- a/kernel/cgroup.c
+++ b/kernel/cgroup.c
@@ -1621,6 +1621,8 @@ static struct file_system_type cgroup_fs_type = {
.kill_sb = cgroup_kill_sb,
};
+static struct kobject *cgroup_kobj;
+
static inline struct cgroup *__d_cgrp(struct dentry *dentry)
{
return dentry->d_fsdata;
@@ -3885,9 +3887,18 @@ int __init cgroup_init(void)
hhead = css_set_hash(init_css_set.subsys);
hlist_add_head(&init_css_set.hlist, hhead);
BUG_ON(!init_root_id(&rootnode));
+
+ cgroup_kobj = kobject_create_and_add("cgroup", fs_kobj);
+ if (!cgroup_kobj) {
+ err = -ENOMEM;
+ goto out;
+ }
+
err = register_filesystem(&cgroup_fs_type);
- if (err < 0)
+ if (err < 0) {
+ kobject_put(cgroup_kobj);
goto out;
+ }
proc_create("cgroups", 0, NULL, &proc_cgroupstats_operations);
--
1.6.6.1

View file

@ -23,38 +23,23 @@ LDFLAGS=""
license=('GPL2')
url="https://github.com/Freescale/meta-fsl-arm/"
source=(config
0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch
NFS-Fix-nfsroot-support.patch
NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch
no-unaligned-access.patch
w1-fix-support-multiple-master.patch
smsc95xx-randomize-mac-once.patch
dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch
wire-up-sys_accept4-on-ARM.patch
mx23-do-not-use-safe-write.patch
mx23-dont-mange-IRQ_VDDA_BRNOUT.patch
mx28-removecpufreq.patch
mxs-duart-use-ttyAMA-for-device-name.patch
imx233-olinuxino.patch)
md5sums=('1cee0cf2dc43ff44b83880fcedcdd386'
'bde087470cb0715ca709bd5bcd3803d0'
md5sums=('953ddea92634bb713853f2c1b14ed130'
'e086ab0b162d292549f9bf453e07ad2e'
'ff1281a87da6f8093992ad70d23e71d2'
'bcba9216d3414a9de22b7d4fb24853e1'
'c8894e44904cc1365e7110eb04aea1d6'
'14ec6ec6f9de8d1fd0333024481541af'
'f0ebf1f2dbfa4030ba3945fea97710a1'
'1d38c32d1d5348ef24745b2f38b0f040'
'8ea565af62cf67bccf53dc45edecc447'
'2db15e97e1122c38995d3d0727cd73b4'
'c2d9dba73587fd00d990a2521428d67b'
'302ad0fe4e990c789793e25ced58f712'
'ba72c5e3ea407e6214e237323d6b467b')
__gitname="linux-2.6-imx"
__gitroot="git://git.freescale.com/imx/${__gitname}.git"
__gitbranch="imx_2.6.35_10.12.01"
__gitcommit="a0e8d80376957175e959f70aba51a1cae487e414"
__gitcommit="38bf41cc376e24c384934fbeb10770d6712e9143"
build() {
@ -76,17 +61,10 @@ build() {
make mrproper
msg "Patching ..."
patch -Np1 -i ../0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch
patch -Np1 -i ../NFS-Fix-nfsroot-support.patch
patch -Np1 -i ../NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch
patch -Np1 -i ../no-unaligned-access.patch
patch -Np1 -i ../w1-fix-support-multiple-master.patch
patch -Np1 -i ../smsc95xx-randomize-mac-once.patch
patch -Np1 -i ../dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch
patch -Np1 -i ../wire-up-sys_accept4-on-ARM.patch
patch -Np1 -i ../mx23-do-not-use-safe-write.patch
patch -Np1 -i ../mx23-dont-mange-IRQ_VDDA_BRNOUT.patch
patch -Np1 -i ../mx28-removecpufreq.patch
patch -Np1 -i ../mxs-duart-use-ttyAMA-for-device-name.patch
patch -Np1 -i ../imx233-olinuxino.patch
@ -100,7 +78,7 @@ build() {
sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
# Configure the kernel. Replace the line below with one of your choice.
#make menuconfig # CLI menu for configuration
make menuconfig # CLI menu for configuration
#make nconfig # new CLI menu for configuration
#make oldconfig # using old config from previous kernel version

View file

@ -129,10 +129,11 @@ CONFIG_PERF_USE_VMALLOC=y
# CONFIG_PERF_EVENTS is not set
# CONFIG_PERF_COUNTERS is not set
CONFIG_VM_EVENT_COUNTERS=y
CONFIG_SLUB_DEBUG=y
CONFIG_COMPAT_BRK=y
# CONFIG_SLAB is not set
# CONFIG_SLUB is not set
CONFIG_SLOB=y
CONFIG_SLUB=y
# CONFIG_SLOB is not set
# CONFIG_PROFILING is not set
CONFIG_HAVE_OPROFILE=y
# CONFIG_KPROBES is not set
@ -145,6 +146,7 @@ CONFIG_HAVE_CLK=y
#
# CONFIG_SLOW_WORK is not set
CONFIG_HAVE_GENERIC_DMA_COHERENT=y
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
CONFIG_MODULES=y
@ -689,7 +691,7 @@ CONFIG_NETDEVICES=y
# CONFIG_VETH is not set
# CONFIG_PHYLIB is not set
CONFIG_NET_ETHERNET=y
CONFIG_MII=y
CONFIG_MII=m
# CONFIG_AX88796 is not set
# CONFIG_SMC91X is not set
# CONFIG_DM9000 is not set
@ -755,13 +757,13 @@ CONFIG_ZD1211RW=m
# CONFIG_USB_KAWETH is not set
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_RTL8150 is not set
CONFIG_USB_USBNET=y
CONFIG_USB_USBNET=m
# CONFIG_USB_NET_AX8817X is not set
# CONFIG_USB_NET_CDCETHER is not set
# CONFIG_USB_NET_CDC_EEM is not set
# CONFIG_USB_NET_DM9601 is not set
# CONFIG_USB_NET_SMSC75XX is not set
CONFIG_USB_NET_SMSC95XX=y
CONFIG_USB_NET_SMSC95XX=m
# CONFIG_USB_NET_GL620A is not set
# CONFIG_USB_NET_NET1080 is not set
# CONFIG_USB_NET_PLUSB is not set
@ -769,6 +771,7 @@ CONFIG_USB_NET_SMSC95XX=y
# CONFIG_USB_NET_RNDIS_HOST is not set
# CONFIG_USB_NET_CDC_SUBSET is not set
# CONFIG_USB_NET_ZAURUS is not set
# CONFIG_USB_HSO is not set
# CONFIG_USB_NET_INT51X1 is not set
# CONFIG_USB_IPHETH is not set
# CONFIG_USB_SIERRA_NET is not set
@ -808,9 +811,9 @@ CONFIG_INPUT_KEYBOARD=y
# CONFIG_KEYBOARD_ATKBD is not set
# CONFIG_KEYBOARD_QT2160 is not set
# CONFIG_KEYBOARD_LKKBD is not set
CONFIG_KEYBOARD_GPIO=m
# CONFIG_KEYBOARD_GPIO is not set
# CONFIG_KEYBOARD_TCA6416 is not set
CONFIG_KEYBOARD_MATRIX=m
# CONFIG_KEYBOARD_MATRIX is not set
# CONFIG_KEYBOARD_MAX7359 is not set
# CONFIG_KEYBOARD_NEWTON is not set
# CONFIG_KEYBOARD_OPENCORES is not set

View file

@ -1,32 +0,0 @@
dm9601: Added support for usb ethernet (0x0fe6, 0x9700)
The device is very similar to (0x0fe6, 0x8101),
And works well with dm9601 driver.
Upstream-Status: Backport [2.6.38]
Signed-off-by: Shahar Havivi <shaharh@redhat.com>
Acked-by: Peter Korsgaard <jacmet@sunsite.dk>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
drivers/net/usb/dm9601.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/drivers/net/usb/dm9601.c b/drivers/net/usb/dm9601.c
index 02b622e..5002f5b 100644
--- a/drivers/net/usb/dm9601.c
+++ b/drivers/net/usb/dm9601.c
@@ -651,6 +651,10 @@ static const struct usb_device_id products[] = {
.driver_info = (unsigned long)&dm9601_info,
},
{
+ USB_DEVICE(0x0fe6, 0x9700), /* DM9601 USB to Fast Ethernet Adapter */
+ .driver_info = (unsigned long)&dm9601_info,
+ },
+ {
USB_DEVICE(0x0a46, 0x9000), /* DM9000E */
.driver_info = (unsigned long)&dm9601_info,
},
--
1.7.10

View file

@ -1,31 +0,0 @@
From: Otavio Salvador <otavio@ossystems.com.br>
Subject: [PATCH 2/2] [MX23] Do not use safe write when building for MX23 arch
The change 105ae4a60 include a safe write support for use with MX23
but does not include a dummy implementation for other architecture
making build to fail. This add a dummy version to allow the use with
MX23 arch.
Upstream-Status: Pending
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
arch/arm/plat-mxs/usb_common.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/arch/arm/plat-mxs/usb_common.c b/arch/arm/plat-mxs/usb_common.c
index 700d168..c3bc9a9 100644
--- a/arch/arm/plat-mxs/usb_common.c
+++ b/arch/arm/plat-mxs/usb_common.c
@@ -53,6 +53,8 @@ static void fsl_safe_writel(u32 val32, volatile u32 *addr)
{
__asm__ ("swp %0, %0, [%1]" : : "r"(val32), "r"(addr));
}
+#else
+static void fsl_safe_writel(u32 val32, volatile u32 *addr) { }
#endif
void fsl_usb_xcvr_register(struct fsl_xcvr_ops *xcvr_ops)
--
1.7.10.4

View file

@ -1,51 +0,0 @@
From: Otavio Salvador <otavio@ossystems.com.br>
Subject: [PATCH 1/2] [MX23] Don't mangle IRQ_VDDA_BRNOUT for MX23 arch
This has been introduced on commit e93820b3 and makes the kernel to
fail to build for MX23 arch so we avoid the IRQ_VDDA_BRNOUT
manipulation for MX23 arch as this IRQ is not available on MX23.
Upstream-Status: Pending
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
drivers/power/mxs/linux.c | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/drivers/power/mxs/linux.c b/drivers/power/mxs/linux.c
index d5185fa..0d6c729 100644
--- a/drivers/power/mxs/linux.c
+++ b/drivers/power/mxs/linux.c
@@ -1171,7 +1171,9 @@ static int __init mxs_bat_init(void)
disable_irq(IRQ_DCDC4P2_BRNOUT);
disable_irq(IRQ_BATT_BRNOUT);
disable_irq(IRQ_VDDD_BRNOUT);
+#ifndef CONFIG_ARCH_MX23
disable_irq(IRQ_VDDA_BRNOUT);
+#endif
if (no_battery)
disable_irq(IRQ_VDDIO_BRNOUT);
#ifndef CONFIG_ARCH_MX28
@@ -1184,7 +1186,9 @@ static int __init mxs_bat_init(void)
mxs_set_irq_fiq(IRQ_DCDC4P2_BRNOUT, 1);
mxs_set_irq_fiq(IRQ_BATT_BRNOUT, 1);
mxs_set_irq_fiq(IRQ_VDDD_BRNOUT, 1);
+#ifndef CONFIG_ARCH_MX23
mxs_set_irq_fiq(IRQ_VDDA_BRNOUT, 1);
+#endif
if (no_battery)
mxs_set_irq_fiq(IRQ_VDDIO_BRNOUT, 1);
#ifndef CONFIG_ARCH_MX28
@@ -1199,7 +1203,9 @@ static int __init mxs_bat_init(void)
enable_irq(IRQ_DCDC4P2_BRNOUT);
enable_irq(IRQ_BATT_BRNOUT);
enable_irq(IRQ_VDDD_BRNOUT);
+#ifndef CONFIG_ARCH_MX23
enable_irq(IRQ_VDDA_BRNOUT);
+#endif
if (no_battery)
enable_irq(IRQ_VDDIO_BRNOUT);
#ifndef CONFIG_ARCH_MX28
--
1.7.10.4

View file

@ -0,0 +1,79 @@
From 7b781d1a67486a2ae50c174731ca1daebf381ab4 Mon Sep 17 00:00:00 2001
From: Fabio Estevam <festevam@gmail.com>
Date: Fri, 23 Mar 2012 13:13:49 -0300
Subject: [PATCH] ARM: mx28: Remove CPUFREQ support
When using CPUFREQ driver with the mainline U-boot, the kernel hangs.
Remove CPUFREQ support for now.
Signed-off-by: Fabio Estevam <fabio.estevam@freescale.com>
---
arch/arm/configs/imx28evk_defconfig | 1 -
arch/arm/plat-mxs/Kconfig | 2 --
arch/arm/plat-mxs/clock.c | 10 ----------
3 files changed, 0 insertions(+), 13 deletions(-)
diff --git a/arch/arm/configs/imx28evk_defconfig b/arch/arm/configs/imx28evk_defconfig
index 08f6a18..0c8bc66 100644
--- a/arch/arm/configs/imx28evk_defconfig
+++ b/arch/arm/configs/imx28evk_defconfig
@@ -18,7 +18,6 @@ CONFIG_TRACE_IRQFLAGS_SUPPORT=y
CONFIG_HARDIRQS_SW_RESEND=y
CONFIG_GENERIC_IRQ_PROBE=y
CONFIG_RWSEM_GENERIC_SPINLOCK=y
-CONFIG_ARCH_HAS_CPUFREQ=y
CONFIG_GENERIC_HWEIGHT=y
CONFIG_GENERIC_CALIBRATE_DELAY=y
CONFIG_ZONE_DMA=y
diff --git a/arch/arm/plat-mxs/Kconfig b/arch/arm/plat-mxs/Kconfig
index 831a24b..63768f8 100644
--- a/arch/arm/plat-mxs/Kconfig
+++ b/arch/arm/plat-mxs/Kconfig
@@ -13,7 +13,6 @@ config ARCH_MX28
select MXS_ICOLL
select MXS_DMA_ENGINE
select MXS_AUART_DMA_SUPPORT
- select ARCH_HAS_CPUFREQ
---help---
Support Freescale MX28 chips
@@ -25,7 +24,6 @@ config ARCH_MX23
select MXS_ICOLL
select MXS_DMA_ENGINE
select MXS_AUART_DMA_SUPPORT
- select ARCH_HAS_CPUFREQ
---help---
Support Freescale MX23 chips
diff --git a/arch/arm/plat-mxs/clock.c b/arch/arm/plat-mxs/clock.c
index 1b98b1e..3ce7953 100644
--- a/arch/arm/plat-mxs/clock.c
+++ b/arch/arm/plat-mxs/clock.c
@@ -119,11 +119,6 @@ int clk_enable(struct clk *clk)
ret = __clk_enable(clk);
spin_unlock_irqrestore(&clockfw_lock, flags);
- if ((clk->flags & CPU_FREQ_TRIG_UPDATE)
- && (pre_usage == 0)) {
- cpufreq_trig_needed = 1;
- cpufreq_update_policy(0);
- }
return ret;
}
EXPORT_SYMBOL(clk_enable);
@@ -139,11 +134,6 @@ void clk_disable(struct clk *clk)
spin_lock_irqsave(&clockfw_lock, flags);
__clk_disable(clk);
spin_unlock_irqrestore(&clockfw_lock, flags);
- if ((clk->flags & CPU_FREQ_TRIG_UPDATE)
- && ((clk->ref & CLK_EN_MASK) == 0)) {
- cpufreq_trig_needed = 1;
- cpufreq_update_policy(0);
- }
}
EXPORT_SYMBOL(clk_disable);
--
1.7.1

View file

@ -1,40 +0,0 @@
diff --git a/Makefile b/Makefile
index 554683d..087e0c0 100644
--- a/Makefile
+++ b/Makefile
@@ -535,6 +535,9 @@ else
KBUILD_CFLAGS += -O2
endif
+# conserve stack if available
+KBUILD_CFLAGS += $(call cc-option,-fconserve-stack)
+
include $(srctree)/arch/$(SRCARCH)/Makefile
ifneq ($(CONFIG_FRAME_WARN),0)
@@ -579,9 +582,6 @@ KBUILD_CFLAGS += $(call cc-option,-Wno-pointer-sign,)
# disable invalid "can't wrap" optimizations for signed / pointers
KBUILD_CFLAGS += $(call cc-option,-fno-strict-overflow)
-# conserve stack if available
-KBUILD_CFLAGS += $(call cc-option,-fconserve-stack)
-
# Add user supplied CPPFLAGS, AFLAGS and CFLAGS as the last assignments
# But warn user when we do so
warn-assign = \
diff --git a/arch/arm/Makefile b/arch/arm/Makefile
index 767874d..89afaea 100644
--- a/arch/arm/Makefile
+++ b/arch/arm/Makefile
@@ -93,6 +93,11 @@ ifeq ($(CONFIG_ARM_UNWIND),y)
CFLAGS_ABI +=-funwind-tables
endif
+ifeq ($(CONFIG_ALIGNMENT_TRAP),y)
+CFLAGS_ABI +=$(call cc-option,-mno-unaligned-access,)
+endif
+KBUILD_CFLAGS += $(call cc-option,-fno-conserve-stack,)
+
ifeq ($(CONFIG_THUMB2_KERNEL),y)
AFLAGS_AUTOIT :=$(call as-option,-Wa$(comma)-mimplicit-it=always,-Wa$(comma)-mauto-it)
AFLAGS_NOWARN :=$(call as-option,-Wa$(comma)-mno-warn-deprecated,-Wa$(comma)-W)

View file

@ -1,51 +0,0 @@
smsc95xx: generate random MAC address once, not every ifup
The smsc95xx driver currently generates a new random MAC address
every time the interface is brought up. This makes it impossible to
override using the standard `ifconfig hw ether` approach.
Past patches tried to make the MAC address a module parameter or
base it off the die ID, but it seems to me much simpler (and
hopefully less controversial) to stick with the current random
generation scheme, but allow the user to change the address.
This patch does exactly that - it moves the random address
generation from smsc95xx_reset() into smsc95xx_bind(), so that it is
done once on module load, not on every ifup. The user can then
override this using the standard mechanisms.
Applies against 2.6.35 and linux-2.6 head.
Upstream-Status: Backport [2.6.36]
Signed-off-by: Bernard Blackham <b-omap@largestprime.net>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
drivers/net/usb/smsc95xx.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index 12a3c88..65cb1ab 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -805,8 +805,6 @@ static int smsc95xx_reset(struct usbnet *dev)
return ret;
}
- smsc95xx_init_mac_address(dev);
-
ret = smsc95xx_set_mac_address(dev);
if (ret < 0)
return ret;
@@ -1047,6 +1045,8 @@ static int smsc95xx_bind(struct usbnet *dev, struct usb_interface *intf)
pdata->use_tx_csum = DEFAULT_TX_CSUM_ENABLE;
pdata->use_rx_csum = DEFAULT_RX_CSUM_ENABLE;
+ smsc95xx_init_mac_address(dev);
+
/* Init all registers */
ret = smsc95xx_reset(dev);
--
1.7.7.6

View file

@ -1,79 +0,0 @@
drivers/w1/w1_int.c: multiple masters used same init_name
When using multiple masters, w1_int.c would use the .init_name from w1.c
for all entities, which will fail when creating a corresponding sysfs
entry. This patch uses the unique name previously generated.
WARNING: at fs/sysfs/dir.c:451 sysfs_add_one+0x48/0x64()
sysfs: cannot create duplicate filename '/devices/w1 bus master'
Modules linked in:
Call trace:
[<9001a604>] warn_slowpath_common+0x34/0x44
[<9001a64c>] warn_slowpath_fmt+0x14/0x18
[<90078020>] sysfs_add_one+0x48/0x64
[<900784ec>] create_dir+0x40/0x68
[<9007857a>] sysfs_create_dir+0x66/0x78
[<900c1a8a>] kobject_add_internal+0x6e/0x104
[<900c1bc0>] kobject_add_varg+0x20/0x2c
[<900c1c1c>] kobject_add+0x30/0x3c
[<900dbd66>] device_add+0x6a/0x378
[<900dbb4a>] device_initialize+0x12/0x48
[<900dc080>] device_register+0xc/0x10
[<900f99be>] w1_add_master_device+0x162/0x274
[<90008e7a>] w1_gpio_probe+0x66/0xb4
[<9000030c>] kernel_init+0x0/0xe8
[<900dde54>] platform_drv_probe+0xc/0xe
[<9000030c>] kernel_init+0x0/0xe8
[<900dd4f8>] driver_probe_device+0x6c/0xdc
[<900dd5fc>] __driver_attach+0x34/0x48
[<900dcce8>] bus_for_each_dev+0x2c/0x48
[<900dd5c8>] __driver_attach+0x0/0x48
[<900dd38c>] driver_attach+0x10/0x14
[<900dd16a>] bus_add_driver+0x6a/0x18c
[<900dd768>] driver_register+0x60/0xb8
[<90011594>] __initcall_w1_therm_init6+0x0/0x4
[<90008e00>] w1_gpio_init+0x0/0x14
[<9000030c>] kernel_init+0x0/0xe8
[<900ddf48>] platform_driver_register+0x30/0x38
[<90011594>] __initcall_w1_therm_init6+0x0/0x4
[<90008e00>] w1_gpio_init+0x0/0x14
[<9000030c>] kernel_init+0x0/0xe8
[<900ddf5e>] platform_driver_probe+0xe/0x3c
[<90008e0c>] w1_gpio_init+0xc/0x14
[<90011594>] __initcall_w1_therm_init6+0x0/0x4
[<90008e00>] w1_gpio_init+0x0/0x14
[<900126d4>] do_one_initcall+0x34/0x130
[<90000372>] kernel_init+0x66/0xe8
[<90011594>] __initcall_w1_therm_init6+0x0/0x4
[<9001ca3e>] do_exit+0x0/0x3a6
[<9000030c>] kernel_init+0x0/0xe8
[<9001ca3e>] do_exit+0x0/0x3a6
---[ end trace 5a9233884fead918 ]---
kobject_add_internal failed for w1 bus master with -EEXIST, don't try to register things with the same name in the same directory.
Upstream-Status: Backport [3.2]
Signed-off-by: Florian Faber <faber@faberman.de>
Cc: Evgeniy Polyakov <zbr@ioremap.net>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
---
drivers/w1/w1_int.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/w1/w1_int.c b/drivers/w1/w1_int.c
index d220bce..f79e62e 100644
--- a/drivers/w1/w1_int.c
+++ b/drivers/w1/w1_int.c
@@ -78,6 +78,7 @@ static struct w1_master * w1_alloc_dev(u32 id, int slave_count, int slave_ttl,
memcpy(&dev->dev, device, sizeof(struct device));
dev_set_name(&dev->dev, "w1_bus_master%u", dev->id);
snprintf(dev->name, sizeof(dev->name), "w1_bus_master%u", dev->id);
+ dev->dev.init_name = dev->name;
dev->driver = driver;
--
1.7.10

View file

@ -1,53 +0,0 @@
From 1415ec63689ef39bcb24b5095941ec4cc884035c Mon Sep 17 00:00:00 2001
From: Mikael Pettersson <mikpe@it.uu.se>
Date: Sun, 15 Aug 2010 10:47:23 +0100
Subject: [PATCH 1/2] ARM: 6329/1: wire up sys_accept4() on ARM
sys_accept4() was added in kernel 2.6.28, but ARM was not updated
to include it. The number and types of parameters is such that
no ARM-specific processing is needed, so wiring up sys_accept4()
just requires defining __NR_accept4 and adding a direct call in
the syscall entry table.
Tested with an EABI 2.6.35 kernel and Ulrich Drepper's original
accept4() test program, modified to define __NR_accept4 for ARM.
Using the updated unistd.h also eliminates a warning then building
glibc (2.10.2 and newer) about accept4() being unimplemented.
Upstream-Status: Backport [2.6.36]
Signed-off-by: Mikael Pettersson <mikpe@it.uu.se>
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
---
arch/arm/include/asm/unistd.h | 1 +
arch/arm/kernel/calls.S | 1 +
2 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/arch/arm/include/asm/unistd.h b/arch/arm/include/asm/unistd.h
index dd2bf53..d02cfb6 100644
--- a/arch/arm/include/asm/unistd.h
+++ b/arch/arm/include/asm/unistd.h
@@ -392,6 +392,7 @@
#define __NR_rt_tgsigqueueinfo (__NR_SYSCALL_BASE+363)
#define __NR_perf_event_open (__NR_SYSCALL_BASE+364)
#define __NR_recvmmsg (__NR_SYSCALL_BASE+365)
+#define __NR_accept4 (__NR_SYSCALL_BASE+366)
/*
* The following SWIs are ARM private.
diff --git a/arch/arm/kernel/calls.S b/arch/arm/kernel/calls.S
index 37ae301..afeb71f 100644
--- a/arch/arm/kernel/calls.S
+++ b/arch/arm/kernel/calls.S
@@ -375,6 +375,7 @@
CALL(sys_rt_tgsigqueueinfo)
CALL(sys_perf_event_open)
/* 365 */ CALL(sys_recvmmsg)
+ CALL(sys_accept4)
#ifndef syscalls_counted
.equ syscalls_padding, ((NR_syscalls + 3) & ~3) - NR_syscalls
#define syscalls_counted
--
1.6.6.1