mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/firefox fixes
This commit is contained in:
parent
559987212b
commit
899c384d29
3 changed files with 22 additions and 28 deletions
|
@ -10,7 +10,7 @@ highmem=1
|
|||
|
||||
pkgname=firefox
|
||||
pkgver=47.0.1
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
|
@ -34,9 +34,7 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
|
|||
mozilla-1245076-1.patch
|
||||
no-libnotify.patch
|
||||
no-neon.patch
|
||||
69f237c2cf91.patch::https://hg.mozilla.org/mozilla-central/raw-rev/69f237c2cf91
|
||||
a5919256fd5c.patch::https://hg.mozilla.org/mozilla-central/raw-rev/a5919256fd5c
|
||||
aarch64-no-static-sizes.patch)
|
||||
mozilla-1253216.patch)
|
||||
sha256sums=('5ac36c3481dde80ef2e36237badef6cb8ec5fe7e3b5ac1728839477de0cc034c'
|
||||
'039c7c5162ec19a5814c97e33f577e3074358484782181941e9629732456bc54'
|
||||
'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
|
||||
|
@ -48,9 +46,7 @@ sha256sums=('5ac36c3481dde80ef2e36237badef6cb8ec5fe7e3b5ac1728839477de0cc034c'
|
|||
'6e7cba25c52b246da183b8309e7b56208bd991d1a7adb40063c5702a6f3722ea'
|
||||
'e4ebdd14096d177d264a7993dbd5df46463605ff45f783732c26d30b9caa53a7'
|
||||
'c1cceeb8875eee7c61289e82c6c6b0f338c045152f3a5e1a8d87bad67548397f'
|
||||
'32e116fcd3ede2b4074fa169453216ca8ed71f93e67fbdc78e14c308b3f2a99c'
|
||||
'fb5f84100e01f127160a82797860cb0e04bb6da860a8343963ed45c44740ef0e'
|
||||
'b73d92a6e96b84464e1f675f8cac730a12cfc9701318a3a9ba46b3d34bfe7cb4')
|
||||
'1e7ef08acd46aeacc8cd8b2c89012983fb2c8c18648e0f3e9371b0c76caedbde')
|
||||
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -96,19 +92,16 @@ prepare() {
|
|||
echo "ac_add_options --with-mozilla-api-keyfile=\"$PWD/mozilla-api-key\"" >>.mozconfig
|
||||
|
||||
mkdir "$srcdir/path"
|
||||
|
||||
# WebRTC build tries to execute "python" and expects Python 2
|
||||
ln -s /usr/bin/python2 "$srcdir/path/python"
|
||||
|
||||
[[ $CARCH != "aarch64" ]] && echo "ac_add_options --disable-ion" >> .mozconfig
|
||||
[[ $CARCH != "aarch64" ]] && echo "ac_add_options --disable-ion" >> .mozconfig \
|
||||
&& echo "ac_add_options --disable-elf-hack" >> .mozconfig \
|
||||
&& echo "ac_add_options --disable-yarr-jit" >> .mozconfig
|
||||
[[ $CARCH == "aarch64" ]] && echo "ac_add_options --disable-gold" >> .mozconfig \
|
||||
&& echo 'ac_add_options --disable-jemalloc' >> .mozconfig \
|
||||
&& echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
|
||||
patch -p1 -i ../no-neon.patch
|
||||
|
||||
# AArch64 patches
|
||||
patch -p1 -i ../69f237c2cf91.patch
|
||||
patch -p1 -i ../a5919256fd5c.patch
|
||||
patch -p0 -i ../aarch64-no-static-sizes.patch
|
||||
patch -p2 -i ../mozilla-1253216.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -161,7 +154,7 @@ package() {
|
|||
ln -s /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
|
||||
ln -s /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
|
||||
|
||||
#workaround for now
|
||||
#https://bugzilla.mozilla.org/show_bug.cgi?id=658850
|
||||
# Replace duplicate binary with symlink
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
|
||||
ln -sf firefox "$pkgdir/usr/lib/firefox/firefox-bin"
|
||||
}
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- memory/mozjemalloc/jemalloc.c.orig 2016-03-21 19:00:39.971125884 -0600
|
||||
+++ memory/mozjemalloc/jemalloc.c 2016-03-21 18:59:22.474081051 -0600
|
||||
@@ -1089,7 +1089,7 @@
|
||||
* controlling the malloc behavior are defined as compile-time constants
|
||||
* for best performance and cannot be altered at runtime.
|
||||
*/
|
||||
-#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__)
|
||||
+#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__) && !defined(__aarch64__)
|
||||
#define MALLOC_STATIC_SIZES 1
|
||||
#endif
|
||||
|
12
extra/firefox/mozilla-1253216.patch
Normal file
12
extra/firefox/mozilla-1253216.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -up firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h.old firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h
|
||||
--- firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h.old 2016-03-01 09:45:01.000000000 +0100
|
||||
+++ firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h 2016-03-03 13:13:34.915015391 +0100
|
||||
@@ -305,7 +305,7 @@ AtomicOperations::isLockfree(int32_t siz
|
||||
|| defined(__ppc__) || defined(__PPC__)
|
||||
# include "jit/none/AtomicOperations-ppc.h"
|
||||
#elif defined(JS_CODEGEN_NONE)
|
||||
-# include "jit/none/AtomicOperations-none.h"
|
||||
+# include "jit/none/AtomicOperations-ppc.h"
|
||||
#elif defined(JS_CODEGEN_X86) || defined(JS_CODEGEN_X64)
|
||||
# include "jit/x86-shared/AtomicOperations-x86-shared.h"
|
||||
#else
|
Loading…
Reference in a new issue