mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/hardinfo
This commit is contained in:
parent
697c959247
commit
89c5889d2f
5 changed files with 86 additions and 0 deletions
46
community/hardinfo/PKGBUILD
Normal file
46
community/hardinfo/PKGBUILD
Normal file
|
@ -0,0 +1,46 @@
|
||||||
|
# $Id$
|
||||||
|
# Maintainer: Eric Bélanger <eric@archlinux.org>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - fixes for AArch64 from debian
|
||||||
|
|
||||||
|
pkgname=hardinfo
|
||||||
|
pkgver=0.5.1
|
||||||
|
pkgrel=7
|
||||||
|
pkgdesc="A system information and benchmark tool."
|
||||||
|
arch=('x86_64')
|
||||||
|
url="http://sourceforge.net/projects/hardinfo.berlios/"
|
||||||
|
license=('GPL2')
|
||||||
|
depends=('gtk2' 'libsoup')
|
||||||
|
options=('!emptydirs')
|
||||||
|
source=(http://sourceforge.net/projects/hardinfo.berlios/files/${pkgname}-${pkgver}.tar.bz2
|
||||||
|
fixsensors.patch hardinfo.distro hardinfo-gnu89.patch
|
||||||
|
aarch64.patch)
|
||||||
|
sha1sums=('983f0445aa60e02156bc5a5eaedeffb30b8e4d64'
|
||||||
|
'd2151dce76dca238102937d0e15541f172bca530'
|
||||||
|
'4c31cbbfbdeb48593641ff600c8d4fb7bda2b01c'
|
||||||
|
'7807fb252ad8391b61dfe1c3883ecdc232814091'
|
||||||
|
'4573fca8bb686b621596afe9d4ee79ac8f3acf4f')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd ${pkgname}-${pkgver}
|
||||||
|
patch -p1 -i "${srcdir}/fixsensors.patch"
|
||||||
|
sed -i 's|/usr/lib64|/usr/lib|' configure
|
||||||
|
sed -i 's|lib64|lib|' binreloc.c
|
||||||
|
sed -i 's|{ DB_PREFIX "debian_version", "deb" },|{ DB_PREFIX "hardinfo.distro", "arch" },{ DB_PREFIX "debian_version", "deb" },|' computer.h
|
||||||
|
patch -p1 -i ../hardinfo-gnu89.patch # Fix build (Debian)
|
||||||
|
ln -sf armv4l arch/linux/aarch64
|
||||||
|
patch -p1 -i ../aarch64.patch
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd ${pkgname}-${pkgver}
|
||||||
|
./configure --prefix=/usr
|
||||||
|
CFLAGS+=' -gnu89' make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd ${pkgname}-${pkgver}
|
||||||
|
make DESTDIR="${pkgdir}" install
|
||||||
|
install -D -m644 "${srcdir}/hardinfo.distro" "${pkgdir}/etc/hardinfo.distro"
|
||||||
|
}
|
14
community/hardinfo/aarch64.patch
Normal file
14
community/hardinfo/aarch64.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
Index: b/configure
|
||||||
|
===================================================================
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -66,6 +66,9 @@
|
||||||
|
sparc*)
|
||||||
|
ln -sf linux/sparc arch/this
|
||||||
|
ARCH="ARCH_SPARC" ;;
|
||||||
|
+ aarch64*)
|
||||||
|
+ ln -sf linux/aarch64 arch/this
|
||||||
|
+ ARCH="ARCH_AARCH64" ;;
|
||||||
|
armv*)
|
||||||
|
ln -sf linux/armv4l arch/this
|
||||||
|
ARCH="ARCH_ARMV4L" ;;
|
13
community/hardinfo/fixsensors.patch
Normal file
13
community/hardinfo/fixsensors.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff -upNr hardinfo-0.4.2.2.orign/util.c hardinfo-0.4.2.2/util.c
|
||||||
|
--- hardinfo-0.4.2.2.orign/util.c 2007-07-20 16:45:08.000000000 +0200
|
||||||
|
+++ hardinfo-0.4.2.2/util.c 2007-07-26 10:15:32.000000000 +0200
|
||||||
|
@@ -996,7 +996,8 @@ gchar *h_strdup_cprintf(const gchar * fo
|
||||||
|
if (source) {
|
||||||
|
retn = g_strconcat(source, buffer, NULL);
|
||||||
|
g_free(buffer);
|
||||||
|
- g_free(source);
|
||||||
|
+ if(strlen(source))
|
||||||
|
+ g_free(source);
|
||||||
|
} else {
|
||||||
|
retn = buffer;
|
||||||
|
}
|
12
community/hardinfo/hardinfo-gnu89.patch
Normal file
12
community/hardinfo/hardinfo-gnu89.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
diff --git a/Makefile.in b/Makefile.in
|
||||||
|
index 03a9df8..2c69fe9 100644
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
|
||||||
|
CCFLAGS = -fPIC -pipe -Wall -g
|
||||||
|
-CFLAGS = $(GTK_CFLAGS) $(SOUP_CFLAGS) -I.
|
||||||
|
+CFLAGS = $(GTK_CFLAGS) $(SOUP_CFLAGS) -I. -std=gnu89
|
||||||
|
CC = gcc $(ARCHOPTS) -g
|
||||||
|
CCSLOW = gcc -O0 -g
|
||||||
|
|
1
community/hardinfo/hardinfo.distro
Normal file
1
community/hardinfo/hardinfo.distro
Normal file
|
@ -0,0 +1 @@
|
||||||
|
Arch Linux
|
Loading…
Reference in a new issue