removed extra/libinput

This commit is contained in:
Kevin Mihelich 2017-07-06 18:26:35 +00:00
parent 779172d538
commit 89d3241b32
5 changed files with 0 additions and 185 deletions

View file

@ -1,33 +0,0 @@
From b29b47c0c89d33306227556f7fe3aee620e0e47c Mon Sep 17 00:00:00 2001
From: Paul Kocialkowski <contact@paulk.fr>
Date: Fri, 21 Apr 2017 13:31:56 +0200
Subject: [PATCH 1/4] udev: Add name-based input device detection without dmi
Some devices do not use dmi at all (this is the case on most non-x86
platforms, such as arm and arm64) but should able to select specific
quirks based on the input device name too.
This adds name-based input device detection without dmi to support
these devices.
Signed-off-by: Paul Kocialkowski <contact at paulk.fr>
---
udev/90-libinput-model-quirks.rules.in | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/udev/90-libinput-model-quirks.rules.in b/udev/90-libinput-model-quirks.rules.in
index 8bff192..149ef0d 100644
--- a/udev/90-libinput-model-quirks.rules.in
+++ b/udev/90-libinput-model-quirks.rules.in
@@ -37,4 +37,8 @@ ENV{ID_INPUT_MOUSE}=="1", \
KERNELS=="input*", \
IMPORT{builtin}="hwdb 'libinput:name:$attr{name}:$attr{[dmi/id]modalias}'"
+# libinput:name:<name>
+KERNELS=="input*", \
+ IMPORT{builtin}="hwdb 'libinput:name:$attr{name}'"
+
LABEL="libinput_model_quirks_end"
--
2.12.2

View file

@ -1,33 +0,0 @@
From bf5b10b31d23682d1fc1333e9094e902dcc7150a Mon Sep 17 00:00:00 2001
From: Paul Kocialkowski <contact@paulk.fr>
Date: Fri, 21 Apr 2017 13:31:57 +0200
Subject: [PATCH 2/4] udev: Add support for I2C Elan touchpads (without dmi)
This adds support for I2C Elan touchpads, such as the ones found in
various ARM CrOS devices. These devices do not use dmi.
The pressure range is copied as-is from the current Elantech PS/2
touchpads entry. It is not adapted to every touchpad configuration.
Signed-off-by: Paul Kocialkowski <contact at paulk.fr>
---
udev/90-libinput-model-quirks.hwdb | 3 +++
1 file changed, 3 insertions(+)
diff --git a/udev/90-libinput-model-quirks.hwdb b/udev/90-libinput-model-quirks.hwdb
index 560e77a..8cf3304 100644
--- a/udev/90-libinput-model-quirks.hwdb
+++ b/udev/90-libinput-model-quirks.hwdb
@@ -90,6 +90,9 @@ libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*
libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*svnASUSTeKComputerInc.:pnUX21E:*
LIBINPUT_ATTR_PRESSURE_RANGE=24:10
+libinput:name:*Elan Touchpad*
+ LIBINPUT_ATTR_PRESSURE_RANGE=24:8
+
##########################################
# Google
##########################################
--
2.12.2

View file

@ -1,32 +0,0 @@
From 43cba4ba6cdad42faa878008036a75a5049c95d6 Mon Sep 17 00:00:00 2001
From: Paul Kocialkowski <contact@paulk.fr>
Date: Fri, 21 Apr 2017 13:31:58 +0200
Subject: [PATCH 3/4] udev: Decrease high pressure value for Elantech touchpads
The high pressure value for Elantech touchpads (both PS/2 and I2C) is
not adapted to various devices, on which the touchpad is barely usable.
Decreasing the high value makes those devices usable again, while not
introducing any major drawback for other devices.
Signed-off-by: Paul Kocialkowski <contact at paulk.fr>
---
udev/90-libinput-model-quirks.hwdb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/udev/90-libinput-model-quirks.hwdb b/udev/90-libinput-model-quirks.hwdb
index 8cf3304..d9f0022 100644
--- a/udev/90-libinput-model-quirks.hwdb
+++ b/udev/90-libinput-model-quirks.hwdb
@@ -91,7 +91,7 @@ libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*svnASUSTeKComputerInc.:pnUX21E:*
LIBINPUT_ATTR_PRESSURE_RANGE=24:10
libinput:name:*Elan Touchpad*
- LIBINPUT_ATTR_PRESSURE_RANGE=24:8
+ LIBINPUT_ATTR_PRESSURE_RANGE=10:8
##########################################
# Google
--
2.12.2

View file

@ -1,28 +0,0 @@
From 3d319e3a09dbd366d2721844cf6fb5d91adc76c0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 23 Apr 2017 16:56:55 -0600
Subject: [PATCH 4/4] Don't pair touchpad and lid switch
Kills Xorg immediately upon any touchpad or keyboard entry on the Samsung Chromebook Plus.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
src/evdev-mt-touchpad.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/evdev-mt-touchpad.c b/src/evdev-mt-touchpad.c
index a35688b..2243682 100644
--- a/src/evdev-mt-touchpad.c
+++ b/src/evdev-mt-touchpad.c
@@ -1638,7 +1638,7 @@ tp_interface_device_added(struct evdev_device *device,
tp_pair_trackpoint(device, added_device);
tp_dwt_pair_keyboard(device, added_device);
- tp_pair_lid_switch(device, added_device);
+ /*tp_pair_lid_switch(device, added_device);*/
if (tp->sendevents.current_mode !=
LIBINPUT_CONFIG_SEND_EVENTS_DISABLED_ON_EXTERNAL_MOUSE)
--
2.12.2

View file

@ -1,59 +0,0 @@
# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Maintainer: Jan de Groot
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - add proposed upstream patches to fix Elan I2C touchpads
# - patch to not crash Xorg on the Chromebook Plus
pkgname=libinput
pkgver=1.7.3
pkgrel=1
pkgdesc="Input device management and event handling library"
arch=(i686 x86_64)
url="https://www.freedesktop.org/wiki/Software/libinput/"
license=(custom:X11)
depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
# currently no doc files to install
makedepends=('doxygen' 'graphviz' 'gtk3')
#checkdepends=('check' 'libunwind')
source=(https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
0001-udev-Add-name-based-input-device-detection-without-d.patch
0002-udev-Add-support-for-I2C-Elan-touchpads-without-dmi.patch
0003-udev-Decrease-high-pressure-value-for-Elantech-touch.patch
0004-Don-t-pair-touchpad-and-lid-switch.patch)
sha512sums=('2262dc56d213a4d3ea765e870af200e2c336a166baa1bbdf5205e3ce70faefc777429ba09563c5dd79feb5442f53abc84e04a0f32a06bb622d6e120bb8ad152b'
'SKIP'
'3c696a723fd1cc32fd851cb8daea47c629d7245c9190e3086813f81ad54197e2e95fc79df4e6ebb956fed539b362a058d4cfb53f364a1ecaba1cbd5cac7a4cab'
'14a9081f6ca2741d43142251bf38fbd9af445d671472a137e97ccd3827bf01feb076b95c459bcd7947757d919254913fc8c8496976ee5f6f4a4ed5713f7b6f8c'
'f75895141ef2f78c7ccecbc4b08437c1c4e27078ed7bc52751d3f0b3693ca2820c85aacb4435d4fe950d43ea940e90896c55423a80698762d20b740a64f12884'
'db8d684d3370e860764b52cc4f2287630cf58dad337684a7ae485957b8cec54cd2da47e27b5c8eefa42f753d366a4cda3d957cf0514087b3013ac7562fa785f3')
validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../0001-udev-Add-name-based-input-device-detection-without-d.patch
patch -p1 -i ../0002-udev-Add-support-for-I2C-Elan-touchpads-without-dmi.patch
patch -p1 -i ../0003-udev-Decrease-high-pressure-value-for-Elantech-touch.patch
patch -p1 -i ../0004-Don-t-pair-touchpad-and-lid-switch.patch
}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr --disable-static
make
}
check() {
cd $pkgname-$pkgver
make check
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
# install doc - no Makefile target
install -v -dm755 ${pkgdir}/usr/share/doc/libinput
cp -rv doc/html/* ${pkgdir}/usr/share/doc/libinput
}