mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/rust to 1.51.0-1
This commit is contained in:
parent
bee3f1f13b
commit
8a1f156f84
2 changed files with 12 additions and 12 deletions
|
@ -14,11 +14,11 @@ Add aliases to match.
|
|||
3 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
index 083c115d084..2c20bca80bc 100644
|
||||
index 656136c4972..fea9aadfbd4 100644
|
||||
--- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
@@ -8,7 +8,7 @@ pub fn target() -> Target {
|
||||
base.stack_probes = true;
|
||||
@@ -9,7 +9,7 @@ pub fn target() -> Target {
|
||||
base.stack_probes = StackProbeType::Call;
|
||||
|
||||
Target {
|
||||
- llvm_target: "i686-unknown-linux-gnu".to_string(),
|
||||
|
@ -27,10 +27,10 @@ index 083c115d084..2c20bca80bc 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index 8d72df6850f..367ceab88ee 100644
|
||||
index 7a93bac72ca..cb844be88a3 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -1812,6 +1812,9 @@ macro_rules! target_aliases {
|
||||
@@ -1995,6 +1995,9 @@ macro_rules! target_aliases {
|
||||
}
|
||||
|
||||
target_aliases! {
|
||||
|
@ -41,11 +41,11 @@ index 8d72df6850f..367ceab88ee 100644
|
|||
// (See <https://github.com/rust-lang/rust/issues/40531>.)
|
||||
("x86_64-pc-solaris", "x86_64-sun-solaris"),
|
||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
index f127dd49bc4..a958e4fc11d 100644
|
||||
index 2ba6d368484..7322745d9f6 100644
|
||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
@@ -8,7 +8,7 @@ pub fn target() -> Target {
|
||||
base.stack_probes = true;
|
||||
@@ -9,7 +9,7 @@ pub fn target() -> Target {
|
||||
base.stack_probes = StackProbeType::Call;
|
||||
|
||||
Target {
|
||||
- llvm_target: "x86_64-unknown-linux-gnu".to_string(),
|
||||
|
|
|
@ -16,8 +16,8 @@ highmem=1
|
|||
|
||||
pkgname=('rust' 'rust-docs')
|
||||
epoch=1
|
||||
pkgver=1.50.0
|
||||
pkgrel=2
|
||||
pkgver=1.51.0
|
||||
pkgrel=1
|
||||
|
||||
_llvm_ver=11.1.0
|
||||
|
||||
|
@ -38,11 +38,11 @@ source=(
|
|||
0001-Change-LLVM-targets.patch
|
||||
libexec.diff
|
||||
)
|
||||
sha256sums=('95978f8d02bb6175ae3238930baf03563c240aedf9a70bebdc3eaa2a8c3c5a5e'
|
||||
sha256sums=('7a6b9bafc8b3d81bbc566e7c0d1f17c9f499fd22b95142f7ea3a8e4d1f9eb847'
|
||||
'SKIP'
|
||||
'def1fc00c764cd3abbba925c712ac38860a756a43b696b291f46fee09e453274'
|
||||
'SKIP'
|
||||
'66a4792e0169969c23e229d96c88374be0ac24b93ef17102b504892e968959fa'
|
||||
'3703c3defd3af5498a492f80fbb0b0b67c58a5ce0d1bab51328e65598141b745'
|
||||
'9ba3070dbc877ab5e045b6a20be9134f80d8aece42766b4cfbad2a4a60c27514')
|
||||
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
'474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
|
||||
|
|
Loading…
Reference in a new issue