core/pacman to 6.1.0-3

This commit is contained in:
Kevin Mihelich 2024-03-16 00:14:20 +00:00
parent 6c4f047f15
commit 8a41d6b3c5
5 changed files with 66 additions and 67 deletions

View file

@ -1,4 +1,4 @@
From a2da301a5e247c33ea9f925c269346b610a5383f Mon Sep 17 00:00:00 2001
From 638921aedf3a512ee272e7fc1a012acf615d2ace Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Sep 2014 18:58:16 -0600
Subject: [PATCH 1/3] Sychronize filesystem
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+)
diff --git a/lib/libalpm/trans.c b/lib/libalpm/trans.c
index f22f9bf9..04f94dab 100644
index 5e2458e9..043b6305 100644
--- a/lib/libalpm/trans.c
+++ b/lib/libalpm/trans.c
@@ -237,6 +237,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
@@ -241,6 +241,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
trans->state = STATE_COMMITED;
@ -28,5 +28,5 @@ index f22f9bf9..04f94dab 100644
}
--
2.30.1
2.36.1

View file

@ -1,4 +1,4 @@
From 2cf9026a6b56ffa56d54554538a17c9162090045 Mon Sep 17 00:00:00 2001
From 6e5837e7e451b3f2b87582c922abc610db9e0b40 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 30 Jan 2016 17:19:03 -0700
Subject: [PATCH 2/3] Revert "close stdin before running install scripts"
@ -16,10 +16,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 deletion(-)
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
index 299d287e..82e01c5a 100644
index 83160f00..579d5093 100644
--- a/lib/libalpm/util.c
+++ b/lib/libalpm/util.c
@@ -635,7 +635,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -640,7 +640,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
if(pid == 0) {
/* this code runs for the child only (the actual chroot/exec) */
@ -28,5 +28,5 @@ index 299d287e..82e01c5a 100644
close(2);
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
--
2.30.1
2.36.1

View file

@ -1,4 +1,4 @@
From 83d11b75aa34cebe97bf6d31714870ca9c4cea78 Mon Sep 17 00:00:00 2001
From e237b55a291cdcc5d52e55b896fc437f8ed922c8 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 11 Mar 2016 20:11:24 -0700
Subject: [PATCH 3/3] Revert "alpm_run_chroot: always connect parent2child
@ -10,10 +10,10 @@ This reverts commit 1d6583a58da0904fb7feafd4a666391087955a7b.
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
index 82e01c5a..1457535d 100644
index 579d5093..02145ba7 100644
--- a/lib/libalpm/util.c
+++ b/lib/libalpm/util.c
@@ -619,7 +619,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -624,7 +624,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
goto cleanup;
}
@ -22,7 +22,7 @@ index 82e01c5a..1457535d 100644
_alpm_log(handle, ALPM_LOG_ERROR, _("could not create pipe (%s)\n"), strerror(errno));
retval = 1;
goto cleanup;
@@ -639,9 +639,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -644,9 +644,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
close(2);
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
while(dup2(child2parent_pipefd[HEAD], 2) == -1 && errno == EINTR);
@ -37,7 +37,7 @@ index 82e01c5a..1457535d 100644
close(child2parent_pipefd[TAIL]);
close(child2parent_pipefd[HEAD]);
if(cwdfd >= 0) {
@@ -678,16 +680,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -693,16 +695,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
child2parent->events = POLLIN;
fcntl(child2parent->fd, F_SETFL, O_NONBLOCK);
close(child2parent_pipefd[HEAD]);
@ -56,5 +56,5 @@ index 82e01c5a..1457535d 100644
#define STOP_POLLING(p) do { close(p->fd); p->fd = -1; } while(0)
--
2.30.1
2.36.1

View file

@ -2,16 +2,16 @@
# Maintainer: Morten Linderud <foxboron@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - arch/host/flags for arm, armv6h, armv7h, and aarch64
# - pacman.conf: architecture=arm/armv6h/armv7h/aarch64, added our aur and alarm repos
# - makepkg.conf: adjusted C/CXX/LDFLAGS, drop -z,now for armv5
# - arch/host/flags for armv7h, and aarch64
# - pacman.conf: architecture=armv7h/aarch64, added our aur and alarm repos
# - makepkg.conf: adjusted C/CXX/LDFLAGS
# - patch to sync filesystem after install/remove
# - reverts to allow scriplet input on stdin
# - patch to fix application/gzip change in file 5.37
pkgname=pacman
pkgver=6.0.2
pkgrel=9
pkgver=6.1.0
pkgrel=3
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
url="https://www.archlinux.org/pacman/"
@ -27,60 +27,54 @@ backup=(etc/pacman.conf
options=('strip')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.xz{,.sig}
pacman-always-create-directories-from-debugedit.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/efd0c24c07b86be014a4edb5a8ece021b87e3900.patch
pacman-always-create-directories-from-debugedit-fixup.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/86981383a2f4380bda26311831be94cdc743649b.patch
pacman-fix-unique-source-paths.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/478af273dfe24ded197ec54ae977ddc3719d74a0.patch
pacman-strip-include-o-files-similar-to-kernel-modules.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/de11824527ec4e2561e161ac40a5714ec943543c.patch
pacman-fix-compatibility-with-bash-5.2-patsub_replacement.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/0e938f188692c710be36f9dd9ea7b94381aed1b4.patch
pacman-fix-order-of-fakechroot-fakeroot-nesting.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/05f283b5ad8f5b8f995076e93a27c8772076f872.patch
pacman-change-default-checksum-from-md5-to-sha256.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/aa3a1bc3b50d797fb75278f79a83cd7dde50c66e.patch
pacman-sort-debuginfod-repro.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/843bf21e794c79c5b3bcf8a57e45ef9c62312fee.patch
pacman-split-off-strip-debug.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/7a4fff3310ba2eadd3d5428cbb92e58eb2ee853b.patch
pacman-ignore-a-files.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/00d2b1f90261bf77eaaf262d2504af016562f2ac.patch
pacman-early-err-git.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/3aa096a74f717d31650e0eb3cf34e9a5ebadc313.patch
pacman-fix-gnupg-binary-data.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/86ec26b2d33372a4b3bda48f22c4a9f226c3ccce.patch
pacman-fix-gnupg-newsig-check.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/16a064701a30d7e1175e1185cc6da44238302fab.patch
pacman-check-pipes-gnupg.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/f8c2e59ec57c86827b1f1b1c2f6760dc3e59fe40.patch
source=(https://gitlab.archlinux.org/pacman/pacman/-/releases/v$pkgver/downloads/pacman-$pkgver.tar.xz{,.sig}
revertme-makepkg-remove-libdepends-and-libprovides.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/354a300cd26bb1c7e6551473596be5ecced921de.patch
"$pkgname-fix-msg-unknown-key.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/6bb95c8856437513ee0ab19226bc090d6fd0fb06.patch"
"$pkgname-man-gitlab.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/95f148c2222db608a0d72d5c5577d0c71e7fa199.patch"
"$pkgname-make-aligned-titles.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/5e0496260b7d3f9c9fcf2b1c4899e4dbcc20ff03.patch"
"$pkgname-repo-add-parseopts.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/0571ee82bff0edbd5ffac2228d4e6ac510b9008e.patch"
"$pkgname-drop-result-warn.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/111eed0251238a9d3f90e76d62f2ac01aeccce48.patch"
"$pkgname-fix-debugedit.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/bae9594ac1806ce30f2af1de27c49bb101a00d44.patch"
0001-Sychronize-filesystem.patch
0002-Revert-close-stdin-before-running-install-scripts.patch
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
pacman.conf
makepkg.conf)
sha256sums=('7d8e3e8c5121aec0965df71f59bedf46052c6cf14f96365c4411ec3de0a4c1a5'
sha256sums=('5a60ac6e6bf995ba6140c7d038c34448df1f3daa4ae7141d2cad88eeb5f1f9d9'
'SKIP'
'6fed94326b9ecfbb438ab17a4576b5e9d52ecc0f4574f29d46adfde3886dee03'
'd2bc104788290e3de829a232590b66ad745cf5b4762a01acc1191ebf70fef114'
'f3d4f39ef24e312f610cbb3439fb02bc6b8829e37bcf1a50ae50cd0a69bde5d0'
'd87d0c9957c613fda272553bee58140349d151ae399f346ddaf6d75ee5916312'
'8641d514ef4cae9e4d1867aadf4b9c850a9e8dc9792c6c559f9d2a0e1713a5a1'
'b11f62d4bd9557e9d3e7456bc95f63e9eabab5ecee1368f4a14a84bc94b1c8d1'
'cf749ad981e8f3dedd89c05a5e69a9c91d1e58ef9407e8f8e04ba9c183939623'
'17e7af22533984924aaf1cf36c74aa26b46b04ad140cd76b65521be906bd3ff7'
'94d1f3575d0c3faf8bf11fee8e5ef36c8b339ebfd24868931903ba179ffecf4e'
'96efb79a96abf8cdcecb9f8dc461552549cf46159f44bb4160eb073e1ea5000a'
'0ac6a34e6fc126a243a642e509f459f6cde20af213ab949791a5cc325cf031f9'
'6e81b34e6a5f312d48ce3aaca0f02ddd10b7a43325cb32acf7666b6b7ac41552'
'250598a27a3077ec1dfe97a30af8bb0daf449d3ab456ed6a0c7a5bea0eb58f51'
'94c273f07e4e28125b6002567c62e1f6c65f543597de6a8bd79e8c5bf6e4a125'
'ba91c92fbae492be13df12dd34e22b00e1a63c706fdd328e8d9a907c5d517e71'
'bb8d53dd1136c314aacbc275f36936112d04ec6c0ebc882eefe6e46bd86e6db5'
'11b3ed535d0cb981ce5927ed9b308615e4f6b6a8e2aef6e2e15a59df956bfdab'
'b3bce9d662e189e8e49013b818f255d08494a57e13fc264625f852f087d3def2'
'94c987046c2ff232fa0d395cddc11644840d767806711e04ef34f876a9baf217'
'0774d7035e34661f74b673d4b0a94be877bdc0158a555b873ec6bd4e2c936377'
'7bb64910265ce2590f593cdfd302076e49f67a68f8cc792a9aaac572d36fc842'
'2bbfe40539513ff5775aaf900644c8985ef618f5df9af856b9d571e2501365b0'
'160515b741aadc876a67f213029f5f62a51ff072ea4aaeb687bbe614035bf72f'
'1f4e4cc54332e60c9da2bdabf9a80dc11db466535f1a0be298cbf654f0723721'
'98b500555072c84fb5c55a860685adf99eb3bdf674bf11855a9e9920746363fb'
'64e56e6f66f935029bb7c81382b98b71a39a69c13b1e4f80455fdbb1718e051e'
'd344075eb0d5a0aefb1aed27eb337be78221080808f9f516215d675bcdd27ca2'
'6456e1ad704565d1e401b2b94fcfd1c75be290aa92ac9437343625209e7793ab'
'963936676b07ba2fe5a0af00d0b3c49b2d1f0575f902534efbb94c4a45d77cfd')
'72969c7f4ce130e3424f28f3b300abea62d07450cd83b107f2f66c3c66330c00')
prepare() {
cd "$pkgname-$pkgver"
# we backport way too often in pacman
# lets at least make it more convenient
local src
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
msg2 "Applying patch $src..."
patch -Np1 < "../$src"
done
# handle patches
local -a patches
patches=($(printf '%s\n' "${source[@]}" | grep '.patch'))
patches=("${patches[@]%%::*}")
patches=("${patches[@]##*/}")
if (( ${#patches[@]} != 0 )); then
for patch in "${patches[@]}"; do
if [[ $patch =~ revertme-* ]]; then
msg2 "Reverting patch $patch..."
patch -RNp1 < "../$patch"
else
msg2 "Applying patch $patch..."
patch -Np1 < "../$patch"
fi
done
fi
}
build() {

View file

@ -43,10 +43,12 @@ CHOST="@CHOST@"
# -mtune optimizes for an architecture, but builds for whole processor family
CPPFLAGS=""
CFLAGS="@CARCHFLAGS@-O2 -pipe -fstack-protector-strong -fno-plt -fexceptions \
-Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
-fstack-clash-protection"
-Wp,-D_FORTIFY_SOURCE=3 -Wformat -Werror=format-security \
-fstack-clash-protection \
-fno-omit-frame-pointer -mno-omit-leaf-frame-pointer"
CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now \
-Wl,-z,pack-relative-relocs"
LTOFLAGS=""
RUSTFLAGS=""
#-- Make Flags: change this for DistCC/SMP systems
@ -83,7 +85,7 @@ BUILDENV=(!distcc color !ccache check !sign)
# These are default values for the options=() settings
#########################################################################
#
# Makepkg defaults: OPTIONS=(!strip docs libtool staticlibs emptydirs !zipman !purge !debug !lto)
# Makepkg defaults: OPTIONS=(!strip docs libtool staticlibs emptydirs !zipman !purge !debug !lto !autodeps)
# A negated option will do the opposite of the comments below.
#
#-- strip: Strip symbols from binaries/libraries
@ -95,6 +97,7 @@ BUILDENV=(!distcc color !ccache check !sign)
#-- purge: Remove files specified by PURGE_TARGETS
#-- debug: Add debugging flags as specified in DEBUG_* variables
#-- lto: Add compile flags for building with link time optimization
#-- autodeps: Automatically add depends/provides
#
OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !debug !lto)
@ -114,6 +117,8 @@ DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
#-- Directory to store source code in for debug packages
DBGSRCDIR="/usr/src/debug"
#-- Prefix and directories for library autodeps
LIB_DIRS=('lib:usr/lib')
#########################################################################
# PACKAGE OUTPUT