community/openimageio to 1.4.16-2

This commit is contained in:
Kevin Mihelich 2015-03-16 00:03:24 +00:00
parent bf93d19150
commit 8a4939e350
2 changed files with 24 additions and 6 deletions

View file

@ -6,7 +6,7 @@
# - removed intel-tbb from deps, set -DUSE_TBB=0
pkgname=openimageio
pkgver=1.4.15
pkgver=1.4.16
pkgrel=2
pkgdesc="A library for reading and writing images, including classes, utilities, and applications"
arch=(i686 x86_64)
@ -16,15 +16,15 @@ depends=('openexr' 'boost-libs' 'jasper' 'glew' 'libtiff' 'opencolorio')
makedepends=('cmake' 'qt4' 'python2' 'boost' 'mesa' 'git')
optdepends=('qt4: iv image viewer'
'python2: bindings support')
source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver})
md5sums=('SKIP')
source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver}
stdmath.patch)
md5sums=('SKIP'
'7b819bf20cf2c13cbde5fc6511e39f35')
prepare() {
cd oiio
curl "https://github.com/OpenImageIO/oiio/commit/e1150f22f012d8d86f14534eda14bec960e96f3e.patch"|patch -Np1
# https://github.com/OpenImageIO/oiio/issues/987
#git revert -n 6f0e019
patch -Np1 < $srcdir/stdmath.patch
}
build() {

View file

@ -0,0 +1,18 @@
diff --git a/src/include/OpenImageIO/fmath.h b/src/include/OpenImageIO/fmath.h
index 8db8442..751cd07 100644
--- a/src/include/OpenImageIO/fmath.h
+++ b/src/include/OpenImageIO/fmath.h
@@ -1298,9 +1298,9 @@ OIIO_NAMESPACE_EXIT
#ifndef _MSC_VER
// Some systems have isnan, isinf and isfinite in the std namespace.
- using std::isnan;
- using std::isinf;
- using std::isfinite;
+ using ::isnan;
+ using ::isinf;
+ using OIIO::isfinite;
#endif
#if (defined(__FreeBSD__) && (__FreeBSD_version < 803000))