Added older extra/mono

This commit is contained in:
Kevin Mihelich 2011-03-10 21:58:46 -05:00
parent 9313c9b4bf
commit 8a653014da
4 changed files with 106 additions and 0 deletions

47
extra/mono/PKGBUILD Normal file
View file

@ -0,0 +1,47 @@
# $Id$
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
# Contributor: Brice Carpentier <brice@dlfp.org>
plugrel=1
noautobuild=1
pkgname=mono
pkgver=2.8.2
pkgrel=1
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
arch=(i686 x86_64)
license=('GPL' 'LGPL2' 'MPL' 'custom:MITX11')
url="http://www.mono-project.com/"
depends=('zlib' 'libgdiplus>=2.8.1' 'sh')
makedepends=('pkgconfig')
options=('!libtool' '!makeflags')
provides=('monodoc')
conflicts=('monodoc')
source=(http://ftp.novell.com/pub/mono/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2
mono.rc.d)
md5sums=('7ae9055a378b1b1579e4a1997d3ed4c2'
'8315e46c6a6e9625502521fc0ad1a322')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
# build mono
./configure --prefix=/usr --sysconfdir=/etc \
--with-libgdiplus=installed
make || return 1
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install || return 1
# install daemons and pathes
mkdir -p ${pkgdir}/etc/rc.d
install -m755 ${srcdir}/mono.rc.d ${pkgdir}/etc/rc.d/mono
#install license
mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
install -m644 mcs/MIT.X11 ${pkgdir}/usr/share/licenses/${pkgname}/
#fix .pc file to be able to request mono on what it depends, fixes #go-oo build
sed -i -e "s:#Requires:Requires:" ${pkgdir}/usr/lib/pkgconfig/mono.pc
}

View file

@ -0,0 +1,11 @@
--- trunk/mcs/class/System.Web.Services/System.Web.Services.Description/BasicProfileChecker.cs 2008/07/01 20:17:46 107006
+++ trunk/mcs/class/System.Web.Services/System.Web.Services.Description/BasicProfileChecker.cs 2008/10/28 09:32:46 117243
@@ -177,7 +177,7 @@
foreach (OperationMessage om in op.Messages) {
Message msg = ctx.Services.GetMessage (om.Message);
foreach (MessagePart part in msg.Parts)
- parts.Add (part,part);
+ parts [part] = part; // do not use Add() - there could be the same MessagePart instance.
}
}

View file

@ -0,0 +1,13 @@
--- mono/mini/mini-amd64.c 2009-03-19 21:08:18 UTC (rev 129824)
+++ mono/mini/mini-amd64.c 2009-03-19 21:09:53 UTC (rev 129825)
@@ -1009,7 +1009,7 @@
locals_size += mono_type_size (ins->inst_vtype, &ialign);
}
- if ((cfg->num_varinfo > 10000) || (locals_size >= (1 << 15))) {
+ if ((cfg->num_varinfo > 5000) || (locals_size >= (1 << 15)) || (header->code_size > 110000)) {
/* Avoid hitting the stack_alloc_size < (1 << 16) assertion in emit_epilog () */
cfg->arch.omit_fp = FALSE;
}

35
extra/mono/mono.rc.d Normal file
View file

@ -0,0 +1,35 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
case "$1" in
start)
stat_busy "Registering .NET IL binaries with mono"
if [ ! -d /proc/sys/fs/binfmt_misc ]; then
stat_die "You need support for \"misc binaries\" in your kernel!"
fi
mount | grep -q binfmt_misc
if [ $? != 0 ]; then
mount -t binfmt_misc binfmt_misc /proc/sys/fs/binfmt_misc
if [ $? != 0 ]; then
stat_die
fi
fi
echo ':CLR:M::MZ::/usr/bin/mono:' > /proc/sys/fs/binfmt_misc/register
stat_done
;;
stop)
stat_busy "Unregistering .NET IL binaries"
if [ -f /proc/sys/fs/binfmt_misc/CLR ]; then
echo '-1' > /proc/sys/fs/binfmt_misc/CLR
fi
stat_done
;;
restart)
$0 stop
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
esac