mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added community/libvpx1.3
This commit is contained in:
parent
6ea6f1abbf
commit
8a6eaea583
3 changed files with 151 additions and 0 deletions
63
community/libvpx1.3/PKGBUILD
Normal file
63
community/libvpx1.3/PKGBUILD
Normal file
|
@ -0,0 +1,63 @@
|
|||
# $Id$
|
||||
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Contributor: Fabio Castelli <muflone@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix building
|
||||
# - disable neon
|
||||
|
||||
pkgname=libvpx1.3
|
||||
pkgver=1.3.0
|
||||
pkgrel=1
|
||||
pkgdesc='VP8 and VP9 codec'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://www.webmproject.org/'
|
||||
license=('BSD')
|
||||
depends=('glibc')
|
||||
makedepends=('yasm' 'git')
|
||||
provides=('libvpx.so')
|
||||
source=("libvpx-${pkgver}.tar.gz::https://github.com/webmproject/libvpx/archive/v${pkgver}.tar.gz"
|
||||
'libvpx-1.3-gcc-5.2.patch'
|
||||
'fix-armhf-link.patch')
|
||||
sha256sums=('db72881e1c34e4ae92666847844f35dd2dd431bcf6284500b1b396464f882f64'
|
||||
'df157b8f0e4469692598f5f12b305561a56a84374880ef740ccb8f0b447851e1'
|
||||
'caa188558c36888eb169844b3296039bebf053960257a0581f9dadb41f770eaa')
|
||||
|
||||
prepare() {
|
||||
cd libvpx-${pkgver}
|
||||
|
||||
patch -Np1 -i ../libvpx-1.3-gcc-5.2.patch
|
||||
patch -Np1 -i ../fix-armhf-link.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd libvpx-${pkgver}
|
||||
|
||||
[[ $CARCH != "aarch64" ]] && CONFIG="--disable-neon"
|
||||
|
||||
./configure \
|
||||
--prefix='/usr' \
|
||||
--enable-runtime-cpu-detect \
|
||||
--enable-shared \
|
||||
--enable-pic \
|
||||
--disable-install-docs \
|
||||
--disable-install-srcs \
|
||||
--enable-vp8 \
|
||||
--enable-postproc \
|
||||
--enable-vp9 $CONFIG
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd libvpx-${pkgver}
|
||||
|
||||
make DIST_DIR="${pkgdir}"/usr install
|
||||
rm -rf "${pkgdir}"/usr/{bin,include,lib/{libvpx.{a,so},pkgconfig},share}
|
||||
|
||||
install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/libvpx1.3/
|
||||
}
|
||||
|
||||
# vim: ts=2 sw=2 et:
|
64
community/libvpx1.3/fix-armhf-link.patch
Normal file
64
community/libvpx1.3/fix-armhf-link.patch
Normal file
|
@ -0,0 +1,64 @@
|
|||
diff -urN a/build/make/configure.sh b/build/make/configure.sh
|
||||
--- a/build/make/configure.sh 2013-12-07 14:22:52.597542382 -0700
|
||||
+++ b/build/make/configure.sh 2013-12-07 14:26:51.541053756 -0700
|
||||
@@ -601,10 +601,14 @@
|
||||
|
||||
# detect tgt_isa
|
||||
case "$gcctarget" in
|
||||
+ armv6*-gnueabihf)
|
||||
+ tgt_isa=armv6
|
||||
+ float_abi=hard
|
||||
+ ;;
|
||||
armv6*)
|
||||
tgt_isa=armv6
|
||||
;;
|
||||
- armv7*-hardfloat*)
|
||||
+ armv7*-gnueabihf)
|
||||
tgt_isa=armv7
|
||||
float_abi=hard
|
||||
;;
|
||||
@@ -614,6 +618,7 @@
|
||||
;;
|
||||
armv5te*)
|
||||
tgt_isa=armv5te
|
||||
+ float_abi=soft
|
||||
;;
|
||||
*x86_64*|*amd64*)
|
||||
tgt_isa=x86_64
|
||||
@@ -799,7 +804,6 @@
|
||||
|
||||
case ${tgt_cc} in
|
||||
gcc)
|
||||
- CROSS=${CROSS:-arm-none-linux-gnueabi-}
|
||||
link_with_cc=gcc
|
||||
setup_gnu_toolchain
|
||||
arch_int=${tgt_isa##armv}
|
||||
@@ -807,13 +811,6 @@
|
||||
check_add_asflags --defsym ARCHITECTURE=${arch_int}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} = "armv7" ]; then
|
||||
- if [ -z "${float_abi}" ]; then
|
||||
- check_cpp <<EOF && float_abi=hard || float_abi=softfp
|
||||
-#ifndef __ARM_PCS_VFP
|
||||
-#error "not hardfp"
|
||||
-#endif
|
||||
-EOF
|
||||
- fi
|
||||
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
|
||||
@@ -823,12 +820,9 @@
|
||||
check_add_asflags -mfpu=neon
|
||||
fi
|
||||
|
||||
- if [ -z "${tune_cpu}" ]; then
|
||||
- tune_cpu=cortex-a8
|
||||
- fi
|
||||
else
|
||||
- check_add_cflags -march=${tgt_isa}
|
||||
- check_add_asflags -march=${tgt_isa}
|
||||
+ check_add_cflags -march=${tgt_isa} -mfloat-abi=${float_abi}
|
||||
+ check_add_asflags -march=${tgt_isa} -mfloat-abi=${float_abi}
|
||||
fi
|
||||
|
||||
enabled debug && add_asflags -g
|
24
community/libvpx1.3/libvpx-1.3-gcc-5.2.patch
Normal file
24
community/libvpx1.3/libvpx-1.3-gcc-5.2.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
diff -Naur libvpx-1.3.orig/nestegg/halloc/src/align.h libvpx-1.3/nestegg/halloc/src/align.h
|
||||
--- libvpx-1.3.orig/nestegg/halloc/src/align.h 2015-08-02 13:42:14.783914000 +0200
|
||||
+++ libvpx-1.3/nestegg/halloc/src/align.h 2015-08-02 13:43:04.100580874 +0200
|
||||
@@ -30,7 +30,7 @@
|
||||
void (*q)(void);
|
||||
};
|
||||
|
||||
-typedef union max_align max_align_t;
|
||||
+typedef union max_align h_max_align_t;
|
||||
|
||||
#endif
|
||||
|
||||
diff -Naur libvpx-1.3.orig/nestegg/halloc/src/halloc.c libvpx-1.3/nestegg/halloc/src/halloc.c
|
||||
--- libvpx-1.3.orig/nestegg/halloc/src/halloc.c 2015-08-02 13:42:14.783914000 +0200
|
||||
+++ libvpx-1.3/nestegg/halloc/src/halloc.c 2015-08-02 13:43:35.817247310 +0200
|
||||
@@ -30,7 +30,7 @@
|
||||
#endif
|
||||
hlist_item_t siblings; /* 2 pointers */
|
||||
hlist_head_t children; /* 1 pointer */
|
||||
- max_align_t data[1]; /* not allocated, see below */
|
||||
+ h_max_align_t data[1]; /* not allocated, see below */
|
||||
|
||||
} hblock_t;
|
||||
|
Loading…
Reference in a new issue