core/linux-veyron to 3.14.0-14

This commit is contained in:
Kevin Mihelich 2015-11-05 04:27:36 +00:00
parent 9167870e35
commit 8a7b0073ce
6 changed files with 33 additions and 51 deletions

View file

@ -1,4 +1,4 @@
From b5f5565fde88936969aee935bdb8273bb7f81f12 Mon Sep 17 00:00:00 2001
From 2e7904c0c6d9d925c70accd700ecbd6cc758c695 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 25 Jun 2015 20:35:06 -0600
Subject: [PATCH 1/4] use chromiumos mwifiex drivers
@ -26,5 +26,5 @@ index f9ee413..9686025 100644
#define BLOCK_MODE 1
--
2.5.0
2.6.1

View file

@ -1,4 +1,4 @@
From 28a01309079f0a9d2d16ce154e360935c1c32239 Mon Sep 17 00:00:00 2001
From 2e45da7882fa7e8bce60b84310327a8a170a963a Mon Sep 17 00:00:00 2001
From: Bing Zhao <bzhao@marvell.com>
Date: Mon, 19 Aug 2013 16:10:21 -0700
Subject: [PATCH 2/4] mwifiex: do not create AP and P2P interfaces upon driver
@ -31,33 +31,36 @@ other applications manually when they are needed.
Signed-off-by: Bing Zhao <bzhao@marvell.com>
Signed-off-by: Avinash Patil <patila@marvell.com>
---
drivers/net/wireless-3.8/mwifiex/main.c | 13 -------------
1 file changed, 13 deletions(-)
drivers/net/wireless-3.8/mwifiex/main.c | 16 ----------------
1 file changed, 16 deletions(-)
diff --git a/drivers/net/wireless-3.8/mwifiex/main.c b/drivers/net/wireless-3.8/mwifiex/main.c
index b3f9247..a503264 100644
index e43afc1..587f4ae 100644
--- a/drivers/net/wireless-3.8/mwifiex/main.c
+++ b/drivers/net/wireless-3.8/mwifiex/main.c
@@ -515,19 +515,6 @@ static void mwifiex_fw_dpc(const struct firmware *firmware, void *context)
@@ -523,22 +523,6 @@ static void mwifiex_fw_dpc(const struct firmware *firmware, void *context)
"cannot create default STA interface\n");
goto err_add_intf;
}
-
- /* Create AP interface by default */
- if (!mwifiex_add_virtual_intf(adapter->wiphy, "uap%d",
- NL80211_IFTYPE_AP, NULL, NULL)) {
- dev_err(adapter->dev, "cannot create default AP interface\n");
- mwifiex_dbg(adapter, ERROR,
- "cannot create default AP interface\n");
- goto err_add_intf;
- }
-
- /* Create P2P interface by default */
- if (!mwifiex_add_virtual_intf(adapter->wiphy, "p2p%d",
- NL80211_IFTYPE_P2P_CLIENT, NULL, NULL)) {
- dev_err(adapter->dev, "cannot create default P2P interface\n");
- mwifiex_dbg(adapter, ERROR,
- "cannot create default P2P interface\n");
- goto err_add_intf;
- }
rtnl_unlock();
mwifiex_drv_get_driver_version(adapter, fmt, sizeof(fmt) - 1);
--
2.5.0
2.6.1

View file

@ -1,4 +1,4 @@
From 1c67401a52b33aa02cdb0d9608314fc4cd524458 Mon Sep 17 00:00:00 2001
From 276e58952f3f333bcd8dcca621d05499aa46ea6d Mon Sep 17 00:00:00 2001
From: Heiko Stuebner <heiko@sntech.de>
Date: Mon, 25 May 2015 16:38:07 +0200
Subject: [PATCH 3/4] UPSTREAM: soc/rockchip: add handler for usb-uart
@ -302,5 +302,5 @@ index 0000000..97754f9
+}
+early_param("rockchip.usb_uart", rockchip_usb_uart);
--
2.5.0
2.6.1

View file

@ -1,4 +1,4 @@
From 832d7d29401718d2d5ed8c1b110cc0c5b0931b05 Mon Sep 17 00:00:00 2001
From a50240ffd6743509d23a673bb04710496c660860 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 2 Jul 2015 17:48:41 -0600
Subject: [PATCH 4/4] fix brcmfmac oops and race condition
@ -15,8 +15,7 @@ hack.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
.../wireless-3.8/brcm80211/brcmfmac/dhd_common.c | 47 ++++++++++++++--------
.../wireless-3.8/brcm80211/brcmfmac/dhd_linux.c | 4 +-
2 files changed, 32 insertions(+), 19 deletions(-)
1 file changed, 30 insertions(+), 17 deletions(-)
diff --git a/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_common.c b/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_common.c
index 05d4042..7006d19 100644
@ -89,26 +88,6 @@ index 05d4042..7006d19 100644
}
/*
diff --git a/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_linux.c b/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_linux.c
index 128161c..d3db8f7 100644
--- a/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_linux.c
+++ b/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_linux.c
@@ -974,13 +974,13 @@ fail:
brcmf_fws_deinit(drvr);
}
if (drvr->iflist[0]) {
- if (ifp->ndev->destructor == NULL)
+ if (ifp->ndev->destructor == NULL && ifp->vif)
brcmf_free_vif(ifp->vif);
free_netdev(ifp->ndev);
drvr->iflist[0] = NULL;
}
if (p2p_ifp) {
- if (p2p_ifp->ndev->destructor == NULL)
+ if (p2p_ifp->ndev->destructor == NULL && p2p_ifp->vif)
brcmf_free_vif(p2p_ifp->vif);
free_netdev(p2p_ifp->ndev);
drvr->iflist[1] = NULL;
--
2.5.0
2.6.1

View file

@ -7,8 +7,8 @@ pkgbase=linux-veyron
_kernelname=${pkgbase#linux}
_desc="Veyron Chromebooks"
pkgver=3.14.0
pkgrel=13
_commit=faa52508e7f21b775d7e731e4e243dd5cd1cab4d
pkgrel=14
_commit=e1cc77edc5e2d762c7374656636da98a19838b98
arch=('armv7h')
url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-3.14"
license=('GPL2')
@ -28,17 +28,17 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
'cmdline'
'brcmfmac4354-sdio.txt'
'99-veyron-brcm.rules')
md5sums=('SKIP'
md5sums=('98f17b17883c6625bcd7bfc6896aec8c'
'bda543cb5943eac34e16d12911f3ee99'
'5e2d7cd74de07d13052de99411c13a2f'
'1534c1dbfe5df35a5634072f7b912840'
'20f8931f3795e5226829d48c3d470334'
'b98041ace0b7537058ba9095406bbcfc'
'a4ed8eff558abe5bea1eda89cdda2526'
'1c666a868a11e8b799723673772079f4'
'a04ae86c479589d5b638b26d9f6c5a8e'
'4f8e94ba788104a775d3df727bdfba5c'
'de337d0ec6c8d60d57af8d9e7d33b4ae'
'e8f97028325c3999285839e521bb0f6e'
'29ac9b84b8f84fbeb78ed32e049fcea5'
'0a923f72b30570ceae127cb82a0ea432'
'22ad496bbbece67f9a825a2d60d8dc25'
'760b6f2a157e38fcc5111f86f567e568'
'f03a3143e7c5e00c0028415a0d67f5f3'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
'e3bdf63d5d936fb982c4cd62da1433ad'

View file

@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
# Linux/arm 3.14.0-13 Kernel Configuration
# Linux/arm 3.14.0-14 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_ARM_HAS_SG_CHAIN=y
@ -1069,9 +1069,7 @@ CONFIG_NET_SCH_FIFO=y
# CONFIG_DCB is not set
CONFIG_DNS_RESOLVER=y
# CONFIG_BATMAN_ADV is not set
CONFIG_OPENVSWITCH=m
CONFIG_OPENVSWITCH_GRE=y
CONFIG_OPENVSWITCH_VXLAN=y
# CONFIG_OPENVSWITCH is not set
# CONFIG_VSOCKETS is not set
# CONFIG_NETLINK_MMAP is not set
# CONFIG_NETLINK_DIAG is not set
@ -1133,6 +1131,7 @@ CONFIG_BT_ATH3K=m
# CONFIG_AF_RXRPC is not set
CONFIG_FIB_RULES=y
CONFIG_WIRELESS=y
CONFIG_WIRELESS_38=y
CONFIG_WIRELESS_EXT=y
CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
@ -1649,7 +1648,7 @@ CONFIG_RTL8192C_COMMON=m
# CONFIG_ZD1211RW is not set
CONFIG_MWIFIEX=m
CONFIG_MWIFIEX_SDIO=m
CONFIG_MWIFIEX_USB=m
# CONFIG_MWIFIEX_USB is not set
#
# WiMAX Wireless Broadband devices
@ -3787,6 +3786,7 @@ CONFIG_ROCKCHIP_SARADC=m
# Light sensors
#
# CONFIG_ADJD_S311 is not set
# CONFIG_AP3223 is not set
# CONFIG_APDS9300 is not set
# CONFIG_CM32181 is not set
# CONFIG_CM36651 is not set