mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/js78 to 78.5.0-2
This commit is contained in:
parent
44f2f9f67c
commit
8ae098b80d
3 changed files with 3542 additions and 12 deletions
|
@ -1,7 +1,18 @@
|
||||||
diff --git i/build/moz.configure/lto-pgo.configure w/build/moz.configure/lto-pgo.configure
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
index 366c6691f7d1..e5342a037ee9 100644
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||||
--- i/build/moz.configure/lto-pgo.configure
|
Date: Tue, 17 Nov 2020 22:45:47 +0100
|
||||||
+++ w/build/moz.configure/lto-pgo.configure
|
Subject: [PATCH] Fixes for LTO+PGO support
|
||||||
|
|
||||||
|
Cherry-picked from Firefox Nightly.
|
||||||
|
---
|
||||||
|
build/moz.configure/lto-pgo.configure | 7 +++++--
|
||||||
|
config/makefiles/rust.mk | 21 +++++++++++++++++----
|
||||||
|
2 files changed, 22 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/build/moz.configure/lto-pgo.configure b/build/moz.configure/lto-pgo.configure
|
||||||
|
index 366c6691f7d11..e5342a037ee92 100644
|
||||||
|
--- a/build/moz.configure/lto-pgo.configure
|
||||||
|
+++ b/build/moz.configure/lto-pgo.configure
|
||||||
@@ -229,7 +229,10 @@ def lto(value, c_compiler, ld64_known_good, target, instrumented_build):
|
@@ -229,7 +229,10 @@ def lto(value, c_compiler, ld64_known_good, target, instrumented_build):
|
||||||
# instruction sets.
|
# instruction sets.
|
||||||
else:
|
else:
|
||||||
|
@ -22,10 +33,10 @@ index 366c6691f7d1..e5342a037ee9 100644
|
||||||
+set_config('MOZ_LTO_RUST_CROSS', lto.rust_lto)
|
+set_config('MOZ_LTO_RUST_CROSS', lto.rust_lto)
|
||||||
add_old_configure_assignment('MOZ_LTO_CFLAGS', lto.cflags)
|
add_old_configure_assignment('MOZ_LTO_CFLAGS', lto.cflags)
|
||||||
add_old_configure_assignment('MOZ_LTO_LDFLAGS', lto.ldflags)
|
add_old_configure_assignment('MOZ_LTO_LDFLAGS', lto.ldflags)
|
||||||
diff --git i/config/makefiles/rust.mk w/config/makefiles/rust.mk
|
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
|
||||||
index b5c7973104ce..079408b358ed 100644
|
index b5c7973104ceb..079408b358edb 100644
|
||||||
--- i/config/makefiles/rust.mk
|
--- a/config/makefiles/rust.mk
|
||||||
+++ w/config/makefiles/rust.mk
|
+++ b/config/makefiles/rust.mk
|
||||||
@@ -59,17 +59,19 @@ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
|
@@ -59,17 +59,19 @@ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
|
||||||
ifndef DEVELOPER_OPTIONS
|
ifndef DEVELOPER_OPTIONS
|
||||||
ifndef MOZ_DEBUG_RUST
|
ifndef MOZ_DEBUG_RUST
|
File diff suppressed because one or more lines are too long
|
@ -6,7 +6,7 @@
|
||||||
|
|
||||||
pkgname=js78
|
pkgname=js78
|
||||||
pkgver=78.5.0
|
pkgver=78.5.0
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="JavaScript interpreter and libraries - Version 78"
|
pkgdesc="JavaScript interpreter and libraries - Version 78"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
|
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
|
||||||
|
@ -16,11 +16,13 @@ makedepends=(zip autoconf2.13 python-setuptools python-psutil rust llvm clang ll
|
||||||
checkdepends=(mercurial git)
|
checkdepends=(mercurial git)
|
||||||
_relver=${pkgver}esr
|
_relver=${pkgver}esr
|
||||||
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz{,.asc}
|
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz{,.asc}
|
||||||
lto-pgo.diff
|
0001-Fixes-for-LTO-PGO-support.patch
|
||||||
|
0002-Bug-1667736-Update-packed_simd-to-compile-on-Rust-1..patch
|
||||||
arm.patch)
|
arm.patch)
|
||||||
sha256sums=('51f54ff608aa09de07b304307581ae89112781597322b8999b3099cfabf48290'
|
sha256sums=('51f54ff608aa09de07b304307581ae89112781597322b8999b3099cfabf48290'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'7b3d631c20a8de8d0bfd4de77e8ebeffa0bd0aa536abed713c36931ea4810926'
|
'2c5381bd087dc04287f830d8a3ea739d0c69e43170c2240fd5db78c795d2e65a'
|
||||||
|
'08ee665dde9c6f193e3e3f9bd00a478b1bb594b203e99b93fd30518b170dab28'
|
||||||
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966')
|
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966')
|
||||||
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
||||||
|
|
||||||
|
@ -33,7 +35,10 @@ prepare() {
|
||||||
patch -p1 -i ../arm.patch
|
patch -p1 -i ../arm.patch
|
||||||
|
|
||||||
# Post-78 fixes to fix LTO with LLVM 11
|
# Post-78 fixes to fix LTO with LLVM 11
|
||||||
patch -Np1 -i ../lto-pgo.diff
|
patch -Np1 -i ../0001-Fixes-for-LTO-PGO-support.patch
|
||||||
|
|
||||||
|
# Fix build with Rust 1.48
|
||||||
|
patch -Np1 -i ../0002-Bug-1667736-Update-packed_simd-to-compile-on-Rust-1..patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
Loading…
Reference in a new issue