mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/mysql-workbench to 6.3.9-1
This commit is contained in:
parent
93d50a8601
commit
8b13276aa8
4 changed files with 234 additions and 9 deletions
|
@ -0,0 +1,29 @@
|
||||||
|
From 784599e99ee97574798512f6daf987cab8fd4cdf Mon Sep 17 00:00:00 2001
|
||||||
|
From: Christian Hesse <mail@eworm.de>
|
||||||
|
Date: Wed, 8 Feb 2017 09:12:24 +0100
|
||||||
|
Subject: [PATCH 1/1] disable unsupported operating system warning
|
||||||
|
|
||||||
|
Signed-off-by: Christian Hesse <mail@eworm.de>
|
||||||
|
---
|
||||||
|
backend/wbprivate/workbench/wb_context.cpp | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/backend/wbprivate/workbench/wb_context.cpp b/backend/wbprivate/workbench/wb_context.cpp
|
||||||
|
index 82c0fa6..f06ff99 100644
|
||||||
|
--- a/backend/wbprivate/workbench/wb_context.cpp
|
||||||
|
+++ b/backend/wbprivate/workbench/wb_context.cpp
|
||||||
|
@@ -1009,9 +1009,11 @@ void WBContext::init_finish_(WBOptions *options) {
|
||||||
|
|
||||||
|
_frontendCallbacks->show_status_text(_("Ready."));
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
if (options->open_at_startup_type !=
|
||||||
|
"run-script") // <--- so that our runtime tests don't lock up when a modal warning dialog is displayed
|
||||||
|
warnIfRunningOnUnsupportedOS();
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
try {
|
||||||
|
// execute action requested from command line
|
||||||
|
--
|
||||||
|
2.11.1
|
||||||
|
|
|
@ -0,0 +1,36 @@
|
||||||
|
From cca769c75b9421f8ef5090848cea6162ccd85ba7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Christian Hesse <mail@eworm.de>
|
||||||
|
Date: Wed, 8 Feb 2017 09:42:29 +0100
|
||||||
|
Subject: [PATCH 1/1] add option to hide nonstandard server warning
|
||||||
|
|
||||||
|
Signed-off-by: Christian Hesse <mail@eworm.de>
|
||||||
|
---
|
||||||
|
backend/wbprivate/workbench/wb_context.cpp | 5 +++--
|
||||||
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/backend/wbprivate/workbench/wb_context.cpp b/backend/wbprivate/workbench/wb_context.cpp
|
||||||
|
index f06ff99..f89006b 100644
|
||||||
|
--- a/backend/wbprivate/workbench/wb_context.cpp
|
||||||
|
+++ b/backend/wbprivate/workbench/wb_context.cpp
|
||||||
|
@@ -3038,7 +3038,7 @@ std::shared_ptr<SqlEditorForm> WBContext::add_new_query_window(const db_mgmt_Con
|
||||||
|
logError("Unsupported server version: %s %s\n", form->connection_details()["dbmsProductName"].c_str(),
|
||||||
|
form->connection_details()["dbmsProductVersion"].c_str());
|
||||||
|
|
||||||
|
- if (mforms::Utilities::show_warning(
|
||||||
|
+ if (mforms::Utilities::show_message_and_remember(
|
||||||
|
base::strfmt("Connection Warning (%s)", targetConnection->name().c_str()),
|
||||||
|
base::strfmt(
|
||||||
|
"Incompatible/nonstandard server version or connection protocol detected (%s).\n\n"
|
||||||
|
@@ -3046,7 +3046,8 @@ std::shared_ptr<SqlEditorForm> WBContext::add_new_query_window(const db_mgmt_Con
|
||||||
|
"properly since the database is not fully compatible with the supported versions of MySQL.\n\n"
|
||||||
|
"MySQL Workbench is developed and tested for MySQL Server versions 5.1, 5.5, 5.6 and 5.7",
|
||||||
|
bec::sanitize_server_version_number(form->connection_details()["dbmsProductVersion"]).c_str()),
|
||||||
|
- "Continue Anyway", "Cancel") != mforms::ResultOk) {
|
||||||
|
+ "Continue Anyway", "Cancel", "", "wb.supported_server_check.suppress_warning",
|
||||||
|
+ "Don't show this message again") != mforms::ResultOk) {
|
||||||
|
_frontendCallbacks->show_status_text(_("Unsupported server"));
|
||||||
|
return SqlEditorForm::Ref();
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.11.1
|
||||||
|
|
140
community/mysql-workbench/0004-fix-build-for-i686.patch
Normal file
140
community/mysql-workbench/0004-fix-build-for-i686.patch
Normal file
|
@ -0,0 +1,140 @@
|
||||||
|
From af2bff95077b376a21ba815505589f4ad6b62140 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Christian Hesse <mail@eworm.de>
|
||||||
|
Date: Tue, 7 Feb 2017 23:10:23 +0100
|
||||||
|
Subject: [PATCH 1/1] fix build for i686
|
||||||
|
|
||||||
|
Signed-off-by: Christian Hesse <mail@eworm.de>
|
||||||
|
---
|
||||||
|
library/base/jsonparser.cpp | 6 ++++--
|
||||||
|
library/forms/jsonview.cpp | 12 ++++++++++++
|
||||||
|
2 files changed, 16 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/library/base/jsonparser.cpp b/library/base/jsonparser.cpp
|
||||||
|
index 6ed4b3f..fb4e055 100644
|
||||||
|
--- a/library/base/jsonparser.cpp
|
||||||
|
+++ b/library/base/jsonparser.cpp
|
||||||
|
@@ -343,7 +343,7 @@ namespace JsonParser {
|
||||||
|
*/
|
||||||
|
JsonValue &JsonArray::at(SizeType pos) {
|
||||||
|
if (pos > _data.size())
|
||||||
|
- throw std::out_of_range(base::strfmt("Index '%lu' is out of range.", pos));
|
||||||
|
+ throw std::out_of_range(base::strfmt("Index '%zu' is out of range.", pos));
|
||||||
|
return _data.at(pos);
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -358,7 +358,7 @@ namespace JsonParser {
|
||||||
|
*/
|
||||||
|
const JsonValue &JsonArray::at(SizeType pos) const {
|
||||||
|
if (pos > _data.size())
|
||||||
|
- throw std::out_of_range(base::strfmt("Index '%lu' is out of range.", pos));
|
||||||
|
+ throw std::out_of_range(base::strfmt("Index '%zu' is out of range.", pos));
|
||||||
|
return _data.at(pos);
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -1668,12 +1668,14 @@ namespace JsonParser {
|
||||||
|
case VDouble:
|
||||||
|
_output += std::to_string((double)value);
|
||||||
|
break;
|
||||||
|
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||||
|
case VInt64:
|
||||||
|
_output += std::to_string((int64_t)value);
|
||||||
|
break;
|
||||||
|
case VUint64:
|
||||||
|
_output += std::to_string((uint64_t)value);
|
||||||
|
break;
|
||||||
|
+#endif
|
||||||
|
case VObject:
|
||||||
|
write((JsonObject)value);
|
||||||
|
break;
|
||||||
|
diff --git a/library/forms/jsonview.cpp b/library/forms/jsonview.cpp
|
||||||
|
index 1259427..2d50491 100644
|
||||||
|
--- a/library/forms/jsonview.cpp
|
||||||
|
+++ b/library/forms/jsonview.cpp
|
||||||
|
@@ -651,8 +651,10 @@ void JsonTreeBaseView::setCellValue(mforms::TreeNodeRef node, int column, const
|
||||||
|
if (data != nullptr) {
|
||||||
|
std::stringstream buffer;
|
||||||
|
double number = 0;
|
||||||
|
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||||
|
int64_t number2 = 0;
|
||||||
|
uint64_t number3 = 0;
|
||||||
|
+#endif
|
||||||
|
bool retBool = false;
|
||||||
|
auto &storedValue = data->getData();
|
||||||
|
switch (storedValue.getType()) {
|
||||||
|
@@ -664,6 +666,7 @@ void JsonTreeBaseView::setCellValue(mforms::TreeNodeRef node, int column, const
|
||||||
|
storedValue = number;
|
||||||
|
setData = true;
|
||||||
|
break;
|
||||||
|
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||||
|
case VInt64:
|
||||||
|
if (!base::is_number(value))
|
||||||
|
break;
|
||||||
|
@@ -680,6 +683,7 @@ void JsonTreeBaseView::setCellValue(mforms::TreeNodeRef node, int column, const
|
||||||
|
storedValue = number3;
|
||||||
|
setData = true;
|
||||||
|
break;
|
||||||
|
+#endif
|
||||||
|
case VBoolean:
|
||||||
|
if (!base::isBool(value))
|
||||||
|
break;
|
||||||
|
@@ -1073,6 +1077,7 @@ void JsonTreeView::generateNumberInTree(JsonParser::JsonValue &value, int /*colu
|
||||||
|
node->set_string(1, std::to_string((double)value));
|
||||||
|
node->set_string(2, "Double");
|
||||||
|
break;
|
||||||
|
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||||
|
case VInt64:
|
||||||
|
node->set_string(1, std::to_string((int64_t)value));
|
||||||
|
node->set_string(2, "Long Integer");
|
||||||
|
@@ -1081,6 +1086,7 @@ void JsonTreeView::generateNumberInTree(JsonParser::JsonValue &value, int /*colu
|
||||||
|
node->set_string(1, std::to_string((uint64_t)value));
|
||||||
|
node->set_string(2, "Unsigned Long Integer");
|
||||||
|
break;
|
||||||
|
+#endif
|
||||||
|
default:
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
@@ -1322,8 +1328,10 @@ void JsonGridView::setCellValue(mforms::TreeNodeRef node, int column, const std:
|
||||||
|
if (data != NULL) {
|
||||||
|
std::stringstream buffer;
|
||||||
|
double number = 0;
|
||||||
|
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||||
|
int64_t number2 = 0;
|
||||||
|
uint64_t number3 = 0;
|
||||||
|
+#endif
|
||||||
|
bool retBool = false;
|
||||||
|
switch (storedValue.getType()) {
|
||||||
|
case VDouble:
|
||||||
|
@@ -1334,6 +1342,7 @@ void JsonGridView::setCellValue(mforms::TreeNodeRef node, int column, const std:
|
||||||
|
storedValue = number;
|
||||||
|
node->set_float(column, number);
|
||||||
|
_dataChanged(false);
|
||||||
|
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||||
|
case VInt64:
|
||||||
|
if (!base::is_number(value))
|
||||||
|
break;
|
||||||
|
@@ -1352,6 +1361,7 @@ void JsonGridView::setCellValue(mforms::TreeNodeRef node, int column, const std:
|
||||||
|
node->set_float(column, (double)number3);
|
||||||
|
_dataChanged(false);
|
||||||
|
break;
|
||||||
|
+#endif
|
||||||
|
case VBoolean:
|
||||||
|
if (!base::isBool(value))
|
||||||
|
break;
|
||||||
|
@@ -1611,12 +1621,14 @@ void JsonGridView::generateNumberInTree(JsonParser::JsonValue &value, int column
|
||||||
|
case VDouble:
|
||||||
|
node->set_float(columnId, (double)value);
|
||||||
|
break;
|
||||||
|
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||||
|
case VInt64:
|
||||||
|
node->set_long(columnId, (int64_t)value);
|
||||||
|
break;
|
||||||
|
case VUint64:
|
||||||
|
node->set_long(columnId, (uint64_t)value);
|
||||||
|
break;
|
||||||
|
+#endif
|
||||||
|
default:
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.11.1
|
||||||
|
|
|
@ -11,40 +11,48 @@
|
||||||
highmem=1
|
highmem=1
|
||||||
|
|
||||||
pkgname=mysql-workbench
|
pkgname=mysql-workbench
|
||||||
pkgver=6.3.8
|
pkgver=6.3.9
|
||||||
pkgrel=7
|
pkgrel=1
|
||||||
_mysql_version=5.7.17
|
_mysql_version=5.7.17
|
||||||
_connector_version=1.1.8
|
_connector_version=1.1.8
|
||||||
_gdal_version=2.1.2
|
_gdal_version=2.1.3
|
||||||
_boost_version=1.59.0
|
_boost_version=1.59.0
|
||||||
pkgdesc='A cross-platform, visual database design tool developed by MySQL'
|
pkgdesc='A cross-platform, visual database design tool developed by MySQL'
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url='https://www.mysql.com/products/workbench/'
|
url='https://www.mysql.com/products/workbench/'
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
depends=('cairo' 'ctemplate' 'desktop-file-utils' 'freetype2' 'gtkmm'
|
depends=('cairo' 'ctemplate' 'desktop-file-utils' 'freetype2' 'gtkmm3'
|
||||||
'hicolor-icon-theme' 'libgl' 'libgnome-keyring' 'libiodbc' 'libxml2'
|
'hicolor-icon-theme' 'libgl' 'libgnome-keyring' 'libiodbc' 'libxml2'
|
||||||
'libzip' 'mysql-python' 'pcre' 'python2' 'python2-cairo' 'python2-paramiko'
|
'libzip' 'mysql-python' 'pcre' 'python2' 'python2-cairo' 'python2-paramiko'
|
||||||
'python2-pexpect' 'tinyxml' 'unixodbc' 'vsqlite++')
|
'python2-pexpect' 'tinyxml' 'unixodbc' 'vsqlite++')
|
||||||
optdepends=('gnome-keyring: store SSH/MySQL passwords in GNOME password manager'
|
optdepends=('gnome-keyring: store SSH/MySQL passwords in GNOME password manager'
|
||||||
'python2-pyodbc: database migration')
|
'python2-pyodbc: database migration')
|
||||||
makedepends=('cmake' 'boost' 'mesa' 'swig' 'imagemagick')
|
makedepends=('cmake' 'boost' 'mesa' 'swig' 'java-runtime' 'imagemagick')
|
||||||
validpgpkeys=('A4A9406876FCBD3C456770C88C718D3B5072E1F5')
|
validpgpkeys=('A4A9406876FCBD3C456770C88C718D3B5072E1F5')
|
||||||
source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-${pkgver}-src.tar.gz"{,.asc}
|
source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-${pkgver}-src.tar.gz"{,.asc}
|
||||||
"https://cdn.mysql.com/Downloads/MySQL-${_mysql_version%.*}/mysql-${_mysql_version}.tar.gz"{,.asc}
|
"https://cdn.mysql.com/Downloads/MySQL-${_mysql_version%.*}/mysql-${_mysql_version}.tar.gz"{,.asc}
|
||||||
"https://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-${_connector_version}.tar.gz"{,.asc}
|
"https://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-${_connector_version}.tar.gz"{,.asc}
|
||||||
"http://download.osgeo.org/gdal/${_gdal_version}/gdal-${_gdal_version}.tar.xz"
|
"http://download.osgeo.org/gdal/${_gdal_version}/gdal-${_gdal_version}.tar.xz"
|
||||||
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
|
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
|
||||||
|
'http://www.antlr3.org/download/antlr-3.4-complete.jar'
|
||||||
'0001-mysql-workbench-no-check-for-updates.patch'
|
'0001-mysql-workbench-no-check-for-updates.patch'
|
||||||
|
'0002-disable-unsupported-operating-system-warning.patch'
|
||||||
|
'0003-add-option-to-hide-nonstandard-server-warning.patch'
|
||||||
|
'0004-fix-build-for-i686.patch'
|
||||||
'arch_linux_profile.xml')
|
'arch_linux_profile.xml')
|
||||||
sha256sums=('6a263e072b17c682330d559519205fbaa168f30e902bd44cf595ab6c9140adaf'
|
sha256sums=('607af29481821b25c13c8b28011162c9d6d5e9ef96df5f664408116b88308951'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'cebf23e858aee11e354c57d30de7a079754bdc2ef85eb684782458332a4b9651'
|
'cebf23e858aee11e354c57d30de7a079754bdc2ef85eb684782458332a4b9651'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'85ff10bd056128562f92b440eb27766cfcd558b474bfddc1153f7dd8feb5f963'
|
'85ff10bd056128562f92b440eb27766cfcd558b474bfddc1153f7dd8feb5f963'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'b597f36bd29a2b4368998ddd32b28c8cdf3c8192237a81b99af83cc17d7fa374'
|
'b489793627e6cb8d2ff8d7737b61daf58382fe189fae4c581ddfd48c04b49005'
|
||||||
'727a932322d94287b62abb1bd2d41723eec4356a7728909e38adb65ca25241ca'
|
'727a932322d94287b62abb1bd2d41723eec4356a7728909e38adb65ca25241ca'
|
||||||
|
'9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7'
|
||||||
'b189e15c6b6f5a707357d9a9297f39ee3a33264fd28b44d5de6f537f851f82cf'
|
'b189e15c6b6f5a707357d9a9297f39ee3a33264fd28b44d5de6f537f851f82cf'
|
||||||
|
'0d65832bc5a73d4cfecef4b552bb78a30ce6020a5fabe5558dcf2ade8341b593'
|
||||||
|
'3c9097af599f08388c471d6fd02f40ea72e5759eaa89f731e662852a5e67feea'
|
||||||
|
'68295716c55e5f7b07b3ec1162b512b33a0563952a0eb4ef6fd71d852c61de11'
|
||||||
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
|
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -54,9 +62,21 @@ prepare() {
|
||||||
# Updates are provided via Arch Linux packages
|
# Updates are provided via Arch Linux packages
|
||||||
patch -Np1 < "${srcdir}"/0001-mysql-workbench-no-check-for-updates.patch
|
patch -Np1 < "${srcdir}"/0001-mysql-workbench-no-check-for-updates.patch
|
||||||
|
|
||||||
|
# disable unsupported operating system warning
|
||||||
|
patch -Np1 < "${srcdir}"/0002-disable-unsupported-operating-system-warning.patch
|
||||||
|
|
||||||
|
# add option to hide nonstandard server warning
|
||||||
|
patch -Np1 < "${srcdir}"/0003-add-option-to-hide-nonstandard-server-warning.patch
|
||||||
|
|
||||||
|
# fix build for i686
|
||||||
|
patch -Np1 < "${srcdir}"/0004-fix-build-for-i686.patch
|
||||||
|
|
||||||
# we need python 2.x
|
# we need python 2.x
|
||||||
sed -i '/^FIND_PROGRAM(PYTHON_EXEC /c FIND_PROGRAM(PYTHON_EXEC "python2")' \
|
sed -i '/^FIND_PROGRAM(PYTHON_EXEC /c FIND_PROGRAM(PYTHON_EXEC "python2")' \
|
||||||
CMakeLists.txt
|
CMakeLists.txt
|
||||||
|
|
||||||
|
# put antlr into place
|
||||||
|
install -D ${srcdir}/antlr-3.4-complete.jar ${srcdir}/linux-res/bin/antlr-3.4-complete.jar
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
@ -109,8 +129,8 @@ build() {
|
||||||
-DCMAKE_CXX_FLAGS="${CXXFLAGS} -std=c++11 -fsigned-char" \
|
-DCMAKE_CXX_FLAGS="${CXXFLAGS} -std=c++11 -fsigned-char" \
|
||||||
-DCMAKE_BUILD_TYPE=Release \
|
-DCMAKE_BUILD_TYPE=Release \
|
||||||
-DMySQL_CONFIG_PATH="${srcdir}/install-bundle/usr/bin/mysql_config" \
|
-DMySQL_CONFIG_PATH="${srcdir}/install-bundle/usr/bin/mysql_config" \
|
||||||
-DMYSQLCPPCONN_LIBRARY="-L${srcdir}/install-bundle/usr/lib -lmysqlcppconn" \
|
-DMySQLCppConn_LIBRARY="${srcdir}/install-bundle/usr/lib/libmysqlcppconn.so" \
|
||||||
-DMYSQLCPPCONN_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
|
-DMySQLCppConn_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
|
||||||
-DGDAL_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
|
-DGDAL_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
|
||||||
-DGDAL_LIBRARY="${srcdir}/install-bundle/usr/lib/libgdal.so" \
|
-DGDAL_LIBRARY="${srcdir}/install-bundle/usr/lib/libgdal.so" \
|
||||||
-DUSE_BUNDLED_MYSQLDUMP=1
|
-DUSE_BUNDLED_MYSQLDUMP=1
|
||||||
|
|
Loading…
Reference in a new issue