mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/gstreamer: add patch
This commit is contained in:
parent
8731bc468e
commit
8b878d19cd
1 changed files with 25 additions and 0 deletions
|
@ -0,0 +1,25 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
|
||||
Date: Fri, 20 Sep 2024 01:44:53 +0200
|
||||
Subject: [PATCH] ges: Fix name of GESFrameCompositionMeta API type
|
||||
|
||||
g-ir-scanner 1.82.0 failed with a fatal error due to the wrong
|
||||
namespace.
|
||||
---
|
||||
.../gst-editing-services/ges/ges-frame-composition-meta.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/subprojects/gst-editing-services/ges/ges-frame-composition-meta.c b/subprojects/gst-editing-services/ges/ges-frame-composition-meta.c
|
||||
index d8c5a5251309..1ad7b6cfe4c7 100644
|
||||
--- a/subprojects/gst-editing-services/ges/ges-frame-composition-meta.c
|
||||
+++ b/subprojects/gst-editing-services/ges/ges-frame-composition-meta.c
|
||||
@@ -47,7 +47,8 @@ ges_frame_composition_meta_api_get_type (void)
|
||||
static const gchar *tags[] = { "video", NULL };
|
||||
|
||||
if (g_once_init_enter (&type)) {
|
||||
- GType _type = gst_meta_api_type_register ("GstFrameCompositionApi", tags);
|
||||
+ GType _type =
|
||||
+ gst_meta_api_type_register ("GESFrameCompositionMetaAPI", tags);
|
||||
g_once_init_leave (&type, _type);
|
||||
}
|
||||
return type;
|
Loading…
Reference in a new issue