mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed core/keyutils
This commit is contained in:
parent
daa55e7a03
commit
8c1a2398b8
2 changed files with 0 additions and 59 deletions
|
@ -1,38 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
|
||||
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - must build -j1, everything must build in order
|
||||
|
||||
pkgname=keyutils
|
||||
pkgver=1.5.11
|
||||
pkgrel=1
|
||||
pkgdesc="Linux Key Management Utilities"
|
||||
arch=('x86_64')
|
||||
url="http://www.kernel.org"
|
||||
license=('GPL2' 'LGPL2.1')
|
||||
depends=('glibc' 'sh')
|
||||
backup=('etc/request-key.conf')
|
||||
validpgpkeys=('A86E54B0D5E1B4E0AB7C640FFBB7576BA7CB0B6B') # David Howells <dhowells@redhat.com>
|
||||
source=("https://people.redhat.com/~dhowells/${pkgname}/${pkgname}-${pkgver}.tar.bz2"{,.sig}
|
||||
'request-key.conf.patch')
|
||||
sha256sums=('11584488206edc30736263eb855bf7793f16e661987241d333d3cb5ea479b1b5'
|
||||
'SKIP'
|
||||
'203c602c61ed94ccd423a0a453d74143d678c641a9a4486367576ee8af2cb8d6')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
# fix paths of binaries in /etc/request-key.conf
|
||||
patch -Np0 -i ../request-key.conf.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
make -j1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" SBINDIR='/usr/bin' BINDIR='/usr/bin'
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
make DESTDIR="${pkgdir}" SBINDIR='/usr/bin' BINDIR='/usr/bin' LIBDIR='/usr/lib' USRLIBDIR='/usr/lib' install
|
||||
}
|
|
@ -1,21 +0,0 @@
|
|||
--- request-key.conf.old 2013-05-28 15:34:10.966001242 +0200
|
||||
+++ request-key.conf 2013-05-28 15:35:34.857969598 +0200
|
||||
@@ -31,11 +31,11 @@
|
||||
|
||||
#OP TYPE DESCRIPTION CALLOUT INFO PROGRAM ARG1 ARG2 ARG3 ...
|
||||
#====== ======= =============== =============== ===============================
|
||||
-create dns_resolver * * /sbin/key.dns_resolver %k
|
||||
-create user debug:* negate /bin/keyctl negate %k 30 %S
|
||||
-create user debug:* rejected /bin/keyctl reject %k 30 %c %S
|
||||
-create user debug:* expired /bin/keyctl reject %k 30 %c %S
|
||||
-create user debug:* revoked /bin/keyctl reject %k 30 %c %S
|
||||
-create user debug:loop:* * |/bin/cat
|
||||
+create dns_resolver * * /usr/bin/key.dns_resolver %k
|
||||
+create user debug:* negate /usr/bin/keyctl negate %k 30 %S
|
||||
+create user debug:* rejected /usr/bin/keyctl reject %k 30 %c %S
|
||||
+create user debug:* expired /usr/bin/keyctl reject %k 30 %c %S
|
||||
+create user debug:* revoked /usr/bin/keyctl reject %k 30 %c %S
|
||||
+create user debug:loop:* * |/usr/bin/cat
|
||||
create user debug:* * /usr/share/keyutils/request-key-debug.sh %k %d %c %S
|
||||
-negate * * * /bin/keyctl negate %k 30 %S
|
||||
+negate * * * /usr/bin/keyctl negate %k 30 %S
|
Loading…
Reference in a new issue