mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/mariadb to 10.3.12-4
This commit is contained in:
parent
8710a46dd5
commit
8c4ee34c96
2 changed files with 30 additions and 2 deletions
18
extra/mariadb/0001-systemd-240.patch
Normal file
18
extra/mariadb/0001-systemd-240.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
diff --git a/mysys/my_file.c b/mysys/my_file.c
|
||||
index a23ab487d00..23226595b2e 100644
|
||||
--- a/mysys/my_file.c
|
||||
+++ b/mysys/my_file.c
|
||||
@@ -52,10 +52,9 @@ static uint set_max_open_files(uint max_file_limit)
|
||||
DBUG_PRINT("info", ("rlim_cur: %u rlim_max: %u",
|
||||
(uint) rlimit.rlim_cur,
|
||||
(uint) rlimit.rlim_max));
|
||||
- if ((ulonglong) rlimit.rlim_cur == (ulonglong) RLIM_INFINITY)
|
||||
- rlimit.rlim_cur = max_file_limit;
|
||||
- if (rlimit.rlim_cur >= max_file_limit)
|
||||
- DBUG_RETURN(rlimit.rlim_cur); /* purecov: inspected */
|
||||
+ if ((ulonglong) rlimit.rlim_cur == (ulonglong) RLIM_INFINITY ||
|
||||
+ rlimit.rlim_cur >= max_file_limit)
|
||||
+ DBUG_RETURN(max_file_limit);
|
||||
rlimit.rlim_cur= rlimit.rlim_max= max_file_limit;
|
||||
if (setrlimit(RLIMIT_NOFILE, &rlimit))
|
||||
max_file_limit= old_cur; /* Use original value */
|
|
@ -9,7 +9,7 @@ pkgbase=mariadb
|
|||
pkgname=('mariadb-libs' 'mariadb-clients' 'mariadb' 'mytop')
|
||||
pkgdesc='Fast SQL database server, derived from MySQL'
|
||||
pkgver=10.3.12
|
||||
pkgrel=2
|
||||
pkgrel=4
|
||||
arch=('x86_64')
|
||||
license=('GPL')
|
||||
url='https://mariadb.org/'
|
||||
|
@ -17,9 +17,11 @@ makedepends=('boost' 'bzip2' 'cmake' 'jemalloc' 'libaio' 'libxml2' 'lz4' 'lzo'
|
|||
'openssl' 'systemd' 'zlib' 'zstd')
|
||||
validpgpkeys=('199369E5404BD5FC7D2FE43BCBCB082A1BB943DB') # MariaDB Package Signing Key <package-signing-key@mariadb.org>
|
||||
source=("https://ftp.heanet.ie/mirrors/mariadb/mariadb-$pkgver/source/mariadb-$pkgver.tar.gz"{,.asc}
|
||||
'0001-systemd-240.patch'
|
||||
'atomic.patch')
|
||||
sha256sums=('f7449a34c25e0455928d7983dae83fd2069fe1f16c4c5f4aeed9ed9d3f081ff6'
|
||||
'SKIP'
|
||||
'd57500014f50d73fe7f35a4503488fb1008bbd15cbcc6ec9aa927fc801e816f4'
|
||||
'7769fd8eb2bb3a6644a2200d01918ff887be25638d79dbec25897fe0d87badc4')
|
||||
|
||||
prepare() {
|
||||
|
@ -43,6 +45,12 @@ prepare() {
|
|||
# fix path to our config
|
||||
sed -i 's|my.cnf.d|mysql/my.cnf.d|' support-files/rpm/{my.cnf,enable_encryption.preset}
|
||||
|
||||
# fix memory allocation and OOM with systemd >= 240
|
||||
# https://bugs.archlinux.org/task/61433
|
||||
# https://github.com/systemd/systemd/issues/11510
|
||||
# https://jira.mariadb.org/browse/MDEV-18360
|
||||
patch -Np1 < ../0001-systemd-240.patch
|
||||
|
||||
if [[ $CARCH == arm || $CARCH == armv6h ]]; then
|
||||
patch -p0 -i ../atomic.patch
|
||||
fi
|
||||
|
@ -136,8 +144,10 @@ package_mariadb-libs() {
|
|||
install -D -m0644 support-files/mariadb.pc "$pkgdir"/usr/share/pkgconfig/mariadb.pc
|
||||
install -D -m0644 "$srcdir"/"$pkgbase-$pkgver"/support-files/mysql.m4 "$pkgdir"/usr/share/aclocal/mysql.m4
|
||||
|
||||
cd "$pkgdir"
|
||||
|
||||
# remove static libraries
|
||||
rm "$pkgdir"/usr/lib/*.a
|
||||
rm usr/lib/*.a
|
||||
}
|
||||
|
||||
package_mariadb-clients() {
|
||||
|
|
Loading…
Reference in a new issue