mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/chromium to 67.0.3396.99-1
This commit is contained in:
parent
396f8dda69
commit
8c5d3c7f3f
3 changed files with 55 additions and 40 deletions
|
@ -15,8 +15,8 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=67.0.3396.87
|
||||
pkgrel=2
|
||||
pkgver=67.0.3396.99
|
||||
pkgrel=1
|
||||
_launcher_ver=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
arch=('x86_64')
|
||||
|
@ -35,18 +35,18 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
remove-dependency-on-ffmpeg-internals-for-start-time.patch
|
||||
x11-fix-mixup-between-DIP-pixel-coordinates.patch
|
||||
blink-disable-XML-catalogs-at-runtime.patch
|
||||
chromium-ffmpeg-r1.patch
|
||||
chromium-widevine-r2.patch
|
||||
chromium-disable_xml_catalogs.patch
|
||||
chromium-skia-harmony.patch
|
||||
0001-Ensure-all-targets-build-when-target_arch-arm-and-ta.patch)
|
||||
sha256sums=('5d27a72f0cb8247343034f63fdd9747ff388c05b9fceb541668dd04fb372db1d'
|
||||
sha256sums=('452d6b9d8df6c88600aaeff3fad4c065574fd6dbee804e628b70e73a39c0a02a'
|
||||
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
|
||||
'2cc80f5ed8a9b42495a0f3ab3c1bae026b9081972269a1b6d407331d33f7d257'
|
||||
'e2c2754536243a60fa70541bbd4121715eccd83caa8f1fb1873bd994cd81f871'
|
||||
'98a5c41cf9687c52ee380d2b683c95387334c76254479c347bdb733646dab815'
|
||||
'aa885330bc4180b78d915f9dfdfc3210038a0acab7b16735ea9828ab6a633bde'
|
||||
'02c69bb3954087db599def7f5b6d65cf8f7cf2ed81dfbdaa4bb7b51863b4df15'
|
||||
'f9d191e89ed9b2b2641bbbb370ea0a11868409a13cad181f7b63f6007de002a1'
|
||||
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
|
||||
'9e4d63c582b316edaa550aae6fe6623f0df1a94c53f97bae4b0d7826e0779a32')
|
||||
|
||||
|
@ -108,13 +108,15 @@ prepare() {
|
|||
# https://crbug.com/707721
|
||||
patch -Np1 -i ../x11-fix-mixup-between-DIP-pixel-coordinates.patch
|
||||
|
||||
# https://crbug.com/736026
|
||||
patch -Np1 -i ../blink-disable-XML-catalogs-at-runtime.patch
|
||||
|
||||
# https://crbug.com/skia/6663#c10
|
||||
patch -Np4 -i ../chromium-skia-harmony.patch
|
||||
|
||||
# Fixes from Gentoo
|
||||
patch -Np1 -i ../chromium-ffmpeg-r1.patch
|
||||
patch -Np1 -i ../chromium-widevine-r2.patch
|
||||
patch -Np1 -i ../chromium-disable_xml_catalogs.patch
|
||||
|
||||
# Remove compiler flags not supported by our system clang
|
||||
sed -i \
|
||||
|
|
47
extra/chromium/blink-disable-XML-catalogs-at-runtime.patch
Normal file
47
extra/chromium/blink-disable-XML-catalogs-at-runtime.patch
Normal file
|
@ -0,0 +1,47 @@
|
|||
From 8f0c8c8d9bce12c70ce9acb4a7474cd15c9be65b Mon Sep 17 00:00:00 2001
|
||||
From: Mike Gilbert <floppymaster@gmail.com>
|
||||
Date: Wed, 20 Jun 2018 20:37:46 +0000
|
||||
Subject: [PATCH] blink: disable XML catalogs at runtime
|
||||
|
||||
Chromium may optionally be built against libxml installed on the system.
|
||||
The system libxml commonly has XML catalog support enabled. Disable it
|
||||
by calling xmlCatalogSetDefaults(XML_CATA_ALLOW_NONE).
|
||||
|
||||
Bug: https://bugs.gentoo.org/653078
|
||||
Change-Id: I069f6dcecf81168f9d31eb0efe2519197ec8e779
|
||||
Reviewed-on: https://chromium-review.googlesource.com/1103710
|
||||
Reviewed-by: Daniel Cheng <dcheng@chromium.org>
|
||||
Commit-Queue: Scott Graham <scottmg@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#568998}
|
||||
---
|
||||
.../blink/renderer/core/xml/parser/xml_document_parser.cc | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc b/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
|
||||
index 9744de383d9a..d0539f61e4b5 100644
|
||||
--- a/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
|
||||
+++ b/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
|
||||
@@ -28,6 +28,10 @@
|
||||
|
||||
#include <libxml/parser.h>
|
||||
#include <libxml/parserInternals.h>
|
||||
+#include <libxml/xmlversion.h>
|
||||
+#if defined(LIBXML_CATALOG_ENABLED)
|
||||
+#include <libxml/catalog.h>
|
||||
+#endif
|
||||
#include <libxslt/xslt.h>
|
||||
|
||||
#include <memory>
|
||||
@@ -648,6 +652,9 @@ static void InitializeLibXMLIfNecessary() {
|
||||
if (did_init)
|
||||
return;
|
||||
|
||||
+#if defined(LIBXML_CATALOG_ENABLED)
|
||||
+ xmlCatalogSetDefaults(XML_CATA_ALLOW_NONE);
|
||||
+#endif
|
||||
xmlInitParser();
|
||||
xmlRegisterInputCallbacks(MatchFunc, OpenFunc, ReadFunc, CloseFunc);
|
||||
xmlRegisterOutputCallbacks(MatchFunc, OpenFunc, WriteFunc, CloseFunc);
|
||||
--
|
||||
2.17.1
|
||||
|
|
@ -1,34 +0,0 @@
|
|||
--- a/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
|
||||
+++ b/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
|
||||
@@ -28,6 +28,10 @@
|
||||
|
||||
#include <libxml/parser.h>
|
||||
#include <libxml/parserInternals.h>
|
||||
+#include <libxml/xmlversion.h>
|
||||
+#if defined(LIBXML_CATALOG_ENABLED)
|
||||
+#include <libxml/catalog.h>
|
||||
+#endif
|
||||
#include <libxslt/xslt.h>
|
||||
|
||||
#include <memory>
|
||||
@@ -538,10 +542,6 @@
|
||||
static bool ShouldAllowExternalLoad(const KURL& url) {
|
||||
String url_string = url.GetString();
|
||||
|
||||
- // libxml should not be configured with catalogs enabled, so it
|
||||
- // should not be asking to load default catalogs.
|
||||
- CHECK(!IsLibxmlDefaultCatalogFile(url));
|
||||
-
|
||||
// The most common DTD. There isn't much point in hammering www.w3c.org by
|
||||
// requesting this URL for every XHTML document.
|
||||
if (url_string.StartsWithIgnoringASCIICase("http://www.w3.org/TR/xhtml"))
|
||||
@@ -648,6 +648,9 @@
|
||||
if (did_init)
|
||||
return;
|
||||
|
||||
+#if defined(LIBXML_CATALOG_ENABLED)
|
||||
+ xmlCatalogSetDefaults(XML_CATA_ALLOW_NONE);
|
||||
+#endif
|
||||
xmlInitParser();
|
||||
xmlRegisterInputCallbacks(MatchFunc, OpenFunc, ReadFunc, CloseFunc);
|
||||
xmlRegisterOutputCallbacks(MatchFunc, OpenFunc, WriteFunc, CloseFunc);
|
Loading…
Reference in a new issue