mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/mgba to 0.5.2-4
This commit is contained in:
parent
a5d9cf1835
commit
8c905eca4d
2 changed files with 20 additions and 3 deletions
|
@ -10,17 +10,22 @@
|
||||||
pkgbase=mgba
|
pkgbase=mgba
|
||||||
pkgname=('libmgba' 'mgba-sdl' 'mgba-qt')
|
pkgname=('libmgba' 'mgba-sdl' 'mgba-qt')
|
||||||
pkgver=0.5.2
|
pkgver=0.5.2
|
||||||
pkgrel=3
|
pkgrel=4
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url='http://mgba.io'
|
url='http://mgba.io'
|
||||||
license=('custom:MPL2')
|
license=('custom:MPL2')
|
||||||
makedepends=('cmake' 'qt5-multimedia' 'sdl2' 'zlib' 'libpng' 'libzip' 'libedit'
|
makedepends=('cmake' 'qt5-multimedia' 'sdl2' 'zlib' 'libpng' 'libzip' 'libedit'
|
||||||
'ffmpeg' 'imagemagick' 'desktop-file-utils' 'qt5-tools')
|
'ffmpeg' 'imagemagick' 'desktop-file-utils' 'qt5-tools')
|
||||||
source=($pkgbase-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.tar.gz)
|
source=($pkgbase-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.tar.gz
|
||||||
md5sums=('c3d20052503dca08e58030ac4e3f0408')
|
mgba-gcc7.patch)
|
||||||
|
md5sums=('c3d20052503dca08e58030ac4e3f0408'
|
||||||
|
'ea583f6af8cdbfed8f83f16311b9c788')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
[[ ! -d build ]] && mkdir build || rm -rf build
|
[[ ! -d build ]] && mkdir build || rm -rf build
|
||||||
|
|
||||||
|
cd $pkgbase-$pkgver
|
||||||
|
patch -p1 -i ../mgba-gcc7.patch # Fix build with GCC7
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
12
community/mgba/mgba-gcc7.patch
Normal file
12
community/mgba/mgba-gcc7.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
diff --git a/src/platform/qt/GameController.h b/src/platform/qt/GameController.h
|
||||||
|
index 79b18d3bf..7b8d6908b 100644
|
||||||
|
--- a/src/platform/qt/GameController.h
|
||||||
|
+++ b/src/platform/qt/GameController.h
|
||||||
|
@@ -14,6 +14,7 @@
|
||||||
|
#include <QTimer>
|
||||||
|
|
||||||
|
#include <memory>
|
||||||
|
+#include <functional>
|
||||||
|
|
||||||
|
#include <mgba/core/core.h>
|
||||||
|
#include <mgba/core/thread.h>
|
Loading…
Reference in a new issue