mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
added community/openimageio
This commit is contained in:
parent
128126bd1e
commit
8ce1761f01
2 changed files with 82 additions and 0 deletions
25
community/openimageio/0001-disable-neon.patch
Normal file
25
community/openimageio/0001-disable-neon.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From aff1753c7632464312843617b1b0d98112aff04d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 2 Oct 2020 11:10:28 -0600
|
||||
Subject: [PATCH] disable neon
|
||||
|
||||
---
|
||||
src/include/OpenImageIO/simd.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/include/OpenImageIO/simd.h b/src/include/OpenImageIO/simd.h
|
||||
index 0b2c1193..5498af00 100644
|
||||
--- a/src/include/OpenImageIO/simd.h
|
||||
+++ b/src/include/OpenImageIO/simd.h
|
||||
@@ -193,7 +193,7 @@
|
||||
|
||||
// FIXME Future: support ARM Neon
|
||||
// Uncomment this when somebody with Neon can verify it works
|
||||
-#if defined(__ARM_NEON__) && !defined(OIIO_NO_NEON)
|
||||
+#if 0 && defined(__ARM_NEON__) && !defined(OIIO_NO_NEON)
|
||||
# define OIIO_SIMD 4
|
||||
# define OIIO_SIMD_NEON 1
|
||||
# define OIIO_SIMD_MAX_SIZE_BYTES 16
|
||||
--
|
||||
2.28.0
|
||||
|
57
community/openimageio/PKGBUILD
Normal file
57
community/openimageio/PKGBUILD
Normal file
|
@ -0,0 +1,57 @@
|
|||
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
|
||||
# Contributor: SpepS <dreamspepser at yahoo dot it>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to disable neon
|
||||
|
||||
pkgname=openimageio
|
||||
pkgver=2.2.7.0
|
||||
pkgrel=1.1
|
||||
pkgdesc="A library for reading and writing images, including classes, utilities, and applications"
|
||||
arch=(x86_64)
|
||||
url="http://www.openimageio.org/"
|
||||
license=('custom')
|
||||
depends=('openexr' 'boost-libs' 'openjpeg2' 'glew' 'libtiff' 'opencolorio' 'intel-tbb' 'libpng' 'libraw' 'libwebp'
|
||||
'fmt' 'pugixml' 'pybind11')
|
||||
# TODO: Consider adding these deps: 'openvdb' 'ffmpeg' 'ptex' 'libheif' 'hdf5' 'opencv'
|
||||
makedepends=('cmake' 'qt5-base' 'python' 'boost' 'mesa' 'freetype2' 'fontconfig' 'libxrender' 'ninja' 'robin-map')
|
||||
optdepends=('qt5-base: iv image viewer'
|
||||
'python: bindings support')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/Release-$pkgver.tar.gz"
|
||||
'0001-disable-neon.patch')
|
||||
sha512sums=('a36ffcf150cb1134aea33ec3e7ee2113c9df48c6860812a9e5ca519400211ba0fa5732153226f7e80cc20c2553834bd425adb93cdebbd5354612752f46ebc8e0'
|
||||
'ea88d253d9f9a9302ffe113c6d8f86ff990ada1c304c890d6aecdb4ad3370c9fd12887bb421aaaeff658af4840caefa9f243d3f552cbfc533403b81c2a56d156')
|
||||
|
||||
prepare() {
|
||||
cd oiio-Release-$pkgver
|
||||
patch -p1 -i ../0001-disable-neon.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd oiio-Release-$pkgver
|
||||
|
||||
cmake \
|
||||
-Bbuild \
|
||||
-GNinja \
|
||||
-DUSE_PYTHON=ON \
|
||||
-DPYTHON_VERSION=3.8 \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||
-DOIIO_BUILD_TESTS=ON \
|
||||
-DOIIO_BUILD_TOOLS=ON \
|
||||
-DBUILD_MISSING_FMT=OFF \
|
||||
-DUSE_EXTERNAL_PUGIXML=ON \
|
||||
-DSTOP_ON_WARNING=OFF
|
||||
ninja -C build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd oiio-Release-$pkgver
|
||||
|
||||
DESTDIR="$pkgdir" ninja -C build install
|
||||
|
||||
# Remove vendored fonts
|
||||
rm -r "$pkgdir"/usr/share/fonts
|
||||
|
||||
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE".md
|
||||
}
|
Loading…
Reference in a new issue