diff --git a/extra/fuse/PKGBUILD b/extra/fuse/PKGBUILD
deleted file mode 100644
index 88eec8df3..000000000
--- a/extra/fuse/PKGBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# $Id$
-# Maintainer: Ronald van Haren <ronald.archlinux.org>
-# Contributor: Tom Gundersen <teg@jklm.no>
-# Contributor: Mark Rosenstand <mark@archlinux.org>
-
-# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
-#  - patch for AArch64
-
-pkgname=fuse
-pkgver=2.9.7
-pkgrel=1
-pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
-arch=('i686' 'x86_64')
-url='https://github.com/libfuse/libfuse'
-license=('GPL2')
-depends=('glibc')
-makedepends=('pkg-config')
-backup=(etc/fuse.conf)
-_tag=fuse-$pkgver
-source=(https://github.com/libfuse/libfuse/archive/$_tag.zip
-	'fuse.conf'
-	'aarch64.patch')
-sha1sums=('805be38cbfb29d05036b03f2560b193010c38720'
-          '3b42e37a741d4651099225987dc40e7f02a716ad'
-          '0065fcb1b576ed21560c715158a88dc5e71f6611')
-
-prepare() {
-  cd libfuse-$_tag
-
-  patch -p1 -i ../aarch64.patch
-}
-
-build() {
-  cd libfuse-$_tag
-
-  ./makeconf.sh
-  export MOUNT_FUSE_PATH=/usr/bin
-  ./configure --prefix=/usr --libdir=/usr/lib --enable-lib --enable-util --disable-example
-  make
-}
-
-package() {
-  cd libfuse-$_tag
-
-  make DESTDIR=${pkgdir} install
-
-  # Remove init script in wrong path
-  # Don't add our own for now, as fusectl fs oopses on 2.6.18
-  rm -rf ${pkgdir}/etc/init.d
-
-  # install sample config file
-  install -Dm644 ${srcdir}/fuse.conf ${pkgdir}/etc/fuse.conf
-
-  # remove udev rules (is in the udev package}
-  rm -rf ${pkgdir}/etc/udev
-
-  # static device nodes are handled by udev
-  rm -rf ${pkgdir}/dev
-}
diff --git a/extra/fuse/aarch64.patch b/extra/fuse/aarch64.patch
deleted file mode 100644
index 66b795408..000000000
--- a/extra/fuse/aarch64.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Author: Riku Voipio <riku.voipio@linaro.org>
-Description: fuse_kernel.h: clean includes
- Use <linux/types.h> for linux and define types used for other operating systems
- using <stdint.h> types (Closes: #752081).
-
-diff -Naurp fuse.orig/include/fuse_kernel.h fuse/include/fuse_kernel.h
---- fuse.orig/include/fuse_kernel.h
-+++ fuse/include/fuse_kernel.h
-@@ -88,12 +88,16 @@
- #ifndef _LINUX_FUSE_H
- #define _LINUX_FUSE_H
- 
--#include <sys/types.h>
-+#ifdef __linux__
-+#include <linux/types.h>
-+#else
-+#include <stdint.h>
- #define __u64 uint64_t
- #define __s64 int64_t
- #define __u32 uint32_t
- #define __s32 int32_t
- #define __u16 uint16_t
-+#endif
- 
- /*
-  * Version negotiation:
diff --git a/extra/fuse/fuse.conf b/extra/fuse/fuse.conf
deleted file mode 100644
index cb6c631e0..000000000
--- a/extra/fuse/fuse.conf
+++ /dev/null
@@ -1,9 +0,0 @@
-# Set the maximum number of FUSE mounts allowed to non-root users.
-# The default is 1000.
-#
-#mount_max = 1000
-
-# Allow non-root users to specify the 'allow_other' or 'allow_root'
-# mount options.
-#
-#user_allow_other