mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/libvpx to 1.3.0-1
This commit is contained in:
parent
3a31cc8e0b
commit
8d2d140adb
2 changed files with 15 additions and 49 deletions
|
@ -2,38 +2,37 @@
|
|||
# Maintainer: Ionut Biru <ibiru@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix building
|
||||
# - disable neon
|
||||
|
||||
pkgname=libvpx
|
||||
pkgver=1.2.0
|
||||
pkgrel=2.1
|
||||
pkgdesc="The VP8 Codec SDK"
|
||||
pkgver=1.3.0
|
||||
pkgrel=1
|
||||
pkgdesc='The VP8 Codec SDK'
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.webmproject.org/"
|
||||
url='http://www.webmproject.org/'
|
||||
license=('BSD')
|
||||
depends=('glibc')
|
||||
makedepends=('yasm')
|
||||
source=(http://mirrors.kernel.org/archlinux/other/libvpx/libvpx-$pkgver.tar.xz{,.sig}
|
||||
fix-armhf-link.patch)
|
||||
sha1sums=('75cd953cf2db694412569272803fbdc73f2b599f'
|
||||
'SKIP'
|
||||
'bf81bc89d9d18930c2d8d52d1f7442926381b4d5')
|
||||
makedepends=('yasm' 'git')
|
||||
source=($pkgname::git+http://code.google.com/p/webm.libvpx#tag=v$pkgver)
|
||||
md5sums=('SKIP')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -p1 -i ../fix-armhf-link.patch
|
||||
./configure --prefix=/usr --enable-vp8 \
|
||||
cd $pkgname
|
||||
./configure --prefix=/usr \
|
||||
--enable-vp8 \
|
||||
--enable-vp9 \
|
||||
--enable-shared \
|
||||
--enable-postproc \
|
||||
--enable-pic \
|
||||
--disable-install-docs \
|
||||
--disable-install-srcs --disable-neon
|
||||
--disable-install-srcs \
|
||||
--disable-neon
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
cd $pkgname
|
||||
make DIST_DIR="$pkgdir/usr" install
|
||||
install -D -m 0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
diff --git a/build/make/configure.sh b/build/make/configure.sh
|
||||
index c99a01c..34f9baf 100755
|
||||
--- a/build/make/configure.sh
|
||||
+++ b/build/make/configure.sh
|
||||
@@ -775,7 +775,6 @@ process_common_toolchain() {
|
||||
|
||||
case ${tgt_cc} in
|
||||
gcc)
|
||||
- CROSS=${CROSS:-arm-none-linux-gnueabi-}
|
||||
link_with_cc=gcc
|
||||
setup_gnu_toolchain
|
||||
arch_int=${tgt_isa##armv}
|
||||
@@ -783,18 +782,14 @@ process_common_toolchain() {
|
||||
check_add_asflags --defsym ARCHITECTURE=${arch_int}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} == "armv7" ]; then
|
||||
- check_add_cflags -march=armv7-a -mfloat-abi=softfp
|
||||
- check_add_asflags -march=armv7-a -mfloat-abi=softfp
|
||||
+ check_add_cflags -march=armv7-a
|
||||
+ check_add_asflags -march=armv7-a
|
||||
|
||||
if enabled neon
|
||||
then
|
||||
check_add_cflags -mfpu=neon #-ftree-vectorize
|
||||
check_add_asflags -mfpu=neon
|
||||
fi
|
||||
-
|
||||
- if [ -z "${tune_cpu}" ]; then
|
||||
- tune_cpu=cortex-a8
|
||||
- fi
|
||||
else
|
||||
check_add_cflags -march=${tgt_isa}
|
||||
check_add_asflags -march=${tgt_isa}
|
Loading…
Reference in a new issue