mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/chromium to 22.0.1229.79-2
This commit is contained in:
parent
9489844688
commit
8d90fba0b2
2 changed files with 25 additions and 15 deletions
|
@ -15,8 +15,8 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=21.0.1180.89
|
||||
pkgrel=1
|
||||
pkgver=22.0.1229.79
|
||||
pkgrel=2
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.chromium.org/"
|
||||
|
@ -38,16 +38,14 @@ source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgna
|
|||
chromium.default
|
||||
chromium.sh
|
||||
chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
|
||||
chromium-20.0.1132.57-bison-2.6-fix.patch
|
||||
chromium-21.0.1180.57-fix-crash-in-task-queue.patch
|
||||
chromium-22.0.1229.79-only-use-the-different-return-type-under-test.patch
|
||||
chromium-ppapi-r0.patch)
|
||||
sha256sums=('16cca8d90a3369840f79a6f06d11756515fc8a4c3595060778dcab21e59235c5'
|
||||
sha256sums=('06cab1c48092def5bd94e9f4aa764f6ff5728ce35bbcdcc12fddbad3a0f0f738'
|
||||
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
|
||||
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
|
||||
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
|
||||
'c1baf14121502efbc2a31b64029dcafa0e28ca5b71ad0e28a3c6342d18198615'
|
||||
'd7aecc17e1eb582fe791c3e5fb2ca3f0efcb9bf5379309c1c27be35be4363bba'
|
||||
'cbd04d9a7cfda7e9c39fa215da897991a410fb59bf0f664abf93ab2c38689898'
|
||||
'9fd5cb18b109e172e6244456ba265c343460537d6acc0eb5c3def6ebc8272056'
|
||||
'1f4b57670d317959bc2dc60e5d2a44aa8fc6028f7ed540cdb502fa0aa99c81bd')
|
||||
|
||||
build() {
|
||||
|
@ -56,14 +54,9 @@ build() {
|
|||
# Fix build with glibc 2.16
|
||||
patch -Np1 -i "$srcdir/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch"
|
||||
|
||||
# Fix build with bison 2.6 (patch from Alexis Menard)
|
||||
# http://crbug.com/138243 / https://bugs.webkit.org/show_bug.cgi?id=92264
|
||||
patch -d third_party/WebKit -Np1 -i \
|
||||
"$srcdir/chromium-20.0.1132.57-bison-2.6-fix.patch"
|
||||
|
||||
# Fix crash in LazyBackgroundTaskQueue::ProcessPendingTasks
|
||||
# http://crbug.com/138790
|
||||
patch -Np1 -i "$srcdir/chromium-21.0.1180.57-fix-crash-in-task-queue.patch"
|
||||
# Fix return code when reusing the existing browser
|
||||
# http://code.google.com/p/chromium/issues/detail?id=146842
|
||||
patch -Np2 -i "$srcdir/chromium-22.0.1229.79-only-use-the-different-return-type-under-test.patch"
|
||||
|
||||
# Fix build without NaCl glibc toolchain (patch from Gentoo)
|
||||
patch -Np0 -i "$srcdir/chromium-ppapi-r0.patch"
|
||||
|
|
|
@ -0,0 +1,17 @@
|
|||
--- trunk/src/chrome/browser/chrome_browser_main.cc 2012/09/07 19:44:53 155456
|
||||
+++ trunk/src/chrome/browser/chrome_browser_main.cc 2012/09/07 19:45:06 155457
|
||||
@@ -1081,7 +1081,13 @@
|
||||
printf("%s\n", base::SysWideToNativeMB(UTF16ToWide(
|
||||
l10n_util::GetStringUTF16(IDS_USED_EXISTING_BROWSER))).c_str());
|
||||
#endif
|
||||
- return chrome::RESULT_CODE_NORMAL_EXIT_PROCESS_NOTIFIED;
|
||||
+ // Having a differentiated return type for testing allows for tests to
|
||||
+ // verify proper handling of some switches. When not testing, stick to
|
||||
+ // the standard Unix convention of returning zero when things went as
|
||||
+ // expected.
|
||||
+ if (parsed_command_line().HasSwitch(switches::kTestType))
|
||||
+ return chrome::RESULT_CODE_NORMAL_EXIT_PROCESS_NOTIFIED;
|
||||
+ return content::RESULT_CODE_NORMAL_EXIT;
|
||||
|
||||
case ProcessSingleton::PROFILE_IN_USE:
|
||||
return chrome::RESULT_CODE_PROFILE_IN_USE;
|
Loading…
Reference in a new issue