core/linux-armv7-rc to 6.0.rc2-1

This commit is contained in:
Kevin Mihelich 2022-08-27 22:21:51 +00:00
parent e26e1e660e
commit 8de2a22565
9 changed files with 872 additions and 616 deletions

View file

@ -1,4 +1,4 @@
From cf30569da906ee631341244693ab1affde38809d Mon Sep 17 00:00:00 2001
From 4533007cef1bd1da546752b372234b9bb9548214 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/7] ARM: atags: add support for Marvell's u-boot
@ -47,5 +47,5 @@ index 25ceda63b284..83578c54975b 100644
};
--
2.35.1
2.37.0

View file

@ -1,4 +1,4 @@
From 9f2269dc32ec1f583bba94432ca17dcef3778677 Mon Sep 17 00:00:00 2001
From b2f96ec9b408c8bbec437c3d3b54c0b748fca85a Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/7] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
@ -34,5 +34,5 @@ index 1feb6b0f7a1f..5e5cb3094b6a 100644
}
--
2.35.1
2.37.0

View file

@ -1,4 +1,4 @@
From e8da1680d0273aaca806c23a10b4f3467a6b4f96 Mon Sep 17 00:00:00 2001
From 5b76d7e549a6f65f881ef832cb39ae6a4ad34119 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 3/7] fix mvsdio eMMC timing
@ -34,5 +34,5 @@ index 629efbe639c4..c507c064736c 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.35.1
2.37.0

View file

@ -1,4 +1,4 @@
From f0eaedee0904275b2ed55b383dba794d53fac17d Mon Sep 17 00:00:00 2001
From 824cc151d839ce92269200119f9148013755adb8 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 4/7] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,18 +8,18 @@ Subject: [PATCH 4/7] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index bc1e3dd67c04..51ae8e6fec4e 100644
index bfb58c91db04..29b7c4cb90f1 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -50,6 +50,7 @@
@@ -54,6 +54,7 @@
#define SUSPEND_SUSPEND3 (0x08)
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
+#define MAC_ADDR_LEN (6)
struct smsc95xx_priv {
u32 mac_cr;
@@ -67,6 +68,10 @@ static bool turbo_mode = true;
#define SMSC95XX_NR_IRQS (1) /* raise to 12 for GPIOs */
#define PHY_HWIRQ (SMSC95XX_NR_IRQS - 1)
@@ -78,6 +79,10 @@ static bool turbo_mode = true;
module_param(turbo_mode, bool, 0644);
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
@ -27,10 +27,10 @@ index bc1e3dd67c04..51ae8e6fec4e 100644
+module_param(macaddr, charp, 0);
+MODULE_PARM_DESC(macaddr, "MAC address");
+
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data, int in_pm)
static int __must_check smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data)
{
@@ -753,8 +758,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
@@ -761,8 +766,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return phy_mii_ioctl(netdev->phydev, rq, cmd);
}
@ -91,5 +91,5 @@ index bc1e3dd67c04..51ae8e6fec4e 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.35.1
2.37.0

View file

@ -1,4 +1,4 @@
From 363e156344b831978306bf95dac7859dafe61d14 Mon Sep 17 00:00:00 2001
From 3a5136fec1bdb0f7a5ca614dab47c55c3177d26a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 5/7] set default cubietruck led triggers
@ -29,5 +29,5 @@ index 52160e368304..21c8ef94c756 100644
};
--
2.35.1
2.37.0

View file

@ -1,4 +1,4 @@
From b4dcf8b9c59c451b667f7cc3f20e7fe837951517 Mon Sep 17 00:00:00 2001
From c87c82c5a03baf1202d22567e4f6d113cfe17bad Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 6/7] exynos4412-odroid: set higher minimum buck2 regulator
@ -13,7 +13,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
index 5b1d4591b35c..8a8d2c6add10 100644
index e7669b9e9edb..a1b4e182717f 100644
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
@@ -436,7 +436,7 @@ buck1_reg: BUCK1 {
@ -26,5 +26,5 @@ index 5b1d4591b35c..8a8d2c6add10 100644
regulator-always-on;
regulator-boot-on;
--
2.35.1
2.37.0

View file

@ -1,4 +1,4 @@
From 915405b2da517ee56a07e57230273ab2ff4e522d Mon Sep 17 00:00:00 2001
From 23e406e404f935be33c917ca7772466dd52582c3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 11 Aug 2019 12:34:17 -0600
Subject: [PATCH 7/7] USB Armory MkII support
@ -12,21 +12,21 @@ Subject: [PATCH 7/7] USB Armory MkII support
create mode 100644 arch/arm/boot/dts/imx6ull-usbarmory.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 235ad559acb2..ca79830160bd 100644
index 05d8aef6e5d2..c6c76fa5047f 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -694,6 +694,7 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
@@ -722,6 +722,7 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ul-tx6ul-0010.dtb \
imx6ul-tx6ul-0011.dtb \
imx6ul-tx6ul-mainboard.dtb \
+ imx6ul-usbarmory.dtb \
imx6ull-14x14-evk.dtb \
imx6ull-colibri-emmc-eval-v3.dtb \
imx6ull-colibri-eval-v3.dtb \
@@ -704,6 +705,7 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ull-phytec-segin-ff-rdk-nand.dtb \
imx6ull-phytec-segin-ff-rdk-emmc.dtb \
imx6ull-phytec-segin-lc-rdk-nand.dtb \
imx6ull-colibri-aster.dtb \
imx6ull-colibri-emmc-aster.dtb \
@@ -745,6 +746,7 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ull-phytec-tauri-nand.dtb \
imx6ull-tqma6ull2-mba6ulx.dtb \
imx6ull-tqma6ull2l-mba6ulx.dtb \
+ imx6ull-usbarmory.dtb \
imx6ulz-14x14-evk.dtb \
imx6ulz-bsh-smm-m2.dtb
@ -557,5 +557,5 @@ index 000000000000..f74d0296d5f6
+ status = "okay";
+};
--
2.35.1
2.37.0

View file

@ -3,10 +3,10 @@
buildarch=4
_rcver=5.17
_rcrel=8
_rcnrel=armv7-x6
_rcnrc=7
_rcver=6.0
_rcrel=2
_rcnrel=armv7-x1
_rcnrc=2
pkgbase=linux-armv7-rc
_srcname=linux-${_rcver}-rc${_rcrel}
@ -34,16 +34,16 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'kernel_data_key.vbprivk'
'linux.preset'
'99-linux.hook')
md5sums=('b630bec9253ce4603ca26f09dbfd7fba'
'bc5ad00d71f3815ee55931e00ea44753'
'874e99c5570d305f43f9925592f08556'
'10f667fedbe19c86c8f51bf1f4edc527'
'19e8d3975bdd5171eef7f98ef50613d0'
'cd41f35d1fac769f411181b3008e4a5a'
'fe6296e63ea66ffb7c8d1ee841206eab'
'd89c1c23e9cf681e5e481b328cb0a9da'
'1e53ab3336cb431233ca5adb18e6d934'
'df398561bb1648aab2b623e1232857ca'
md5sums=('240e152f070588fc3ccc25d0bd63f8d1'
'e36fbdb86de12ec159b25fbbf7eb289f'
'9e9d3b4cde2e27afd79f8818eb86a493'
'46fd4237094df0d32e19ef797511195f'
'bb32c18626916fba143461da3b6d3f7a'
'8f18d1db15ced906458992ea5aafa79e'
'84b9e5ca6d5284561bcb4401d8cd693e'
'6226d24c61278a4b7835b0774a5d0149'
'30c239cd58141b8ae197b4d8efc5bdc7'
'a475824ddf070cc5fa59346dd37bdcaf'
'0963ff6490be16935370812fc75fa065'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
@ -108,7 +108,7 @@ build() {
_package() {
pkgdesc="The Linux Kernel and modules - ${_desc}"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
optdepends=('wireless-regdb: to set the correct wireless channels of your country')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
provides=("linux=${pkgver}" "WIREGUARD-MODULE")
conflicts=('linux')
@ -184,14 +184,6 @@ _package-headers() {
install -Dt "${_builddir}/arch/${KARCH}/kernel" -m644 arch/${KARCH}/kernel/asm-offsets.s
cp -t "${_builddir}/arch/${KARCH}" -a arch/${KARCH}/include
for i in dove omap2; do
mkdir -p "${_builddir}/arch/${KARCH}/mach-${i}"
cp -t "${_builddir}/arch/${KARCH}/mach-${i}" -a arch/$KARCH/mach-${i}/include
done
for i in omap orion versatile; do
mkdir -p "${_builddir}/arch/${KARCH}/plat-${i}"
cp -t "${_builddir}/arch/${KARCH}/plat-${i}" -a arch/$KARCH/plat-${i}/include
done
install -Dt "${_builddir}/drivers/md" -m644 drivers/md/*.h
install -Dt "${_builddir}/net/mac80211" -m644 net/mac80211/*.h

File diff suppressed because it is too large Load diff