mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-odroid-n2 to 4.9.210-1
This commit is contained in:
parent
10818fd57e
commit
8dffc2ce3d
2 changed files with 32 additions and 3 deletions
|
@ -0,0 +1,25 @@
|
|||
From 70dbd03df76b412fb11414bddc95b11ded5ab706 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 17 Jan 2020 18:14:30 -0700
|
||||
Subject: [PATCH] rtl8812au: fix maybe-uninitialized error
|
||||
|
||||
---
|
||||
drivers/net/wireless/rtl8812au/core/rtw_ap.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/net/wireless/rtl8812au/core/rtw_ap.c b/drivers/net/wireless/rtl8812au/core/rtw_ap.c
|
||||
index 1a12c3dee345..c223828a32b4 100644
|
||||
--- a/drivers/net/wireless/rtl8812au/core/rtw_ap.c
|
||||
+++ b/drivers/net/wireless/rtl8812au/core/rtw_ap.c
|
||||
@@ -194,7 +194,7 @@ void rtw_add_bcn_ie(_adapter *padapter, WLAN_BSSID_EX *pnetwork, u8 index, u8 *d
|
||||
u8 bmatch = _FALSE;
|
||||
u8 *pie = pnetwork->IEs;
|
||||
u8 *p=NULL, *dst_ie=NULL, *premainder_ie=NULL, *pbackup_remainder_ie=NULL;
|
||||
- u32 i, offset, ielen, ie_offset, remainder_ielen = 0;
|
||||
+ u32 i, offset, ielen = 0, ie_offset, remainder_ielen = 0;
|
||||
|
||||
for (i = sizeof(NDIS_802_11_FIXED_IEs); i < pnetwork->IELength;) {
|
||||
pIE = (PNDIS_802_11_VARIABLE_IEs)(pnetwork->IEs + i);
|
||||
--
|
||||
2.24.1
|
||||
|
|
@ -4,11 +4,11 @@
|
|||
buildarch=8
|
||||
|
||||
pkgbase=linux-odroid-n2
|
||||
_commit=782764b16ce1a3cfd6b530e5b49c31e28991672f
|
||||
_commit=78b85ed744a20e29e351ce4cbc727e40a7f27dbc
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ODROID-N2"
|
||||
pkgver=4.9.205
|
||||
pkgver=4.9.210
|
||||
pkgrel=1
|
||||
arch=('aarch64')
|
||||
url="https://github.com/hardkernel/linux/tree/odroidn2-4.9.y"
|
||||
|
@ -16,11 +16,13 @@ license=('GPL2')
|
|||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
|
||||
options=('!strip')
|
||||
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
||||
'0001-rtl8812au-fix-maybe-uninitialized-error.patch'
|
||||
'config'
|
||||
'linux.preset'
|
||||
'60-linux.hook'
|
||||
'90-linux.hook')
|
||||
md5sums=('a56d4604bb6d89501358b46774ca3f33'
|
||||
md5sums=('17545d8f0950abc396d908adcd8ccdc2'
|
||||
'0260cbce6933ed5f95ede70d90aad03a'
|
||||
'ec78eb89480b7bec3bc996eb6137c8fd'
|
||||
'86d4a35722b5410e3b29fc92dae15d4b'
|
||||
'ce6c81ad1ad1f8b333fd6077d47abdaf'
|
||||
|
@ -29,6 +31,8 @@ md5sums=('a56d4604bb6d89501358b46774ca3f33'
|
|||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
patch -p1 -i ../0001-rtl8812au-fix-maybe-uninitialized-error.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
# add pkgrel to extraversion
|
||||
|
|
Loading…
Reference in a new issue