core/linux-espressobin to 4.12.3-1

This commit is contained in:
Kevin Mihelich 2017-07-22 01:34:30 +00:00
parent 1b4482aed2
commit 8e05aedc12
13 changed files with 69 additions and 114 deletions

View file

@ -1,7 +1,7 @@
From e9fa04548195495c53ed7d13a7f6028f60b24fde Mon Sep 17 00:00:00 2001
From 792e2f54d07c74863fbd3132ce996e6dd9988f78 Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:34 +0100
Subject: [PATCH 02/12] ARM64: dts: marvell: armada37xx: Fix GIC maintenance
Subject: [PATCH 01/11] ARM64: dts: marvell: armada37xx: Fix GIC maintenance
interrupt
The GIC-500 integrated in the Armada-37xx SoCs is compliant with
@ -29,5 +29,5 @@ index bc179efb10ef..592e95e5f633 100644
};
--
2.13.2
2.13.3

View file

@ -1,42 +0,0 @@
From 88b3509f36a458b882b895ecf9eb50e922ddb2e1 Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:33 +0100
Subject: [PATCH 01/12] ARM64: dts: marvell: armada37xx: Fix timer interrupt
specifiers
Contrary to popular belief, PPIs connected to a GICv3 to not have
an affinity field similar to that of GICv2. That is consistent
with the fact that GICv3 is designed to accomodate thousands of
CPUs, and fitting them as a bitmap in a byte is... difficult.
Signed-off-by: Marc Zyngier <marc.zyngier@arm.com>
---
arch/arm64/boot/dts/marvell/armada-37xx.dtsi | 12 ++++--------
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
index 4d495ec39202..bc179efb10ef 100644
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
@@ -75,14 +75,10 @@
timer {
compatible = "arm,armv8-timer";
- interrupts = <GIC_PPI 13
- (GIC_CPU_MASK_SIMPLE(2) | IRQ_TYPE_LEVEL_HIGH)>,
- <GIC_PPI 14
- (GIC_CPU_MASK_SIMPLE(2) | IRQ_TYPE_LEVEL_HIGH)>,
- <GIC_PPI 11
- (GIC_CPU_MASK_SIMPLE(2) | IRQ_TYPE_LEVEL_HIGH)>,
- <GIC_PPI 10
- (GIC_CPU_MASK_SIMPLE(2) | IRQ_TYPE_LEVEL_HIGH)>;
+ interrupts = <GIC_PPI 13 IRQ_TYPE_LEVEL_HIGH>,
+ <GIC_PPI 14 IRQ_TYPE_LEVEL_HIGH>,
+ <GIC_PPI 11 IRQ_TYPE_LEVEL_HIGH>,
+ <GIC_PPI 10 IRQ_TYPE_LEVEL_HIGH>;
};
soc {
--
2.13.2

View file

@ -1,7 +1,7 @@
From 4d36e9fbcde62f6312d0f3c573aa0bb9ee48c478 Mon Sep 17 00:00:00 2001
From 2a993779ed34ad9669bffd437a7106f8a298a71d Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:35 +0100
Subject: [PATCH 03/12] ARM64: dts: marvell: armada37xx: Enable memory-mapped
Subject: [PATCH 02/11] ARM64: dts: marvell: armada37xx: Enable memory-mapped
GIC CPU interface
The Cortex-A53s that power the Armada-37xx SoCs are equipped with
@ -34,5 +34,5 @@ index 592e95e5f633..fd26d31d2846 100644
};
};
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From 55f2b7a0efc914173368405d1399f31a4ca76566 Mon Sep 17 00:00:00 2001
From da7c6201bef6779dbfb35eb66c4ca30a77508caf Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:36 +0100
Subject: [PATCH 04/12] ARM64: dts: marvell: armada37xx: Wire PMUv3
Subject: [PATCH 03/11] ARM64: dts: marvell: armada37xx: Wire PMUv3
The Cortex-A53s that power the Armada-37xx SoCs are equipped with
a PMUv3, just like most ARMv8 cores.
@ -31,5 +31,5 @@ index fd26d31d2846..f4deb8cd11c6 100644
compatible = "simple-bus";
#address-cells = <2>;
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From 8024835ce8bd95e953658bd3c83eadc3eaf4dec6 Mon Sep 17 00:00:00 2001
From 67d3a70c46ec6d531122e2bd207a1e38397038c3 Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:37 +0100
Subject: [PATCH 05/12] ARM64: dts: marvell: armada37xx: Enable USB2 on
Subject: [PATCH 04/11] ARM64: dts: marvell: armada37xx: Enable USB2 on
espressobin
The Espressobin SBC has a USB2 interface available on J8. Let's
@ -29,5 +29,5 @@ index e3a136ed77b0..b1af3f988b29 100644
switch0: switch0@1 {
compatible = "marvell,mv88e6085";
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From 85348a90e9b2bc41164e51184bad445bdc4b777d Mon Sep 17 00:00:00 2001
From 5943d262a9224e883371e40f1b98b03255ee4e19 Mon Sep 17 00:00:00 2001
From: Konstantin Porotchkin <kostap@marvell.com>
Date: Tue, 23 May 2017 16:11:40 +0300
Subject: [PATCH 06/12] arm64: dts: marvell: Enable second SDHCI controller in
Subject: [PATCH 05/11] arm64: dts: marvell: Enable second SDHCI controller in
Armada 37xx
The Armada 37xx SoCs has 2 SDHCI interfaces. This patch adds the second
@ -68,5 +68,5 @@ index f4deb8cd11c6..a78195b4ef7a 100644
compatible = "marvell,armada-3700-sdhci",
"marvell,sdhci-xenon";
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From 191c274b6024a3b3055200e909d6ad68872fa976 Mon Sep 17 00:00:00 2001
From b05ee624e1e2dbd155be851cd64a14d711545238 Mon Sep 17 00:00:00 2001
From: Sean Nyekjaer <sean@nyekjaer.dk>
Date: Sun, 25 Jun 2017 21:20:05 +0200
Subject: [PATCH 07/12] arm64: dts: marvell: Add microsd card definition for
Subject: [PATCH 06/11] arm64: dts: marvell: Add microsd card definition for
the ESPRESSObin
This defines and enables the microsd card on the
@ -42,5 +42,5 @@ index b1af3f988b29..409385c4195a 100644
&usb3 {
status = "okay";
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From d07fa043fcdf4b15c70e90a7701ad8dc0a9a1158 Mon Sep 17 00:00:00 2001
From 70150dbcc8e10bf5c060eaa2ca62c38e669cd51f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 4 Jul 2017 19:25:28 -0600
Subject: [PATCH 08/12] arm64: dts: marvell: armada37xx: Add eth0 alias
Subject: [PATCH 07/11] arm64: dts: marvell: armada37xx: Add eth0 alias
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -21,5 +21,5 @@ index a78195b4ef7a..14248957b2dd 100644
};
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From 3c4ad04a042ca8022cbb8511742ea297536b78fd Mon Sep 17 00:00:00 2001
From 34d2d35b71e9633d92833816759cecd77044479c Mon Sep 17 00:00:00 2001
From: Victor Gu <xigu@marvell.com>
Date: Wed, 29 Mar 2017 15:17:03 +0800
Subject: [PATCH 09/12] fix: pci: aardvark: disable LOS state by default
Subject: [PATCH 08/11] fix: pci: aardvark: disable LOS state by default
Some PCIe devices do not support LOS, there will be time out issue
if the RC forces the LOS state.
@ -31,5 +31,5 @@ index 37d0bcd31f8a..072bc70e900c 100644
reg = advk_readl(pcie, PCIE_CORE_CMD_STATUS_REG);
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From 9fe10853807dd1bd370ca2bf8baf76c4cfe242a9 Mon Sep 17 00:00:00 2001
From 181d38497946c60cb18afb2f16d6aad241817110 Mon Sep 17 00:00:00 2001
From: Victor Gu <xigu@marvell.com>
Date: Mon, 27 Mar 2017 18:28:25 +0800
Subject: [PATCH 10/12] fix: pci: aardvark: use isr1 interrupt in legacy irq
Subject: [PATCH 09/11] fix: pci: aardvark: use isr1 interrupt in legacy irq
mode
The Aardvark has two interrupts sets, first set is bit[23:16] of
@ -100,5 +100,5 @@ index 072bc70e900c..10154dcf219b 100644
virq = irq_find_mapping(pcie->irq_domain, i);
generic_handle_irq(virq);
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From 4455b4e78d3696f842d7b27ff6e4c1c15adffbf3 Mon Sep 17 00:00:00 2001
From 85d74730e0aefda9425ebe205619b63cedf2636e Mon Sep 17 00:00:00 2001
From: Victor Gu <xigu@marvell.com>
Date: Fri, 24 Mar 2017 20:52:30 +0800
Subject: [PATCH 11/12] pci: aardvard: set host and device to the same MAX
Subject: [PATCH 10/11] pci: aardvard: set host and device to the same MAX
payload size
Since the Aardvard does not implement PCIe root bus, the Linux PCIe
@ -101,5 +101,5 @@ index 10154dcf219b..0407c8cb89fb 100644
return 0;
}
--
2.13.2
2.13.3

View file

@ -1,7 +1,7 @@
From ebd87e2955e49f5197aff99702606866e8729a1d Mon Sep 17 00:00:00 2001
From 61f340e9b751bca4cd9178d34d08cdf04893e156 Mon Sep 17 00:00:00 2001
From: Victor Gu <xigu@marvell.com>
Date: Fri, 24 Mar 2017 20:41:55 +0800
Subject: [PATCH 12/12] fix: pcie: aardvark: correct the default MAX payload
Subject: [PATCH 11/11] fix: pcie: aardvark: correct the default MAX payload
size
The previous PCIe MAX payload field is set to 7 which is undefined
@ -40,5 +40,5 @@ index 0407c8cb89fb..cac1558b8d3b 100644
PCIE_CORE_DEV_CTRL_STATS_MAX_RD_REQ_SIZE_SHIFT;
advk_writel(pcie, reg, PCIE_CORE_DEV_CTRL_STATS_REG);
--
2.13.2
2.13.3

View file

@ -7,7 +7,7 @@ pkgbase=linux-espressobin
_srcname=linux-4.12
_kernelname=${pkgbase#linux}
_desc="Globalscale ESPRESSOBin"
pkgver=4.12.2
pkgver=4.12.3
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
@ -16,34 +16,32 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
'0001-ARM64-dts-marvell-armada37xx-Fix-timer-interrupt-spe.patch'
'0002-ARM64-dts-marvell-armada37xx-Fix-GIC-maintenance-int.patch'
'0003-ARM64-dts-marvell-armada37xx-Enable-memory-mapped-GI.patch'
'0004-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch'
'0005-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch'
'0006-arm64-dts-marvell-Enable-second-SDHCI-controller-in-.patch'
'0007-arm64-dts-marvell-Add-microsd-card-definition-for-th.patch'
'0008-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch'
'0009-fix-pci-aardvark-disable-LOS-state-by-default.patch'
'0010-fix-pci-aardvark-use-isr1-interrupt-in-legacy-irq-mo.patch'
'0011-pci-aardvard-set-host-and-device-to-the-same-MAX-pay.patch'
'0012-fix-pcie-aardvark-correct-the-default-MAX-payload-si.patch'
'0001-ARM64-dts-marvell-armada37xx-Fix-GIC-maintenance-int.patch'
'0002-ARM64-dts-marvell-armada37xx-Enable-memory-mapped-GI.patch'
'0003-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch'
'0004-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch'
'0005-arm64-dts-marvell-Enable-second-SDHCI-controller-in-.patch'
'0006-arm64-dts-marvell-Add-microsd-card-definition-for-th.patch'
'0007-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch'
'0008-fix-pci-aardvark-disable-LOS-state-by-default.patch'
'0009-fix-pci-aardvark-use-isr1-interrupt-in-legacy-irq-mo.patch'
'0010-pci-aardvard-set-host-and-device-to-the-same-MAX-pay.patch'
'0011-fix-pcie-aardvark-correct-the-default-MAX-payload-si.patch'
'config'
'linux.preset')
md5sums=('fc454157e2d024d401a60905d6481c6b'
'df72b6950492a79610d443d8992b3293'
'b2a7116c7b3908fe1603c796f83fb56c'
'2f43eba428830c7a7bf4a520f7077535'
'9d0f72905f1f1320f52d6f65dd668d0b'
'b50d466feecea898a74c3867319fb90e'
'd79d1f0f7d9a7c35137229e70a30c0d7'
'3e60cf410ae3bb37c01d2eb04501d174'
'57dace766b81b0680ac43f37765d7018'
'd659197cb859a9976123b73dc796db9f'
'b24d333e00622a48ea68058b6157d276'
'4f340086bdc4fab53ac271f821a62176'
'f3f6c6fe3645783486aac43e4d7c00ec'
'd540534a40050f4dfea2bd658b89e038'
'e119cc2b89646167b63aab0ae6ac916c'
'9647a04afabc1aaa0e99ed31988f9358'
'5a8ed7f3dfa667557a4bc1f80adef594'
'e9172548f2bb05e3782ace8139569371'
'07abbd10d99d1b14fc872931d501eab3'
'0a0c95c38f0ca4e0c1bef400b087ee4b'
'3c5f88901967e6c23ea860a9b02db23f'
'2fb6ce5073e76b8f1d3b0ddc82912775'
'c5293d8d517fc9f1d8d28275ee2e412f'
'b85e8d83529df2ddddef257f1ed457d9'
'3d02f59fefe47f9c03eba3ac5acece57'
'af80e6f7b84ae0d2714ee0707c9bc16b'
'aafe13461c5fed44285f685025ec610f'
'd8d30aa4a9d4c2b8d4ea53faf46ccf80')
@ -54,18 +52,17 @@ prepare() {
git apply --whitespace=nowarn ../patch-${pkgver}
# ALARM patches
git apply ../0001-ARM64-dts-marvell-armada37xx-Fix-timer-interrupt-spe.patch
git apply ../0002-ARM64-dts-marvell-armada37xx-Fix-GIC-maintenance-int.patch
git apply ../0003-ARM64-dts-marvell-armada37xx-Enable-memory-mapped-GI.patch
git apply ../0004-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch
git apply ../0005-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch
git apply ../0006-arm64-dts-marvell-Enable-second-SDHCI-controller-in-.patch
git apply ../0007-arm64-dts-marvell-Add-microsd-card-definition-for-th.patch
git apply ../0008-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch
git apply ../0009-fix-pci-aardvark-disable-LOS-state-by-default.patch
git apply ../0010-fix-pci-aardvark-use-isr1-interrupt-in-legacy-irq-mo.patch
git apply ../0011-pci-aardvard-set-host-and-device-to-the-same-MAX-pay.patch
git apply ../0012-fix-pcie-aardvark-correct-the-default-MAX-payload-si.patch
git apply ../0001-ARM64-dts-marvell-armada37xx-Fix-GIC-maintenance-int.patch
git apply ../0002-ARM64-dts-marvell-armada37xx-Enable-memory-mapped-GI.patch
git apply ../0003-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch
git apply ../0004-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch
git apply ../0005-arm64-dts-marvell-Enable-second-SDHCI-controller-in-.patch
git apply ../0006-arm64-dts-marvell-Add-microsd-card-definition-for-th.patch
git apply ../0007-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch
git apply ../0008-fix-pci-aardvark-disable-LOS-state-by-default.patch
git apply ../0009-fix-pci-aardvark-use-isr1-interrupt-in-legacy-irq-mo.patch
git apply ../0010-pci-aardvard-set-host-and-device-to-the-same-MAX-pay.patch
git apply ../0011-fix-pcie-aardvark-correct-the-default-MAX-payload-si.patch
cat "${srcdir}/config" > ./.config
@ -104,7 +101,7 @@ build() {
# build!
unset LDFLAGS
make ${MAKEFLAGS} Image Image.gz modules dtbs
make ${MAKEFLAGS} Image modules dtbs
}
_package() {