mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-armv5 to 4.0.5-1
This commit is contained in:
parent
c969544081
commit
8e6476ebd9
2 changed files with 3 additions and 55 deletions
|
@ -1,50 +0,0 @@
|
|||
From bbfb0c2a33848ed6aa2eeedef96ae3a5a153456c Mon Sep 17 00:00:00 2001
|
||||
From: Eric Work <work.eric@gmail.com>
|
||||
Date: Mon, 18 May 2015 23:26:23 -0700
|
||||
Subject: [PATCH] md/raid0: fix restore to sector variable in
|
||||
raid0_make_request
|
||||
|
||||
The variable "sector" in "raid0_make_request()" was improperly updated
|
||||
by a call to "sector_div()" which modifies its first argument in place.
|
||||
Commit 47d68979cc968535cb87f3e5f2e6a3533ea48fbd restored this variable
|
||||
after the call for later re-use. Unfortunetly the restore was done after
|
||||
the referenced variable "bio" was advanced. This lead to the original
|
||||
value and the restored value being different. Here we move this line to
|
||||
the proper place.
|
||||
|
||||
One observed side effect of this bug was discarding a file though
|
||||
unlinking would cause an unrelated file's contents to be discarded.
|
||||
|
||||
Signed-off-by: NeilBrown <neilb@suse.de>
|
||||
Fixes: 47d68979cc96 ("md/raid0: fix bug with chunksize not a power of 2.")
|
||||
Cc: stable@vger.kernel.org (any that received above backport)
|
||||
URL: https://bugzilla.kernel.org/show_bug.cgi?id=98501
|
||||
---
|
||||
drivers/md/raid0.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/md/raid0.c b/drivers/md/raid0.c
|
||||
index 3b5d7f7..903391c 100644
|
||||
--- a/drivers/md/raid0.c
|
||||
+++ b/drivers/md/raid0.c
|
||||
@@ -517,6 +517,9 @@ static void raid0_make_request(struct mddev *mddev, struct bio *bio)
|
||||
? (sector & (chunk_sects-1))
|
||||
: sector_div(sector, chunk_sects));
|
||||
|
||||
+ /* Restore due to sector_div */
|
||||
+ sector = bio->bi_iter.bi_sector;
|
||||
+
|
||||
if (sectors < bio_sectors(bio)) {
|
||||
split = bio_split(bio, sectors, GFP_NOIO, fs_bio_set);
|
||||
bio_chain(split, bio);
|
||||
@@ -524,7 +527,6 @@ static void raid0_make_request(struct mddev *mddev, struct bio *bio)
|
||||
split = bio;
|
||||
}
|
||||
|
||||
- sector = bio->bi_iter.bi_sector;
|
||||
zone = find_zone(mddev->private, §or);
|
||||
tmp_dev = map_sector(mddev, zone, sector, §or);
|
||||
split->bi_bdev = tmp_dev->bdev;
|
||||
--
|
||||
2.4.1
|
||||
|
|
@ -7,8 +7,8 @@ pkgbase=linux-armv5
|
|||
_srcname=linux-4.0
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv5 multi-platform"
|
||||
pkgver=4.0.4
|
||||
pkgrel=2
|
||||
pkgver=4.0.5
|
||||
pkgrel=1
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -22,10 +22,9 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'0002-ARM-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch'
|
||||
'0003-imx23-I2C-fixes.patch'
|
||||
'0004-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
|
||||
'0001-md-raid0-fix-restore-to-sector-variable-in-raid0_mak.patch'
|
||||
'config')
|
||||
md5sums=('a86916bd12798220da9eb4a1eec3616d'
|
||||
'30de8c55237264deee4d4fc60eee78fd'
|
||||
'd634b677385910495fd0c831c0cc5520'
|
||||
'SKIP'
|
||||
'ed7991bb04554fd9ed4292ffd07bc916'
|
||||
'9225efbd445352fcfeaa83317bed0825'
|
||||
|
@ -44,7 +43,6 @@ prepare() {
|
|||
git apply ../0002-ARM-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch
|
||||
git apply ../0003-imx23-I2C-fixes.patch
|
||||
git apply ../0004-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
|
||||
git apply ../0001-md-raid0-fix-restore-to-sector-variable-in-raid0_mak.patch
|
||||
|
||||
# AUFS patches
|
||||
cp -ru "${srcdir}/aufs4-standalone/Documentation" .
|
||||
|
|
Loading…
Reference in a new issue