extra/doxygen to 1.8.12-1

This commit is contained in:
Kevin Mihelich 2016-09-18 18:37:37 +00:00
parent ebd651ff39
commit 8e748b54f7
2 changed files with 5 additions and 45 deletions

View file

@ -1,33 +0,0 @@
From 7725d0a48aee2928dc0544ccbb0aa79ddb3a74d4 Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Wed, 9 Dec 2015 18:16:09 +0200
Subject: [PATCH] Partial revert of commit 080a465b1321
Fixes generation of libstd++ man pages.
https://bugzilla.gnome.org/show_bug.cgi?id=759241
---
src/util.cpp | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/src/util.cpp b/src/util.cpp
index 3ee7ae5..0bf9940 100644
--- a/src/util.cpp
+++ b/src/util.cpp
@@ -1741,11 +1741,9 @@ nextChar:
}
else if (i>0 &&
(
- (s.at(i-1)==')' && isId(c)) // ")id" -> ") id"
+ (s.at(i-1)==')' && isId(c))
||
- (c=='\'' && s.at(i-1)==' ') // "'id" -> "' id"
- ||
- (i>1 && s.at(i-2)==' ' && s.at(i-1)==' ') // " id" -> " id"
+ (c=='\'' && s.at(i-1)==' ')
)
)
{
--
2.6.3

View file

@ -3,22 +3,18 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org> # ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - drop docs package for now, hangs build # - drop docs package for now, hangs build
# - patch for AArch64
pkgname=doxygen pkgname=doxygen
pkgver=1.8.11 pkgver=1.8.12
pkgrel=4 pkgrel=1
license=('GPL') license=('GPL')
arch=(i686 x86_64) arch=(i686 x86_64)
url="http://www.doxygen.org/" url="http://www.doxygen.org/"
makedepends=('cmake' 'gcc-libs' 'flex' 'qt4' 'texlive-core' 'ghostscript' makedepends=('cmake' 'gcc-libs' 'flex' 'qt4' 'texlive-core' 'ghostscript'
'texlive-latexextra' 'graphviz' 'python2') 'texlive-latexextra' 'graphviz' 'python2')
source=(http://ftp.stack.nl/pub/users/dimitri/${pkgname}-${pkgver}.src.tar.gz source=(http://ftp.stack.nl/pub/users/dimitri/${pkgname}-${pkgver}.src.tar.gz)
0001-Partial-revert-of-commit-080a465b1321.patch) md5sums=('08e0f7850c4d22cb5188da226b209a96')
md5sums=('f4697a444feaed739cfa2f0644abc19b' sha1sums=('eacf83859a5bd7f3f71b46f34759cefe1a05babc')
'93cc5bb3f18c73a3e2b53d6276d87a11')
sha1sums=('c0841007cf8a7910ccf0d8e4f7a5dd8fd2d9fc18'
'aa03a6a51ff691ffef11d96bb25236f2f7655b6b')
prepare() { prepare() {
mkdir build mkdir build
@ -27,9 +23,6 @@ prepare() {
# Install the man pages in the right place # Install the man pages in the right place
sed -i 's:DESTINATION man/man1:DESTINATION "${CMAKE_INSTALL_PREFIX}/share/man/man1":g' \ sed -i 's:DESTINATION man/man1:DESTINATION "${CMAKE_INSTALL_PREFIX}/share/man/man1":g' \
doc/CMakeLists.txt doc/CMakeLists.txt
# https://bugzilla.gnome.org/show_bug.cgi?id=759241
patch -Np1 -i ../0001-Partial-revert-of-commit-080a465b1321.patch
} }
build() { build() {