mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
commit
8eb6a94430
2 changed files with 17 additions and 2 deletions
|
@ -18,11 +18,14 @@ url="http://www.gnu.org/software/libtool"
|
|||
makedepends=('gcc=4.8.1')
|
||||
license=('GPL')
|
||||
options=('!libtool' '!distcc')
|
||||
source=(ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.xz{,.sig})
|
||||
source=(ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.xz{,.sig}
|
||||
armv7h-nopic.patch)
|
||||
md5sums=('2ec8997e0c07249eb4cbd072417d70fe'
|
||||
'1e6ba57420c82c663c85e745d11c7eed')
|
||||
'1e6ba57420c82c663c85e745d11c7eed'
|
||||
'7ba2180372dc52d4bfb31a9bafead630')
|
||||
|
||||
build() {
|
||||
[[ $CARCH == "armv7h" ]] && patch -p0 -i ${srcdir}/armv7h-nopic.patch
|
||||
cd ${srcdir}/${pkgbase}-${pkgver}
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
|
@ -53,3 +56,4 @@ package_libltdl() {
|
|||
install-ltdlincludeHEADERS install-data-local
|
||||
rm -rf ${pkgdir}/usr/share/{aclocal,libtool/config}
|
||||
}
|
||||
|
||||
|
|
11
core/libtool/armv7h-nopic.patch
Normal file
11
core/libtool/armv7h-nopic.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- libtool-2.4.2/tests/demo-nopic.test.orig 2013-10-10 10:55:49.686651787 -0500
|
||||
+++ libtool-2.4.2/tests/demo-nopic.test 2013-10-10 05:45:45.027421384 -0500
|
||||
@@ -26,7 +26,7 @@
|
||||
. tests/defs || exit 1
|
||||
|
||||
case "$host" in
|
||||
-hppa*|x86_64*|s390*)
|
||||
+hppa*|x86_64*|s390*|arm*)
|
||||
func_skip "$host doesn't like non-PIC shared libs"
|
||||
;;
|
||||
*-solaris*|*-sunos*)
|
Loading…
Reference in a new issue