extra/qt5-base to 5.13.1-2

This commit is contained in:
Kevin Mihelich 2019-09-11 12:27:05 +00:00
parent f0b4ed791f
commit 8ede19497c
3 changed files with 18 additions and 25 deletions

View file

@ -8,9 +8,9 @@
pkgbase=qt5-base
pkgname=(qt5-base qt5-xcb-private-headers)
_qtver=5.13.0
_qtver=5.13.1
pkgver=${_qtver/-/}
pkgrel=7
pkgrel=2
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@ -32,13 +32,9 @@ conflicts=('qtchooser')
groups=('qt' 'qt5')
_pkgfqn="${pkgbase/5-/}-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
qtbase-qxcbwindow.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=0c183117"
qtbase-zlib-compression.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=cbdc9a77"
virtualbox-focus.patch)
sha256sums=('ff6964b3b528cd3b1d21bcf3470006e8e5cbe69591923f982871d886ea0488fe'
'51878fdf91d3f191fb4e19cd9ec3fc4c564bbf1eabe92802b40db2ec8ad1d646'
'9300d8ab7abe4145e92eea75178a26ad3d5a71b0646665c3776ca2c375dd1233'
'21c4acce7a789cd0e1e67aca76cf15f536ae8e30ef711a434cfe7ec377556f06')
qtbug-77364.patch)
sha256sums=('110cd08cdacab26274bf2519d3508046616c0b638f0d2f5e00bc8bad87469eab'
'dc742814ab0c1b63da5916d96e3ef01fa96007c385ed033ae5b3a8cd8608c119')
prepare() {
cd ${_pkgfqn}
@ -50,9 +46,7 @@ prepare() {
sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
mkspecs/common/g++-unix.conf
patch -p1 -i ../qtbase-qxcbwindow.patch # Fix NVIDIA freeze
patch -p1 -i ../qtbase-zlib-compression.patch # Change the default compression back to zlib for backwards compatibility
patch -p1 -i ../virtualbox-focus.patch # Fix virtualbox constantly stealing focus https://bugreports.qt.io/browse/QTBUG-76742
patch -p1 -i ../qtbug-77364.patch # Fix keyboard input in webengine
}
build() {

View file

@ -0,0 +1,12 @@
diff --git a/src/widgets/kernel/qwidget.cpp b/src/widgets/kernel/qwidget.cpp
index 04290a4ce1..27773d5762 100644
--- a/src/widgets/kernel/qwidget.cpp
+++ b/src/widgets/kernel/qwidget.cpp
@@ -6446,7 +6446,7 @@ void QWidget::setFocusProxy(QWidget * w)
if (changingAppFocusWidget) {
QWidget *newDeepestFocusProxy = d_func()->deepestFocusProxy();
- QApplicationPrivate::focus_widget = newDeepestFocusProxy ? newDeepestFocusProxy : this;
+ QApplicationPrivate::setFocusWidget(newDeepestFocusProxy ? newDeepestFocusProxy : this, Qt::NoFocusReason);
}
}

View file

@ -1,13 +0,0 @@
diff --git a/src/plugins/platforms/xcb/qxcbwindow.cpp b/src/plugins/platforms/xcb/qxcbwindow.cpp
index 9382488b74..1bf1ab268d 100644
--- a/src/plugins/platforms/xcb/qxcbwindow.cpp
+++ b/src/plugins/platforms/xcb/qxcbwindow.cpp
@@ -848,7 +848,7 @@ void QXcbWindow::doFocusOut()
connection()->setFocusWindow(nullptr);
relayFocusToModalWindow();
// Do not set the active window to nullptr if there is a FocusIn coming.
- connection()->focusInTimer().start(400);
+ connection()->focusInTimer().start(100);
}
struct QtMotifWmHints {