mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/gdal to 2.0.0-1
This commit is contained in:
parent
2148614b02
commit
8f0c006e53
4 changed files with 17 additions and 24 deletions
|
@ -8,29 +8,28 @@
|
||||||
# - use uname in path in removing rpath in packaging
|
# - use uname in path in removing rpath in packaging
|
||||||
|
|
||||||
pkgname=gdal
|
pkgname=gdal
|
||||||
pkgver=1.11.2
|
pkgver=2.0.0
|
||||||
pkgrel=5
|
pkgrel=1
|
||||||
pkgdesc="A translator library for raster geospatial data formats"
|
pkgdesc="A translator library for raster geospatial data formats"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url="http://www.gdal.org/"
|
url="http://www.gdal.org/"
|
||||||
license=('custom')
|
license=('custom')
|
||||||
depends=('curl' 'geos' 'giflib' 'hdf5' 'libgeotiff' 'libjpeg' 'libpng' 'libspatialite' 'libtiff' 'netcdf' 'python2' 'python2-numpy' 'cfitsio' 'sqlite' 'libmariadbclient' 'postgresql-libs')
|
depends=('curl' 'geos' 'giflib' 'hdf5' 'libgeotiff' 'libjpeg' 'libpng' 'libspatialite' 'libtiff' 'netcdf'
|
||||||
|
'python2' 'python2-numpy' 'cfitsio' 'sqlite' 'libmariadbclient' 'postgresql-libs')
|
||||||
makedepends=('perl' 'swig' 'chrpath' 'doxygen')
|
makedepends=('perl' 'swig' 'chrpath' 'doxygen')
|
||||||
optdepends=('postgresql: postgresql database support'
|
optdepends=('postgresql: postgresql database support'
|
||||||
'mariadb: mariadb database support'
|
'mariadb: mariadb database support'
|
||||||
'perl: perl binding support')
|
'perl: perl binding support')
|
||||||
|
options=('!emptydirs')
|
||||||
changelog=$pkgname.changelog
|
changelog=$pkgname.changelog
|
||||||
source=(http://download.osgeo.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz
|
source=(http://download.osgeo.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz
|
||||||
gdal-1.5.1-python-install.patch
|
gdal-python-install.patch)
|
||||||
poppler-0.31.patch)
|
|
||||||
sha256sums=('66bc8192d24e314a66ed69285186d46e6999beb44fc97eeb9c76d82a117c0845'
|
sha256sums=('66bc8192d24e314a66ed69285186d46e6999beb44fc97eeb9c76d82a117c0845'
|
||||||
'55a0a961b2d1caddf80f18b6763a96690b0b6443fbd5a0c89e29503ded3bcea6'
|
'55a0a961b2d1caddf80f18b6763a96690b0b6443fbd5a0c89e29503ded3bcea6')
|
||||||
'4fc42bdb729cec92920236ef9f3302fab497069dbb7d41d81222e7e48a36e7a6')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}"/$pkgname-$pkgver
|
cd "${srcdir}"/$pkgname-$pkgver
|
||||||
patch -Np0 -i "${srcdir}"/gdal-1.5.1-python-install.patch
|
patch -Np0 -i "${srcdir}"/gdal-python-install.patch
|
||||||
patch -Np1 -i "${srcdir}"/poppler-0.31.patch
|
|
||||||
|
|
||||||
# python2 fixes
|
# python2 fixes
|
||||||
sed -i 's_python python1.5_python2 python python1.5_' configure
|
sed -i 's_python python1.5_python2 python python1.5_' configure
|
||||||
|
@ -50,8 +49,8 @@ build() {
|
||||||
export LDFLAGS="$LDFLAGS -Wl,--as-needed"
|
export LDFLAGS="$LDFLAGS -Wl,--as-needed"
|
||||||
|
|
||||||
./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 \
|
./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 \
|
||||||
--with-geotiff --with-mysql --with-python --with-curl \
|
--with-geotiff --with-mysql --with-python --with-curl --with-hdf5 \
|
||||||
--with-hdf5 --with-perl --with-geos --with-png --with-spatialite
|
--with-perl --with-geos --with-png --with-spatialite
|
||||||
|
|
||||||
# workaround for bug #13646
|
# workaround for bug #13646
|
||||||
sed -i 's/PY_HAVE_SETUPTOOLS=1/PY_HAVE_SETUPTOOLS=/g' ./GDALmake.opt
|
sed -i 's/PY_HAVE_SETUPTOOLS=1/PY_HAVE_SETUPTOOLS=/g' ./GDALmake.opt
|
||||||
|
@ -67,7 +66,7 @@ package () {
|
||||||
make DESTDIR="${pkgdir}" install-man
|
make DESTDIR="${pkgdir}" install-man
|
||||||
|
|
||||||
# install license
|
# install license
|
||||||
install -D -m644 LICENSE.TXT "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
|
install -Dm644 LICENSE.TXT "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
|
||||||
|
|
||||||
#FS15477 clean up junks
|
#FS15477 clean up junks
|
||||||
rm -f "${pkgdir}"/usr/bin/*.dox
|
rm -f "${pkgdir}"/usr/bin/*.dox
|
||||||
|
|
|
@ -1,3 +1,9 @@
|
||||||
|
2015-06-27 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
||||||
|
* gdal 2.0.0
|
||||||
|
|
||||||
|
2015-03-01 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
||||||
|
* gdal 1.11.2-2 poppler 0.31.0 rebuild
|
||||||
|
|
||||||
2014-12-22 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
2014-12-22 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
||||||
* gdal 1.11.1-5 FS#43193 fix
|
* gdal 1.11.1-5 FS#43193 fix
|
||||||
|
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff -Nur gdal-1.11.2/frmts/pdf/pdfdataset.cpp gdal-1.11.2a/frmts/pdf/pdfdataset.cpp
|
|
||||||
--- gdal-1.11.2/frmts/pdf/pdfdataset.cpp 2015-02-10 13:11:19.000000000 +0100
|
|
||||||
+++ gdal-1.11.2a/frmts/pdf/pdfdataset.cpp 2015-03-02 18:38:25.170155277 +0100
|
|
||||||
@@ -113,7 +113,7 @@
|
|
||||||
GBool allowAntialiasA = gTrue) :
|
|
||||||
SplashOutputDev(colorModeA, bitmapRowPadA,
|
|
||||||
reverseVideoA, paperColorA,
|
|
||||||
- bitmapTopDownA, allowAntialiasA),
|
|
||||||
+ bitmapTopDownA),
|
|
||||||
bEnableVector(TRUE),
|
|
||||||
bEnableText(TRUE),
|
|
||||||
bEnableBitmap(TRUE) {}
|
|
Loading…
Reference in a new issue