mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed community/pdns and pdns-recursor
This commit is contained in:
parent
fa09b95b7a
commit
8f38d8e943
6 changed files with 0 additions and 574 deletions
|
@ -1,47 +0,0 @@
|
|||
# $Id: PKGBUILD 90828 2013-05-14 12:04:07Z arodseth $
|
||||
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
|
||||
# Contributor: Jan de Groot <jgc@archlinux.org>
|
||||
# Contributor: Jan Steffens <heftig@archlinux.org>
|
||||
|
||||
# Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - fix for aeskey.c on ARM (http://wiki.powerdns.com/trac/changeset/3162/)
|
||||
|
||||
pkgname=pdns-recursor
|
||||
pkgver=3.5.3
|
||||
pkgrel=1
|
||||
pkgdesc='PowerDNS recursor'
|
||||
url='https://www.powerdns.com/'
|
||||
license=('GPL')
|
||||
arch=('x86_64' 'i686')
|
||||
depends=('gcc-libs' 'lua51')
|
||||
makedepends=('boost')
|
||||
backup=('etc/powerdns/recursor.conf')
|
||||
source=("http://downloads.powerdns.com/releases/$pkgname-$pkgver.tar.bz2"
|
||||
'pdns-recursor.service'
|
||||
'arm.patch')
|
||||
sha256sums=('192c0b47a1cfcdccaa88d70fd33766a4c381f4223f966416f15e169df5d58eaa'
|
||||
'51688d9576736fdf210048098fa96c8710bfbd6a63eb4d69d20bac57b299b5f9'
|
||||
'ff51af1648d6049f58887ca4f84fa41955ab5df8156d8a00b4b3b148e2bd789f')
|
||||
|
||||
build() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
patch -p5 -i "$srcdir/arm.patch"
|
||||
|
||||
make -j1 LUA=1 \
|
||||
LUA_CPPFLAGS_CONFIG="$(pkg-config --cflags lua5.1)" \
|
||||
LUA_LIBS_CONFIG="$(pkg-config --libs lua5.1)"
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
make SBINDIR="/usr/bin" DESTDIR="$pkgdir" install
|
||||
mv "$pkgdir/etc/powerdns/recursor.conf-dist" \
|
||||
"$pkgdir/etc/powerdns/recursor.conf"
|
||||
rm -r "$pkgdir/etc/init.d"
|
||||
install -Dm644 "$srcdir/pdns-recursor.service" \
|
||||
"$pkgdir/usr/lib/systemd/system/pdns-recursor.service"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,28 +0,0 @@
|
|||
Index: trunk/pdns/pdns/aes/aeskey.c
|
||||
===================================================================
|
||||
--- a/trunk/pdns/pdns/aes/aeskey.c
|
||||
+++ b/trunk/pdns/pdns/aes/aeskey.c
|
||||
@@ -489,4 +489,5 @@
|
||||
}
|
||||
|
||||
+#if 0
|
||||
AES_RETURN aes_decrypt_key256(const unsigned char *key, aes_decrypt_ctx cx[1])
|
||||
{ uint_32t ss[9];
|
||||
@@ -537,4 +538,5 @@
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
+#endif
|
||||
|
||||
#endif
|
||||
@@ -542,4 +544,5 @@
|
||||
#if defined( AES_VAR )
|
||||
|
||||
+#if 0
|
||||
AES_RETURN aes_decrypt_key(const unsigned char *key, int key_len, aes_decrypt_ctx cx[1])
|
||||
{
|
||||
@@ -552,4 +555,5 @@
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
|
||||
#endif
|
|
@ -1,10 +0,0 @@
|
|||
[Unit]
|
||||
Description=PowerDNS recursing nameserver
|
||||
After=network.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/bin/pdns_recursor --daemon
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
|
@ -1,60 +0,0 @@
|
|||
# $Id: PKGBUILD 87427 2013-03-31 19:18:34Z stephane $
|
||||
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
|
||||
# Contributor: Jan de Groot <jgc@archlinux.org>
|
||||
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - need to build with -O1 to get around gcc ICE bug
|
||||
|
||||
pkgname=pdns
|
||||
pkgver=3.3
|
||||
pkgrel=3
|
||||
pkgdesc='Modern, advanced and high performance authoritative-only nameserver'
|
||||
arch=('x86_64' 'i686')
|
||||
url='http://www.powerdns.com/'
|
||||
license=('GPL')
|
||||
depends=('boost-libs' 'gcc-libs' 'postgresql-libs' 'libmariadbclient' 'sqlite' 'libldap' 'lua51')
|
||||
makedepends=('boost')
|
||||
provides=('pdns-ldap' 'pdns-mysql' 'pdns-sqlite' 'pdns-pgsql')
|
||||
replaces=('pdns-ldap' 'pdns-mysql' 'pdns-sqlite' 'pdns-pgsql')
|
||||
conflicts=('pdns-ldap' 'pdns-mysql' 'pdns-sqlite' 'pdns-pgsql')
|
||||
options=('!makeflags')
|
||||
backup=('etc/powerdns/pdns.conf')
|
||||
source=("http://downloads.powerdns.com/releases/$pkgname-$pkgver.tar.gz"
|
||||
'pdns.service'
|
||||
'pdns.conf')
|
||||
sha256sums=('93417bb418ccd1eaf85fc98aa9f687ed175de388fa2624a1978b7cd40dc2b0b6'
|
||||
'b2358a5951ac944feee15ac03d42ffe9c2a72fa6f57746f77ef8997d54a82040'
|
||||
'a1afcccb0d2fb6a6f7a5960de95f8d38ce1ac75ac5e3dcecf09e49f0de10166e')
|
||||
|
||||
prepare() {
|
||||
CFLAGS=`echo $CFLAGS | sed -e 's/-O2/-O1/'` && CXXFLAGS="$CFLAGS"
|
||||
touch "$pkgname-$pkgver/AUTHORS" "$pkgname-$pkgver/NEWS"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc/powerdns \
|
||||
--libexecdir=/usr/lib \
|
||||
--libdir=/usr/lib/powerdns \
|
||||
--mandir=/usr/share/man \
|
||||
--with-modules='' \
|
||||
--with-dynmodules="ldap pipe gmysql gpgsql gsqlite3 geo" \
|
||||
--disable-static \
|
||||
--sbindir=/usr/bin \
|
||||
--bindir=/usr/bin
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
|
||||
install -m644 "$srcdir/pdns.conf" "$pkgdir/etc/powerdns/"
|
||||
install -Dm644 "$srcdir/pdns.service" \
|
||||
"$pkgdir/usr/lib/systemd/system/pdns.service"
|
||||
rm -f "$pkgdir/etc/powerdns/pdns.conf-dist"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,417 +0,0 @@
|
|||
# Autogenerated configuration file template
|
||||
#################################
|
||||
# allow-axfr-ips Allow zonetransfers only to these subnets
|
||||
#
|
||||
# allow-axfr-ips=0.0.0.0/0,::/0
|
||||
|
||||
#################################
|
||||
# allow-recursion List of subnets that are allowed to recurse
|
||||
#
|
||||
allow-recursion=127.0.0.1
|
||||
|
||||
#################################
|
||||
# cache-ttl Seconds to store packets in the PacketCache
|
||||
#
|
||||
cache-ttl=60
|
||||
|
||||
#################################
|
||||
# chroot If set, chroot to this directory for more security
|
||||
#
|
||||
chroot=/var/empty
|
||||
|
||||
#################################
|
||||
# config-dir Location of configuration directory (pdns.conf)
|
||||
#
|
||||
config-dir=/etc
|
||||
|
||||
#################################
|
||||
# config-name Name of this virtual configuration - will rename the binary image
|
||||
#
|
||||
# config-name=
|
||||
|
||||
#################################
|
||||
# control-console Debugging switch - don't use
|
||||
#
|
||||
# control-console=no
|
||||
|
||||
#################################
|
||||
# daemon Operate as a daemon
|
||||
#
|
||||
daemon=yes
|
||||
|
||||
#################################
|
||||
# default-soa-name name to insert in the SOA record if none set in the backend
|
||||
#
|
||||
# default-soa-name=a.misconfigured.powerdns.server
|
||||
|
||||
#################################
|
||||
# default-ttl Seconds a result is valid if not set otherwise
|
||||
#
|
||||
# default-ttl=3600
|
||||
|
||||
#################################
|
||||
# disable-axfr Disable zonetransfers but do allow TCP queries
|
||||
#
|
||||
# disable-axfr=no
|
||||
|
||||
#################################
|
||||
# disable-tcp Do not listen to TCP queries
|
||||
#
|
||||
# disable-tcp=no
|
||||
|
||||
#################################
|
||||
# distributor-threads Default number of Distributor (backend) threads to start
|
||||
#
|
||||
distributor-threads=3
|
||||
|
||||
#################################
|
||||
# do-ipv6-additional-processing Do AAAA additional processing
|
||||
#
|
||||
# do-ipv6-additional-processing=yes
|
||||
|
||||
#################################
|
||||
# edns-subnet-option-number EDNS option number to use
|
||||
#
|
||||
# edns-subnet-option-number=20730
|
||||
|
||||
#################################
|
||||
# edns-subnet-processing If we should act on EDNS Subnet options
|
||||
#
|
||||
# edns-subnet-processing=no
|
||||
|
||||
#################################
|
||||
# entropy-source If set, read entropy from this file
|
||||
#
|
||||
# entropy-source=/dev/urandom
|
||||
|
||||
#################################
|
||||
# experimental-direct-dnskey EXPERIMENTAL: fetch DNSKEY RRs from backend during DNSKEY synthesis
|
||||
#
|
||||
# experimental-direct-dnskey=no
|
||||
|
||||
#################################
|
||||
# experimental-json-interface If the webserver should serve JSON data
|
||||
#
|
||||
# experimental-json-interface=no
|
||||
|
||||
#################################
|
||||
# experimental-logfile Filename of the log file for JSON parser
|
||||
#
|
||||
# experimental-logfile=/var/log/pdns.log
|
||||
|
||||
#################################
|
||||
# fancy-records Process URL and MBOXFW records
|
||||
#
|
||||
# fancy-records=no
|
||||
|
||||
#################################
|
||||
# guardian Run within a guardian process
|
||||
#
|
||||
guardian=yes
|
||||
|
||||
#################################
|
||||
# launch Which backends to launch and order to query them in
|
||||
#
|
||||
# launch=
|
||||
|
||||
#################################
|
||||
# load-modules Load this module - supply absolute or relative path
|
||||
#
|
||||
# load-modules=
|
||||
|
||||
#################################
|
||||
# local-address Local IP addresses to which we bind
|
||||
#
|
||||
local-address=127.0.0.1
|
||||
|
||||
#################################
|
||||
# local-ipv6 Local IP address to which we bind
|
||||
#
|
||||
# local-ipv6=
|
||||
|
||||
#################################
|
||||
# local-port The port on which we listen
|
||||
#
|
||||
local-port=53
|
||||
|
||||
#################################
|
||||
# log-dns-details If PDNS should log DNS non-erroneous details
|
||||
#
|
||||
# log-dns-details=
|
||||
|
||||
#################################
|
||||
# log-dns-queries If PDNS should log all incoming DNS queries
|
||||
#
|
||||
# log-dns-queries=no
|
||||
|
||||
#################################
|
||||
# log-failed-updates If PDNS should log failed update requests
|
||||
#
|
||||
# log-failed-updates=
|
||||
|
||||
#################################
|
||||
# logging-facility Log under a specific facility
|
||||
#
|
||||
# logging-facility=
|
||||
|
||||
#################################
|
||||
# loglevel Amount of logging. Higher is more. Do not set below 3
|
||||
#
|
||||
loglevel=3
|
||||
|
||||
#################################
|
||||
# lua-prequery-script Lua script with prequery handler
|
||||
#
|
||||
# lua-prequery-script=
|
||||
|
||||
#################################
|
||||
# master Act as a master
|
||||
#
|
||||
# master=no
|
||||
|
||||
#################################
|
||||
# max-cache-entries Maximum number of cache entries
|
||||
#
|
||||
# max-cache-entries=1000000
|
||||
|
||||
#################################
|
||||
# max-ent-entries Maximum number of empty non-terminals in a zone
|
||||
#
|
||||
# max-ent-entries=100000
|
||||
|
||||
#################################
|
||||
# max-queue-length Maximum queuelength before considering situation lost
|
||||
#
|
||||
# max-queue-length=5000
|
||||
|
||||
#################################
|
||||
# max-tcp-connections Maximum number of TCP connections
|
||||
#
|
||||
# max-tcp-connections=10
|
||||
|
||||
#################################
|
||||
# module-dir Default directory for modules
|
||||
#
|
||||
module-dir=/usr/lib/powerdns
|
||||
|
||||
#################################
|
||||
# negquery-cache-ttl Seconds to store negative query results in the QueryCache
|
||||
#
|
||||
negquery-cache-ttl=60
|
||||
|
||||
#################################
|
||||
# no-shuffle Set this to prevent random shuffling of answers - for regression testing
|
||||
#
|
||||
# no-shuffle=off
|
||||
|
||||
#################################
|
||||
# out-of-zone-additional-processing Do out of zone additional processing
|
||||
#
|
||||
# out-of-zone-additional-processing=yes
|
||||
|
||||
#################################
|
||||
# overload-queue-length Maximum queuelength moving to packetcache only
|
||||
#
|
||||
# overload-queue-length=0
|
||||
|
||||
#################################
|
||||
# pipebackend-abi-version Version of the pipe backend ABI
|
||||
#
|
||||
# pipebackend-abi-version=1
|
||||
|
||||
#################################
|
||||
# query-cache-ttl Seconds to store query results in the QueryCache
|
||||
#
|
||||
# query-cache-ttl=20
|
||||
|
||||
#################################
|
||||
# query-local-address Source IP address for sending queries
|
||||
#
|
||||
# query-local-address=0.0.0.0
|
||||
|
||||
#################################
|
||||
# query-local-address6 Source IPv6 address for sending queries
|
||||
#
|
||||
# query-local-address6=::
|
||||
|
||||
#################################
|
||||
# query-logging Hint backends that queries should be logged
|
||||
#
|
||||
# query-logging=no
|
||||
|
||||
#################################
|
||||
# queue-limit Maximum number of milliseconds to queue a query
|
||||
#
|
||||
# queue-limit=1500
|
||||
|
||||
#################################
|
||||
# receiver-threads Default number of Distributor (backend) threads to start
|
||||
#
|
||||
# receiver-threads=1
|
||||
|
||||
#################################
|
||||
# recursive-cache-ttl Seconds to store packets for recursive queries in the PacketCache
|
||||
#
|
||||
# recursive-cache-ttl=10
|
||||
|
||||
#################################
|
||||
# recursor If recursion is desired, IP address of a recursing nameserver
|
||||
#
|
||||
# recursor=no
|
||||
|
||||
#################################
|
||||
# retrieval-threads Number of AXFR-retrieval threads for slave operation
|
||||
#
|
||||
# retrieval-threads=2
|
||||
|
||||
#################################
|
||||
# send-root-referral Send out old-fashioned root-referral instead of ServFail in case of no authority
|
||||
#
|
||||
# send-root-referral=no
|
||||
|
||||
#################################
|
||||
# server-id Returned when queried for 'server.id' TXT or NSID, defaults to hostname
|
||||
#
|
||||
# server-id=
|
||||
|
||||
#################################
|
||||
# setgid If set, change group id to this gid for more security
|
||||
#
|
||||
setgid=nobody
|
||||
|
||||
#################################
|
||||
# setuid If set, change user id to this uid for more security
|
||||
#
|
||||
setuid=nobody
|
||||
|
||||
#################################
|
||||
# signing-threads Default number of signer threads to start
|
||||
#
|
||||
# signing-threads=3
|
||||
|
||||
#################################
|
||||
# slave Act as a slave
|
||||
#
|
||||
# slave=no
|
||||
|
||||
#################################
|
||||
# slave-cycle-interval Reschedule failed SOA serial checks once every .. seconds
|
||||
#
|
||||
# slave-cycle-interval=60
|
||||
|
||||
#################################
|
||||
# slave-renotify If we should send out notifications for slaved updates
|
||||
#
|
||||
# slave-renotify=no
|
||||
|
||||
#################################
|
||||
# smtpredirector Our smtpredir MX host
|
||||
#
|
||||
# smtpredirector=a.misconfigured.powerdns.smtp.server
|
||||
|
||||
#################################
|
||||
# soa-expire-default Default SOA expire
|
||||
#
|
||||
# soa-expire-default=604800
|
||||
|
||||
#################################
|
||||
# soa-minimum-ttl Default SOA minimum ttl
|
||||
#
|
||||
# soa-minimum-ttl=3600
|
||||
|
||||
#################################
|
||||
# soa-refresh-default Default SOA refresh
|
||||
#
|
||||
# soa-refresh-default=10800
|
||||
|
||||
#################################
|
||||
# soa-retry-default Default SOA retry
|
||||
#
|
||||
# soa-retry-default=3600
|
||||
|
||||
#################################
|
||||
# soa-serial-offset Make sure that no SOA serial is less than this number
|
||||
#
|
||||
# soa-serial-offset=0
|
||||
|
||||
#################################
|
||||
# socket-dir Where the controlsocket will live
|
||||
#
|
||||
socket-dir=/var/run
|
||||
|
||||
#################################
|
||||
# strict-rfc-axfrs Perform strictly rfc compliant axfrs (very slow)
|
||||
#
|
||||
# strict-rfc-axfrs=no
|
||||
|
||||
#################################
|
||||
# tcp-control-address If set, PowerDNS can be controlled over TCP on this address
|
||||
#
|
||||
# tcp-control-address=
|
||||
|
||||
#################################
|
||||
# tcp-control-port If set, PowerDNS can be controlled over TCP on this address
|
||||
#
|
||||
# tcp-control-port=53000
|
||||
|
||||
#################################
|
||||
# tcp-control-range If set, remote control of PowerDNS is possible over these networks only
|
||||
#
|
||||
# tcp-control-range=127.0.0.0/8, 10.0.0.0/8, 192.168.0.0/16, 172.16.0.0/12, ::1/128, fe80::/10
|
||||
|
||||
#################################
|
||||
# tcp-control-secret If set, PowerDNS can be controlled over TCP after passing this secret
|
||||
#
|
||||
# tcp-control-secret=
|
||||
|
||||
#################################
|
||||
# traceback-handler Enable the traceback handler (Linux only)
|
||||
#
|
||||
# traceback-handler=yes
|
||||
|
||||
#################################
|
||||
# trusted-notification-proxy IP address of incoming notification proxy
|
||||
#
|
||||
# trusted-notification-proxy=
|
||||
|
||||
#################################
|
||||
# urlredirector Where we send hosts to that need to be url redirected
|
||||
#
|
||||
# urlredirector=127.0.0.1
|
||||
|
||||
#################################
|
||||
# version-string PowerDNS version in packets - full, anonymous, powerdns or custom
|
||||
#
|
||||
# version-string=full
|
||||
|
||||
#################################
|
||||
# webserver Start a webserver for monitoring
|
||||
#
|
||||
webserver=no
|
||||
|
||||
#################################
|
||||
# webserver-address IP Address of webserver to listen on
|
||||
#
|
||||
# webserver-address=127.0.0.1
|
||||
|
||||
#################################
|
||||
# webserver-password Password required for accessing the webserver
|
||||
#
|
||||
# webserver-password=
|
||||
|
||||
#################################
|
||||
# webserver-port Port of webserver to listen on
|
||||
#
|
||||
# webserver-port=8081
|
||||
|
||||
#################################
|
||||
# webserver-print-arguments If the webserver should print arguments
|
||||
#
|
||||
# webserver-print-arguments=no
|
||||
|
||||
#################################
|
||||
# wildcard-url Process URL and MBOXFW records
|
||||
#
|
||||
# wildcard-url=no
|
||||
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
[Unit]
|
||||
Description=PowerDNS Authorative Server
|
||||
After=syslog.target network.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/bin/pdns_server --daemon --guardian=yes
|
||||
ExecReload=/usr/bin/pdns_control cycle
|
||||
ExecStop=/usr/bin/pdns_control quit
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
Loading…
Reference in a new issue