community/consul to 1.5.2-1

This commit is contained in:
Kevin Mihelich 2019-06-29 20:32:55 +00:00
parent 8a938fb18c
commit 8f5c175896
4 changed files with 48 additions and 48 deletions

View file

@ -1,4 +1,4 @@
From ea2da7ffd718d4b9d8448fdac97ea5b387ab72d9 Mon Sep 17 00:00:00 2001
From ec190de75ad612a93561d65a11168a544d334bac Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 26 Jun 2018 06:43:01 -0600
Subject: [PATCH] fix ARM build
@ -8,10 +8,10 @@ Subject: [PATCH] fix ARM build
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/GNUmakefile b/GNUmakefile
index 1a89de16..e4e1d97d 100644
index bee271760..7786ac50f 100644
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -119,7 +119,7 @@ changelogfmt:
@@ -137,7 +137,7 @@ changelogfmt:
# linux builds a linux package independent of the source platform
linux:
@ -21,5 +21,5 @@ index 1a89de16..e4e1d97d 100644
# dist builds binaries for all platforms and packages them for distribution
dist:
--
2.17.1
2.21.0

View file

@ -6,7 +6,7 @@
# - remove export GOARCH='amd64'
pkgname=consul
pkgver=1.4.2
pkgver=1.5.2
pkgrel=1
pkgdesc="A tool for service discovery, monitoring and configuration."
arch=('x86_64')
@ -21,24 +21,23 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hashicorp/consul/archiv
'consul.default'
'consul.sysusers'
'example.json'
'consul-ldflags.patch'
'fix-build-version-info.patch'
'disable-syslog-test.patch'
'consul-ldflags.patch'
'unparallelize-or-disable-flaky-tests.patch'
'0001-fix-ARM-build.patch')
'0001-fix-ARM-build.patch'
)
install=consul.install
backup=('etc/default/consul')
sha512sums=('7890626903ae167bddd31eac92da8da56df46c913e4a5e166cec910b749bdf24df4eaa5f9f13f2d0b6ff8f4133a81d85a5b2c90ef52275a4caa752c737b8210f'
sha512sums=('e0820592abc5e119f74c8bf3d11a23726ee6dda7d193864a4486d64deef0bfd6ae4c9170b57d6f978e7ddfeb425229a019c45a8edcdea0938bce9315f2444fd6'
'SKIP'
'c70b9d1556f6c7ecb2e915ab685f289cef0e31198bd2e50c74a0483bbfb387beec67334f539a90adbf68b61b07946e98b300ab8a8e26e53b35f4ab4894adeb04'
'ec5a800529a297c709fa383c094ecf106351cf0f8ac7b613b972d415d77fe001088902d7ab805e63e78a8e6360323fec1b795db5a4446df1e21b9b4ed31e7079'
'ef872aedb2bc022a29292b7972a792b22e684c1ccb904a2b2cfec6d8966c28fb19be1452ce060821c419f1b646b236ba2e783175595e4bb6926d164c27a15c87'
'c4292b8f56ee955ed7385a49843fd90d6434029891b3e1e724cb2fc841514c06e2554a26d3937c114371b18c2168c4e64319eb2cbd726ee8b35870df19089348'
'1d261cc36c3fe617db55d1bfa31354637cdd707bfc803582181e86f64fb8166905b46ba91b326d205392e142ba53deeb6dc1ed8f0f0fefe5201c10773e904b1c'
'64a73277468929c65f7aa3ef1523a5e170b18333129629d5070492e773f63cfdf56ff9a670798d140ef301bece1579bdc881343499b5ea7a0d807c7c95154a2e'
'2a2e31469708f66877885c9e38f2044da13067c4111fc081ffea6187ff39acea6b17c0d33b2d0ada614315c3e5759a7592fbf7b0e9e9094ba2c31003bf1dbd4c'
'8442826050639bf4a8799d5bdeb9778b5dbf45c7c557292209691a08d207ece6106e7f6711ccb1e252b7d1dbbff14f0deb72b4f07e664a304b91092d0afa447b'
'0d779e78bb5f5edafddcc3de1a754a6c39e3ce6dd7aa1387f491803f977b4a7d5e9a1eaa17d212be89109b191c91c2cdf4dd9728cffb3b724b28d20248ce8e12'
'b59b2733d598ae6648c198f26f23961d4c1ea8c693a1a5b1c16a0951400c3bb9a9d2d5efe4f0a5cca9ae3b1f225a8eb4133c9011c4125589e936c7dcdc4b2495'
'b9be57fc21ffccd5083ceccd96937d8d1e83b9e411b0ad1c4b79daad74aa11746afa360b937724cd6d559a9d679774e0abbaefe519bca6ad0b94462c57159f58')
'3f6c2d7e13bb13ee1614463f81a33eedbce8237b2e5189c78e3e12b00c38497a1f17eae8298d3276c4df8bf5e1f950ac62718f6a4ec5c07a94de2210efbc26bc')
prepare() {
export GOPATH="${srcdir}"
@ -72,7 +71,7 @@ check() {
export GOMAXPROCS="2"
export GOOS='linux'
export GOTEST_FLAGS="-p 2 -parallel 2"
export CONSUL_TEST_SKIP_SYSLOG='true'
export TRAVIS='true'
make -j1 test
}

View file

@ -1,24 +1,7 @@
--- a/GNUmakefile 2018-11-14 23:37:47.000000000 +0100
+++ b/GNUmakefile 2019-01-08 15:44:48.494251517 +0100
@@ -29,6 +29,7 @@ GIT_DIRTY?=$(shell test -n "`git status
GIT_DESCRIBE?=$(shell git describe --tags --always)
GIT_IMPORT=github.com/hashicorp/consul/version
GOLDFLAGS=-X $(GIT_IMPORT).GitCommit=$(GIT_COMMIT)$(GIT_DIRTY) -X $(GIT_IMPORT).GitDescribe=$(GIT_DESCRIBE)
+EXTLDFLAGS := ${LDFLAGS}
ifeq ($(FORCE_REBUILD),1)
NOCACHE=--no-cache
@@ -98,6 +99,7 @@ export GIT_DIRTY
export GIT_DESCRIBE
export GOTAGS
export GOLDFLAGS
+export EXTLDFLAGS
DEV_PUSH?=0
--- a/build-support/functions/20-build.sh 2018-11-14 23:37:47.000000000 +0100
+++ b/build-support/functions/20-build.sh 2019-01-08 15:03:55.598451424 +0100
@@ -468,7 +468,7 @@ function build_consul_local {
diff -upr b/build-support/functions/20-build.sh c/build-support/functions/20-build.sh
--- b/build-support/functions/20-build.sh 2019-05-08 20:34:08.000000000 +0200
+++ c/build-support/functions/20-build.sh 2019-05-09 10:39:50.420779679 +0200
@@ -453,7 +453,7 @@ function build_consul_local {
if [ $os == "windows" ];then
binname="consul.exe"
fi
@ -27,3 +10,22 @@
if test $? -ne 0
then
err "ERROR: Failed to build Consul for ${osarch}"
diff -upr b/GNUmakefile c/GNUmakefile
--- b/GNUmakefile 2019-05-09 10:38:41.960775825 +0200
+++ c/GNUmakefile 2019-05-09 10:39:15.477444378 +0200
@@ -22,6 +22,7 @@ GOPATH=$(shell go env GOPATH)
ASSETFS_PATH?=agent/bindata_assetfs.go
GOLDFLAGS=
+EXTLDFLAGS := ${LDFLAGS}
ifeq ($(FORCE_REBUILD),1)
NOCACHE=--no-cache
@@ -90,6 +91,7 @@ export GIT_DIRTY
export GIT_DESCRIBE
export GOTAGS
export GOLDFLAGS
+export EXTLDFLAGS
# Allow skipping docker build during integration tests in CI since we already
# have a built binary

View file

@ -33,23 +33,23 @@
// Strip off any single quotes added by the git information.
return strings.Replace(version, "'", "", -1)
--- b/GNUmakefile 2019-01-08 15:44:48.494251517 +0100
+++ c/GNUmakefile 2019-01-08 15:48:07.639739133 +0100
@@ -23,12 +23,7 @@ GOARCH?=$(shell go env GOARCH)
--- a/GNUmakefile 2019-05-08 20:34:08.000000000 +0200
+++ b/GNUmakefile 2019-05-09 09:55:40.400630733 +0200
@@ -21,12 +21,7 @@ GOARCH?=$(shell go env GOARCH)
GOPATH=$(shell go env GOPATH)
ASSETFS_PATH?=agent/bindata_assetfs.go
-# Get the git commit
-GIT_COMMIT?=$(shell git rev-parse --short HEAD)
-GIT_DIRTY?=$(shell test -n "`git status --porcelain`" && echo "+CHANGES" || true)
-GIT_DESCRIBE?=$(shell git describe --tags --always)
-GIT_DESCRIBE?=$(shell git describe --tags --always --match "v*")
-GIT_IMPORT=github.com/hashicorp/consul/version
-GOLDFLAGS=-X $(GIT_IMPORT).GitCommit=$(GIT_COMMIT)$(GIT_DIRTY) -X $(GIT_IMPORT).GitDescribe=$(GIT_DESCRIBE)
+GOLDFLAGS=
EXTLDFLAGS := ${LDFLAGS}
ifeq ($(FORCE_REBUILD),1)
@@ -238,17 +233,6 @@ ui: ui-legacy-docker ui-docker static-as
NOCACHE=--no-cache
@@ -248,16 +243,6 @@ ui: ui-docker static-assets-docker
tools:
go get -u -v $(GOTOOLS)
@ -63,13 +63,12 @@
- @echo -n "Version + release + git: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh -r -g
-
-
docker-images: go-build-image ui-build-image ui-legacy-build-image
go-build-image:
@@ -276,4 +263,4 @@ ui-legacy-docker: ui-legacy-build-image
docker-images: go-build-image ui-build-image
@@ -286,4 +271,4 @@ proto:
.PHONY: all ci bin dev dist cov test test-ci test-internal test-install-deps cover format vet ui static-assets tools vendorfmt
-.PHONY: docker-images go-build-image ui-build-image ui-legacy-build-image static-assets-docker consul-docker ui-docker ui-legacy-docker version proto
+.PHONY: docker-images go-build-image ui-build-image ui-legacy-build-image static-assets-docker consul-docker ui-docker ui-legacy-docker proto
.PHONY: all ci bin dev dist cov test test-ci test-internal test-install-deps cover format vet ui static-assets tools
.PHONY: docker-images go-build-image ui-build-image static-assets-docker consul-docker ui-docker
-.PHONY: version proto test-envoy-integ
+.PHONY: proto test-envoy-integ