core/linux-mmp to 3.18.48-1

This commit is contained in:
Kevin Mihelich 2017-02-09 01:28:44 +00:00
parent 8b13276aa8
commit 8f8fc53a97
10 changed files with 53 additions and 148 deletions

View file

@ -1,7 +1,7 @@
From 50c47ecd8e145225551e33de572eb4bde84b864a Mon Sep 17 00:00:00 2001
From 9317631a8cbe150cbbe175bf3b1f5fc5d8e1e02f Mon Sep 17 00:00:00 2001
From: Ashokkumar G <0xfee1dead.sa@gmail.com>
Date: Mon, 26 Jan 2015 11:03:08 -0700
Subject: [PATCH 1/9] clk:mmp: Adding clocks of pxa168 peripherals for gplugd
Subject: [PATCH 1/8] clk:mmp: Adding clocks of pxa168 peripherals for gplugd
1. Adding peripherals register address information
2. Changing clock names for sd driver reference sdhci-pxav2
@ -13,7 +13,7 @@ Signed-off-by: Ashokkumar G <0xfee1dead.sa@gmail.com>
1 file changed, 191 insertions(+), 50 deletions(-)
diff --git a/drivers/clk/mmp/clk-pxa168.c b/drivers/clk/mmp/clk-pxa168.c
index 014396b..39a80fb 100644
index 014396b028a2..39a80fb2aefa 100644
--- a/drivers/clk/mmp/clk-pxa168.c
+++ b/drivers/clk/mmp/clk-pxa168.c
@@ -20,30 +20,137 @@
@ -335,5 +335,5 @@ index 014396b..39a80fb 100644
+ clk_register_clkdev(clk, NULL, "pxa168-eth");
}
--
2.10.2
2.11.1

View file

@ -1,7 +1,7 @@
From e43cc7d091352f82d2fda3439a68e2c5d03420c0 Mon Sep 17 00:00:00 2001
From 26da78dc5a7b8b35ff6abbdca10f77b08c972a1c Mon Sep 17 00:00:00 2001
From: Ashokkumar G <0xfee1dead.sa@gmail.com>
Date: Mon, 27 Jan 2014 09:26:20 -0700
Subject: [PATCH 2/9] arch:arm:mmp: initialize gpio driver before other drivers
Subject: [PATCH 2/8] arch:arm:mmp: initialize gpio driver before other drivers
Add gpio driver for pxa168 based gplugd before adding other
peripheral drivers to boot properly.
@ -12,7 +12,7 @@ Add I2C information while initializing TWSI
1 file changed, 9 insertions(+), 4 deletions(-)
diff --git a/arch/arm/mach-mmp/gplugd.c b/arch/arm/mach-mmp/gplugd.c
index d81b247..83a7019 100644
index d81b2475e67e..83a7019b14f9 100644
--- a/arch/arm/mach-mmp/gplugd.c
+++ b/arch/arm/mach-mmp/gplugd.c
@@ -133,6 +133,10 @@ static struct pxa_gpio_platform_data pxa168_gpio_pdata = {
@ -49,5 +49,5 @@ index d81b247..83a7019 100644
pxa168_add_eth(&gplugd_eth_platform_data);
}
--
2.10.2
2.11.1

View file

@ -1,7 +1,7 @@
From 13c6324acbf65678412415d6c0272878bc02dea8 Mon Sep 17 00:00:00 2001
From ec43224b350802d1e5aa2e6254534ee4605fb6dc Mon Sep 17 00:00:00 2001
From: Ashokkumar G <0xfee1dead.sa@gmail.com>
Date: Mon, 27 Jan 2014 09:47:06 -0700
Subject: [PATCH 3/9] arch:arm:mmp: Adding spi master and mtd dataflash for
Subject: [PATCH 3/8] arch:arm:mmp: Adding spi master and mtd dataflash for
gplugd
1. Adding SPI master for gplugd
@ -11,7 +11,7 @@ Subject: [PATCH 3/9] arch:arm:mmp: Adding spi master and mtd dataflash for
1 file changed, 48 insertions(+)
diff --git a/arch/arm/mach-mmp/gplugd.c b/arch/arm/mach-mmp/gplugd.c
index 83a7019..9c441e1 100644
index 83a7019b14f9..9c441e1b3159 100644
--- a/arch/arm/mach-mmp/gplugd.c
+++ b/arch/arm/mach-mmp/gplugd.c
@@ -12,6 +12,8 @@
@ -89,5 +89,5 @@ index 83a7019..9c441e1 100644
MACHINE_START(GPLUGD, "PXA168-based GuruPlug Display (gplugD) Platform")
--
2.10.2
2.11.1

View file

@ -1,7 +1,7 @@
From 1f105cbfcbd629d29bdbad20199129e7cf964caa Mon Sep 17 00:00:00 2001
From 51513e290a1df59f6fc59086dfab5b34c5a54c3c Mon Sep 17 00:00:00 2001
From: Ashokkumar G <0xfee1dead.sa@gmail.com>
Date: Mon, 26 Jan 2015 11:08:19 -0700
Subject: [PATCH 4/9] drivers:spi: Adding mmp dependency for SPI_PXA2XX
Subject: [PATCH 4/8] drivers:spi: Adding mmp dependency for SPI_PXA2XX
adding arch_mmp dependency for SPI_PXA2XX as pxa168 based gplugd
uses SPI_PXA2XX
@ -15,7 +15,7 @@ Signed-off-by: Ashokkumar G <0xfee1dead.sa@gmail.com>
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
index 84e7c9e..caa969f 100644
index 84e7c9e6ccef..caa969f64ff4 100644
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
@@ -383,8 +383,8 @@ config SPI_PXA2XX_DMA
@ -30,5 +30,5 @@ index 84e7c9e..caa969f 100644
This enables using a PXA2xx or Sodaville SSP port as a SPI master
controller. The driver can be configured to use any SSP port and
--
2.10.2
2.11.1

View file

@ -1,7 +1,7 @@
From 495551c342fe06cec9a3c1af632b26d10639b153 Mon Sep 17 00:00:00 2001
From 337a000bdf03d6c9bc093ca29c47c86777367b03 Mon Sep 17 00:00:00 2001
From: Ashokkumar G <0xfee1dead.sa@gmail.com>
Date: Mon, 26 Jan 2015 11:28:52 -0700
Subject: [PATCH 5/9] mmp:ethernet: Adding ethernet MAC address reading for
Subject: [PATCH 5/8] mmp:ethernet: Adding ethernet MAC address reading for
gplugd
Currently Marvell's pxa168 ethernet driver uses random MAC address
@ -17,7 +17,7 @@ Signed-off-by: Ashokkumar G <0xfee1dead.sa@gmail.com>
3 files changed, 116 insertions(+), 24 deletions(-)
diff --git a/arch/arm/mach-mmp/gplugd.c b/arch/arm/mach-mmp/gplugd.c
index 9c441e1..2981c88 100644
index 9c441e1b3159..2981c8878ee7 100644
--- a/arch/arm/mach-mmp/gplugd.c
+++ b/arch/arm/mach-mmp/gplugd.c
@@ -22,6 +22,8 @@
@ -184,7 +184,7 @@ index 9c441e1..2981c88 100644
MACHINE_START(GPLUGD, "PXA168-based GuruPlug Display (gplugD) Platform")
diff --git a/drivers/net/ethernet/marvell/pxa168_eth.c b/drivers/net/ethernet/marvell/pxa168_eth.c
index c3b209c..9cb99ab 100644
index c3b209cd0660..9cb99ab9fa47 100644
--- a/drivers/net/ethernet/marvell/pxa168_eth.c
+++ b/drivers/net/ethernet/marvell/pxa168_eth.c
@@ -1552,6 +1552,11 @@ static int pxa168_eth_probe(struct platform_device *pdev)
@ -200,7 +200,7 @@ index c3b209c..9cb99ab 100644
of_property_read_u32(pdev->dev.of_node, "port-id",
&pep->port_num);
diff --git a/include/linux/pxa168_eth.h b/include/linux/pxa168_eth.h
index 18d75e7..ca94155 100644
index 18d75e795606..ca941555d9b8 100644
--- a/include/linux/pxa168_eth.h
+++ b/include/linux/pxa168_eth.h
@@ -20,11 +20,14 @@ struct pxa168_eth_platform_data {
@ -219,5 +219,5 @@ index 18d75e7..ca94155 100644
#endif /* __LINUX_PXA168_ETH_H */
--
2.10.2
2.11.1

View file

@ -1,7 +1,7 @@
From 0e9da541d71f8f60362d43d78ff915fc61c4f05f Mon Sep 17 00:00:00 2001
From c579ae912ed07193048f88c4fb77df5bf9f96e9e Mon Sep 17 00:00:00 2001
From: Ashokkumar G <0xfee1dead.sa@gmail.com>
Date: Mon, 26 Jan 2015 11:40:41 -0700
Subject: [PATCH 6/9] mmp:mmc: adding sdhc support for pxa168 based gplugd
Subject: [PATCH 6/8] mmp:mmc: adding sdhc support for pxa168 based gplugd
Fixing can't talk to controller for sdhci PXAV2
@ -20,7 +20,7 @@ Signed-off-by: Ashokkumar G <0xfee1dead.sa@gmail.com>
6 files changed, 54 insertions(+), 3 deletions(-)
diff --git a/arch/arm/mach-mmp/Kconfig b/arch/arm/mach-mmp/Kconfig
index ebdba87..5843def 100644
index ebdba87b9671..5843def24351 100644
--- a/arch/arm/mach-mmp/Kconfig
+++ b/arch/arm/mach-mmp/Kconfig
@@ -80,6 +80,7 @@ config MACH_TETON_BGA
@ -32,7 +32,7 @@ index ebdba87..5843def 100644
Say 'Y' here if you want to support the Marvell PXA168-based
GuruPlug Display (gplugD) Board
diff --git a/arch/arm/mach-mmp/gplugd.c b/arch/arm/mach-mmp/gplugd.c
index 2981c88..ba4ce4e 100644
index 2981c8878ee7..ba4ce4e63bbe 100644
--- a/arch/arm/mach-mmp/gplugd.c
+++ b/arch/arm/mach-mmp/gplugd.c
@@ -12,6 +12,7 @@
@ -65,7 +65,7 @@ index 2981c88..ba4ce4e 100644
}
diff --git a/arch/arm/mach-mmp/include/mach/pxa168.h b/arch/arm/mach-mmp/include/mach/pxa168.h
index a83ba7c..def8f46 100644
index a83ba7cb525d..def8f462943d 100644
--- a/arch/arm/mach-mmp/include/mach/pxa168.h
+++ b/arch/arm/mach-mmp/include/mach/pxa168.h
@@ -17,6 +17,7 @@ extern void pxa168_clear_keypad_wakeup(void);
@ -109,7 +109,7 @@ index a83ba7c..def8f46 100644
+}
#endif /* __ASM_MACH_PXA168_H */
diff --git a/arch/arm/mach-mmp/pxa168.c b/arch/arm/mach-mmp/pxa168.c
index 144e997..e7dee43 100644
index 144e997624c0..e7dee43e6458 100644
--- a/arch/arm/mach-mmp/pxa168.c
+++ b/arch/arm/mach-mmp/pxa168.c
@@ -110,6 +110,10 @@ PXA168_DEVICE(ssp5, "pxa168-ssp", 4, SSP5, 0xd4021000, 0x40, 60, 61);
@ -124,7 +124,7 @@ index 144e997..e7dee43 100644
struct resource pxa168_resource_gpio[] = {
{
diff --git a/drivers/mmc/host/Kconfig b/drivers/mmc/host/Kconfig
index 1386065..02f8e4d 100644
index 13860656104b..02f8e4d08854 100644
--- a/drivers/mmc/host/Kconfig
+++ b/drivers/mmc/host/Kconfig
@@ -240,7 +240,9 @@ config MMC_SDHCI_PXAV2
@ -139,7 +139,7 @@ index 1386065..02f8e4d 100644
This selects the Marvell(R) PXAV2 SD Host Controller.
If you have a PXA9XX platform with SD Host Controller
diff --git a/drivers/mmc/host/sdhci-pxav2.c b/drivers/mmc/host/sdhci-pxav2.c
index b4c23e9..f0f36c9 100644
index b4c23e983baf..f0f36c9a803a 100644
--- a/drivers/mmc/host/sdhci-pxav2.c
+++ b/drivers/mmc/host/sdhci-pxav2.c
@@ -111,7 +111,24 @@ static void pxav2_mmc_set_bus_width(struct sdhci_host *host, int width)
@ -177,5 +177,5 @@ index b4c23e9..f0f36c9 100644
dev_err(dev, "failed to get io clock\n");
ret = PTR_ERR(clk);
--
2.10.2
2.11.1

View file

@ -1,7 +1,7 @@
From 17ec3d3ac862cf798485230c032eeb911afa642a Mon Sep 17 00:00:00 2001
From a6f38febc45ec93258617efd526d82b6a11996a2 Mon Sep 17 00:00:00 2001
From: Ashokkumar G <0xfee1dead.sa@gmail.com>
Date: Mon, 26 Jan 2015 11:51:13 -0700
Subject: [PATCH 7/9] arch:arm:mmp: Adding USB Host and OTG peripheral for
Subject: [PATCH 7/8] arch:arm:mmp: Adding USB Host and OTG peripheral for
pxa168
Adding USB host, USB OTG peripherals memory, register information
@ -17,7 +17,7 @@ Signed-off-by: Ashokkumar G <0xfee1dead.sa@gmail.com>
3 files changed, 103 insertions(+)
diff --git a/arch/arm/mach-mmp/devices.c b/arch/arm/mach-mmp/devices.c
index 2bcb766..7d8499f 100644
index 2bcb766af05d..7d8499f9c34c 100644
--- a/arch/arm/mach-mmp/devices.c
+++ b/arch/arm/mach-mmp/devices.c
@@ -241,6 +241,41 @@ void pxa_usb_phy_deinit(void __iomem *phy_reg)
@ -63,7 +63,7 @@ index 2bcb766..7d8499f 100644
struct resource pxa168_u2o_resources[] = {
/* regbase */
diff --git a/arch/arm/mach-mmp/gplugd.c b/arch/arm/mach-mmp/gplugd.c
index ba4ce4e..b9c3c92 100644
index ba4ce4e63bbe..b9c3c9257eec 100644
--- a/arch/arm/mach-mmp/gplugd.c
+++ b/arch/arm/mach-mmp/gplugd.c
@@ -173,6 +173,56 @@ static void __init select_disp_freq(void)
@ -145,7 +145,7 @@ index ba4ce4e..b9c3c92 100644
}
diff --git a/arch/arm/mach-mmp/include/mach/pxa168.h b/arch/arm/mach-mmp/include/mach/pxa168.h
index def8f46..feed849 100644
index def8f462943d..feed849620c1 100644
--- a/arch/arm/mach-mmp/include/mach/pxa168.h
+++ b/arch/arm/mach-mmp/include/mach/pxa168.h
@@ -42,6 +42,10 @@ extern struct pxa_device_desc pxa168_device_sdh1;
@ -160,5 +160,5 @@ index def8f46..feed849 100644
extern int __init pxa168_add_usb_host(struct mv_usb_platform_data *pdata);
--
2.10.2
2.11.1

View file

@ -1,7 +1,7 @@
From f25bccd3f00f61ffffef99dc2e55770095c81c19 Mon Sep 17 00:00:00 2001
From a61956a6d7e63a2870151dd434b1236a189ad31a Mon Sep 17 00:00:00 2001
From: Ashokkumar G <0xfee1dead.sa@gmail.com>
Date: Mon, 26 Jan 2015 12:08:26 -0700
Subject: [PATCH 8/9] arch:arm:mmp:gplugd: Fix gPlugD reboot issue
Subject: [PATCH 8/8] arch:arm:mmp:gplugd: Fix gPlugD reboot issue
Board hangs in u-boot after issuing reboot related
commands from Linux console due to not resetting
@ -17,7 +17,7 @@ Signed-off-by: Ashokkumar G <0xfee1dead.sa@gmail.com>
create mode 100644 arch/arm/mach-mmp/include/mach/regs-mpmu.h
diff --git a/arch/arm/mach-mmp/gplugd.c b/arch/arm/mach-mmp/gplugd.c
index b9c3c92..ec4257e 100644
index b9c3c9257eec..ec4257ee1d60 100644
--- a/arch/arm/mach-mmp/gplugd.c
+++ b/arch/arm/mach-mmp/gplugd.c
@@ -22,6 +22,8 @@
@ -76,7 +76,7 @@ index b9c3c92..ec4257e 100644
MACHINE_END
diff --git a/arch/arm/mach-mmp/include/mach/regs-mpmu.h b/arch/arm/mach-mmp/include/mach/regs-mpmu.h
new file mode 100644
index 0000000..91ecb78
index 000000000000..91ecb7899ff0
--- /dev/null
+++ b/arch/arm/mach-mmp/include/mach/regs-mpmu.h
@@ -0,0 +1,62 @@
@ -143,5 +143,5 @@ index 0000000..91ecb78
+
+#endif /* __ASM_MACH_REGS_APMU_H */
--
2.10.2
2.11.1

View file

@ -1,92 +0,0 @@
From 061da405aa4108735134e85191dc48467f6dec35 Mon Sep 17 00:00:00 2001
From: Philip Pettersson <philip.pettersson@gmail.com>
Date: Wed, 30 Nov 2016 14:55:36 -0800
Subject: [PATCH 9/9] packet: fix race condition in packet_set_ring
When packet_set_ring creates a ring buffer it will initialize a
struct timer_list if the packet version is TPACKET_V3. This value
can then be raced by a different thread calling setsockopt to
set the version to TPACKET_V1 before packet_set_ring has finished.
This leads to a use-after-free on a function pointer in the
struct timer_list when the socket is closed as the previously
initialized timer will not be deleted.
The bug is fixed by taking lock_sock(sk) in packet_setsockopt when
changing the packet version while also taking the lock at the start
of packet_set_ring.
Fixes: f6fb8f100b80 ("af-packet: TPACKET_V3 flexible buffer implementation.")
Signed-off-by: Philip Pettersson <philip.pettersson@gmail.com>
Signed-off-by: Eric Dumazet <edumazet@google.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/packet/af_packet.c | 18 ++++++++++++------
1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
index e73b3fb..abffc15 100644
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
@@ -3281,19 +3281,25 @@ packet_setsockopt(struct socket *sock, int level, int optname, char __user *optv
if (optlen != sizeof(val))
return -EINVAL;
- if (po->rx_ring.pg_vec || po->tx_ring.pg_vec)
- return -EBUSY;
if (copy_from_user(&val, optval, sizeof(val)))
return -EFAULT;
switch (val) {
case TPACKET_V1:
case TPACKET_V2:
case TPACKET_V3:
- po->tp_version = val;
- return 0;
+ break;
default:
return -EINVAL;
}
+ lock_sock(sk);
+ if (po->rx_ring.pg_vec || po->tx_ring.pg_vec) {
+ ret = -EBUSY;
+ } else {
+ po->tp_version = val;
+ ret = 0;
+ }
+ release_sock(sk);
+ return ret;
}
case PACKET_RESERVE:
{
@@ -3756,6 +3762,7 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
/* Added to avoid minimal code churn */
struct tpacket_req *req = &req_u->req;
+ lock_sock(sk);
/* Opening a Tx-ring is NOT supported in TPACKET_V3 */
if (!closing && tx_ring && (po->tp_version > TPACKET_V2)) {
WARN(1, "Tx-ring is not supported.\n");
@@ -3837,7 +3844,6 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
goto out;
}
- lock_sock(sk);
/* Detach socket from network */
spin_lock(&po->bind_lock);
@@ -3886,11 +3892,11 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
if (!tx_ring)
prb_shutdown_retire_blk_timer(po, tx_ring, rb_queue);
}
- release_sock(sk);
if (pg_vec)
free_pg_vec(pg_vec, order, req->tp_block_nr);
out:
+ release_sock(sk);
return err;
}
--
2.10.2

View file

@ -7,8 +7,8 @@ pkgbase=linux-mmp
_srcname=linux-3.18
_kernelname=${pkgbase#linux}
_desc="Marvell PXA168/MMP platforms"
pkgver=3.18.45
pkgrel=2
pkgver=3.18.48
pkgrel=1
arch=('arm')
url="https://github.com/Marvell-Semi/PXA168_kernel/tree/gplugd-dev"
license=('GPL2')
@ -24,19 +24,17 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'0006-mmp-mmc-adding-sdhc-support-for-pxa168-based-gplugd.patch'
'0007-arch-arm-mmp-Adding-USB-Host-and-OTG-peripheral-for-.patch'
'0008-arch-arm-mmp-gplugd-Fix-gPlugD-reboot-issue.patch'
'0009-packet-fix-race-condition-in-packet_set_ring.patch'
'config')
md5sums=('9e854df51ca3fef8bfe566dbd7b89241'
'46375e6ec7ed50e9497390c1f6bb92b3'
'e505809b8ff9f233986ab0797a8932fc'
'1c33a3d7c9dcb256e288f1f679c595df'
'f56073b69e187d97119cc2b1d947ff13'
'bbc148c838fef6bc255ca12ed6c32d3a'
'4048860d050595f333c143f5c00caa00'
'de8fd3a885883dc75be987dd534cffbf'
'2ac5d79b6aef4243aeef43f0e1aaa81e'
'01a8473817232b928de05ad05743aabc'
'eb616d6ad2bdd44b1136220adadd8330'
'a69580d890a748c36f392a04b743518f'
'a862b5c347732e805e783f9c91c42a1b'
'9f8a35ab6d94fde54316f6b6d5c7c0d5'
'19cdd5b19a776324bf090ca5f9751191'
'58a3e2d8b80af4a4756a4eb21a84dd29'
'c9613a74ce8b96dbe4a58e977bf0ef36'
'9563d0258c1ccfe1efb8857b25cb59c3'
'a6ecde1aedf42fc4ffb79f72c920bcec'
'58c4cf02f9cbfcb423dedf424f8aa12f'
'402813a242ce345758a31518f9cd8573')
prepare() {
@ -54,7 +52,6 @@ prepare() {
git apply ../0006-mmp-mmc-adding-sdhc-support-for-pxa168-based-gplugd.patch
git apply ../0007-arch-arm-mmp-Adding-USB-Host-and-OTG-peripheral-for-.patch
git apply ../0008-arch-arm-mmp-gplugd-Fix-gPlugD-reboot-issue.patch
git apply ../0009-packet-fix-race-condition-in-packet_set_ring.patch
cat "${srcdir}/config" > ./.config