alarm/xf86-video-armsoc-rockchip to 260.1b499f5-1

This commit is contained in:
Kevin Mihelich 2015-07-03 01:11:49 +00:00
parent 71bdba1e3d
commit 8fdce48518
2 changed files with 4 additions and 37 deletions

View file

@ -1,26 +0,0 @@
From de6b51ae1dc02ecb48cb9642af31dd2d27d3ae04 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 26 Jun 2015 21:31:12 -0600
Subject: [PATCH] drmmode_display: include sys/stat.h
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
src/drmmode_display.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/drmmode_display.c b/src/drmmode_display.c
index 58c1a84..cf64424 100644
--- a/src/drmmode_display.c
+++ b/src/drmmode_display.c
@@ -51,6 +51,8 @@
#include <libudev.h>
#include "drmmode_driver.h"
+#include <sys/stat.h>
+
struct drmmode_cursor_rec {
/* hardware cursor: */
struct armsoc_bo *bo;
--
2.4.4

View file

@ -3,8 +3,8 @@
buildarch=4
pkgname=xf86-video-armsoc-rockchip
_commit=a095d0437af074701fb5ff02b3b986f8986dd128
pkgver=258.a095d04
_commit=1b499f5ea1f19d514faeeb0ebb9d1056392844b9
pkgver=260.1b499f5
pkgrel=1
pkgdesc='X.org graphics driver for ARM graphics - Rockchip'
arch=('armv7h')
@ -14,21 +14,14 @@ makedepends=('git' 'pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverpro
options=('!libtool')
conflicts=(xf86-video-armsoc)
provides=(xf86-video-armsoc)
source=("$pkgname::git+https://github.com/mmind/xf86-video-armsoc.git#commit=${_commit}"
'0001-drmmode_display-include-sys-stat.h.patch')
md5sums=('SKIP'
'89c59460f599996b0ac5669c0762567e')
source=("$pkgname::git+https://github.com/mmind/xf86-video-armsoc.git#commit=${_commit}")
md5sums=('SKIP')
pkgver() {
cd $pkgname
echo $(git rev-list --count makepkg).$(git rev-parse --short makepkg)
}
prepare() {
cd $pkgname
git apply ../0001-drmmode_display-include-sys-stat.h.patch
}
build() {
cd $pkgname